Unable to restore from snapshot using inbuilt tools

Output of garuda-inxi is given below. I have booted into a recovery snapshot and read the wiki entry for restoring snapshots here. On login to Sway I am prompted to restore the snapshot. Tapping yes does not restore the snapshot. I have tested this by rebooting my system. I attempted to manually run BTRFS Assistant from the launcher but it did not launch. Attempting to launch the Assistant from a terminal gives me the same output as this post. So I cannot manually open any GUI to my snapshots.

I then attempted to follow the format of this post to manually restore my snapshot with the CLI but the first command given to restore the snapshot, sudo mkdir -p /mnt/btrfs, is not available to me because I am inside a read-only snapshot.

It's been a long time since I've done a manual CLI restore: is anyone able to offer assistance?

> sudo btrfs subvolume list /
ID 256 gen 78726 top level 5 path @
ID 257 gen 78790 top level 5 path @home
ID 258 gen 78757 top level 5 path @root
ID 259 gen 7010 top level 5 path @srv
ID 260 gen 78723 top level 5 path @cache
ID 261 gen 78790 top level 5 path @log
ID 262 gen 78750 top level 5 path @tmp
ID 263 gen 78727 top level 256 path @/.snapshots
ID 650 gen 77760 top level 263 path @/.snapshots/387/snapshot
ID 651 gen 77761 top level 263 path @/.snapshots/388/snapshot
ID 652 gen 78153 top level 263 path @/.snapshots/389/snapshot
ID 653 gen 78155 top level 263 path @/.snapshots/390/snapshot
ID 654 gen 78159 top level 263 path @/.snapshots/391/snapshot
ID 655 gen 78160 top level 263 path @/.snapshots/392/snapshot
ID 656 gen 78166 top level 263 path @/.snapshots/393/snapshot
ID 657 gen 78167 top level 263 path @/.snapshots/394/snapshot
ID 658 gen 78368 top level 263 path @/.snapshots/395/snapshot
ID 659 gen 78372 top level 263 path @/.snapshots/396/snapshot
ID 660 gen 78374 top level 263 path @/.snapshots/397/snapshot
ID 661 gen 78733 top level 263 path @/.snapshots/398/snapshot
> findmnt /
TARGET SOURCE                                                          FSTYPE OPTIONS
/      /dev/disk/by-uuid/17ceaa88-b5db-494e-98cc-9c25749bf034[/@/.snapshots/398/snapshot]
                                                                       btrfs  rw,noat
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_ADDRESS = "en_DK.UTF-8",
	LC_NAME = "en_DK.UTF-8",
	LC_MONETARY = "en_DK.UTF-8",
	LC_PAPER = "en_DK.UTF-8",
	LC_IDENTIFICATION = "en_DK.UTF-8",
	LC_TELEPHONE = "en_DK.UTF-8",
	LC_MEASUREMENT = "en_DK.UTF-8",
	LC_TIME = "en_DK.UTF-8",
	LC_NUMERIC = "en_DK.UTF-8",
	LANG = "en_DK.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.19.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/.snapshots/398/snapshot/boot/vmlinuz-linux-zen
    root=UUID=17ceaa88-b5db-494e-98cc-9c25749bf034 quiet
    rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=9aac1dcd-b6e2-4126-b1a9-56b6116f8582 loglevel=3
    mem_sleep_default=deep intel_pstate=disable
    rootflags=defaults,noatime,noautodefrag,compress=zstd,[email protected]/.snapshots/398/snapshot
  Desktop: sway v: 1.7 info: waybar vt: 1 dm: greetd Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9380 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0KTW76 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.16.1 date: 10/07/2021
Battery:
  ID-1: BAT0 charge: 26.3 Wh (56.4%) condition: 46.6/52.0 Wh (89.7%)
    volts: 8.2 min: 7.6 model: LGC-LGC6.73 DELL H754V8C type: Li-ion
    serial: <filter> status: charging
CPU:
  Info: model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Whiskey Lake
    gen: core 8 built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xB (11) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3095 high: 4131 min/max: 400/2001 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2001 2: 3600
    3: 3831 4: 3600 5: 400 6: 3600 7: 4131 8: 3600 bogomips: 31999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0
    chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 0c45:6723 class-ID: 0e02
  Display: wayland server: Xwayland v: 22.1.3 compositor: sway v: 1.7
    driver: gpu: i915 display-ID: 1
  Monitor-1: eDP-1 model: AU Optronics 0x5b2d built: 2018 res: 1920x1080
    hz: 60 dpi: 166 gamma: 1.2 scale: 1 size: 293x162mm (11.54x6.38")
    diag: 335mm (13.2") ratio: 16:9 modes: 1920x1080
  Message: Wayland GBM/EGL data currently not available.
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:9dc8 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.8-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:003e
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
Bluetooth:
  Device-1: Foxconn / Hon Hai type: USB driver: btusb v: 0.8 bus-ID: 1-7:3
    chip-ID: 0489:e0a2 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 82.83 GiB (17.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC401 NVMe
    512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 80007E00
    temp: 39.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 459.83 GiB size: 459.83 GiB (100.00%) used: 82.78 GiB
    (18.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 54 MiB
    (18.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 459.83 GiB size: 459.83 GiB (100.00%) used: 82.78
    GiB (18.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 459.83 GiB size: 459.83 GiB (100.00%) used: 82.78
    GiB (18.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 459.83 GiB size: 459.83 GiB (100.00%) used: 82.78
    GiB (18.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.28 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 16.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 49.0 C pch: 46.0 C mobo: 39.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
  Processes: 243 Uptime: 25m wakeups: 49 Memory: 15.28 GiB used: 4.83 GiB
  (31.6%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1358 nix-default: 0
  nix-sys: 0 nix-usr: 0 pacman: 1353 lib: 326 flatpak: 5 Shell: fish v: 3.5.1
  running-in: alacritty inxi: 3.3.20
Garuda (2.6.7-1):
  System install date:     2021-12-08
  Last full system update: 2022-09-13
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            auto-cpufreq.service garuda-pacman-lock.service garuda-pacman-snapshot-reject.service snapd.failure.service snapd.service systemd-guest-user.service snapd.socket

Try this:

sudo -E btrfs-assistant-bin
5 Likes

Please fix the wrapper xD

Feel free to submit a MR if my timeline for addressing it isn't fast enough for you.

7 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.