Unable to restore from grub timeshift

Hi Please advise.

My system will not restore from timeshift options in GRUB.
I was installing Master PDF Editor 5 with pacman and chose the option for the dependancies,
All was going well until a got a message that read "disk full"
The disk was not full and I couldnt access any thing -as though the system froze. The only thing that moved was the cursor.

So as I couldnt do anything, Id restore from GRUB timeshift.
I chose the latest snapshot, hit enter and 45 minutes later, the white progress marker no longer moves.

As I cannot get into a command prompt, I cannot type in the inxi thingy,
I have retired earlier restor points with the same result - the progress bar just hangs.

Not sure what to do as I cannot get into the system.
I tried some commands in the GRUB command but it only lists a few basic commands,

Please could you advise. Thank you

Read

please
and post

inxi -Fza

as text!

Even if you personally think it is unnecessary.

Try other snapshots too, if their other.

If this not help, did you install or build Master PDF Editor 5?

Use live ISO for chroot and try to update / rescue your data the system.

3 Likes

Have you tried chrooting from a live USB into your system (e.g. follow How to chroot Garuda Linux ) then free up some space if necessary. I think you can also reach your snapshots from the timeshift in the USB and delete old unneded snapshots.

2 Likes

Today we read each other's minds :blush:

3 Likes

I tried about 4 options. I tried the failsafe options in the snapshots.

1 Like

Whew thank you.
I have never tried chroot - but a first for eveything.
Ill give it try tomoro - have a meeting now and will post my results.

Thank you

If you only need to delete or save your data, probably the live USB is enough.
With chroot you should be able to update your system, uninstall, etc... just like if you were in your normal system.

The disk isnt actually full so I need to go and see what is wrong.
Time I learnt how to chroot. Appreciate the heads up. :ok_hand: :+1:

2 Likes

Okay, good morning.
After reading how to chroot Garuda Linux I did the following:
sudo mkdir -p /mnt/broken (This executed no problem)
sudo mount /dev/sda3 /mnt/broken
mount: /mnt/broken: can't read superblock on /dev/sda3.

So this is where I am now stuck. Please help. Thanks

Maybe you could try sudo fsck /dev/sda3 (just a desperate try, I have no other ideas)

fsck from util-linux 2.37
If you wish to check the consistency of a BTRFS filesystem or
repair a damaged filesystem, see btrfs(8) subcommand 'check'.

This is the reply. How do I say that in terminal. I tried -check after the command???

Okay so I tried that with "btrfs check /dev/sda3"
ERROR: mount check: cannot open /dev/sda3: Permission denied
ERROR: could not check mount status: Permission denied

So no progress yet - any advice

Sorry, my bad, I should really avoid answering too quickly without thinking...
it is sudo btrfs check.
Please check carefully:
https://btrfs.wiki.kernel.org/index.php/Btrfsck
https://wiki.archlinux.org/title/Btrfs#btrfs_check
https://www.man7.org/linux/man-pages/man8/btrfs-check.8.html

1 Like

I think you have to use sudo and make sure that the partition is unmounted

my error thank you - I didnt use sudo.
So tried again and got over 100 "root 486 inode 859744 errors 2001, no inode item, link count wrong
unresolved ref dir 218323 index 4351 namelen 10 name timestamps filetype 1 errors 4, no inode ref" messages.
Also got the following:
ERROR: errors found in fs roots
found 32967643136 bytes used, error(s) found
total csum bytes: 30371416
total tree bytes: 689061888
total fs tree bytes: 609189888
total extent tree bytes: 39501824
btree space waste bytes: 124991599
file data blocks allocated: 996641492992
referenced 51977793536.

Looks like something is truly messed.

Auch, that really looks like corrupted or the like.
Quite frankly now this is getting too far from my reach.
I hope someone more experienced will jump in with any kind of suggestions.

Try

btrfs check --repair
4 Likes

Thanks so much. Also good to test your skills and expand them by helping others. Ill keep on posting even if it means a format :see_no_evil:

1 Like

Was scared to try this cos they give a strict warning - DO NOT TRY THIS UNLESS etc.

HOWEVER, Im past playing, so I hit enter and the terminal goes crazy.
deleting dir index - thousands of lines
Repairing something dir index - thousands of lines
2 hours later it stops.

Okay so I dont know enough commands to be fiddling in chroot so I reboot (otherwise I was going to format) and VOILA!!! it boots in to my GARUDA.
I must just run one or 2 checks, maybe Ill use an earlier snapshot and repair like.

A big thank you to all who gave input. My system is up and running. Not a journey I want to go through again - but I suppose thats the way we learn.

Thanks again for Assistance

Regards

2 Likes

I mark it solved!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.