Unable to install Nvidia Drivers

Hello, i'm having an error in downloading my graphics driver (Nvidia)
Would love to get some help
My Specs:

-CPU- AMD Ryzen 7 2700x
-GPU- GeForce GTX 1060 3GB
-RAM- G.Skill Ripjaws V 16gb ddr4 3200Mhz

i've attached the error log when i try to install via garuda settings in the bin file below


Thank You

Use y


y as in? sorry didn't get :sweat_smile:

1 Like
:: python-pyxdg and python-xdg are in conflict. Remove python-xdg? [y/N]

Y for Yes!


Sorry, i understood that it's asking for a y or n prompt. The issue is it isn't. Even before i type y, its finishing the entire script . As soon as i click install drivers, there's a progress bar and it ends up with this error.
I'm not able to uninstall python-xdg in konsole too, it says
Any help would be great.
Thanks :slight_smile:

This was the issue
"python-wheel optionally requires python-xdg: for wheel.signatures"
sudo pacman -Rc python-xdg did the trick!
Thanks @SGS and @jonathon :v:


i have installed Garuda Dragonized Gamer edition, and i can't get the nvidia drivers to work.
I tried booting the installer of garuda via the unfree drivers option, hangs at boot.
with the free drivers option, it boots an i can install it, but i cannot install the nvidia drivers (after install and updates and a restart) because a package called python-xdsg is having a conflict with another package.

This a pretty basic and unrelated issue(unrelated to Nvidia).

Which package is python-xdsg having a conflict with? Basically, what is the error? It is probably a pretty simple fix.

Edit: Also, I believe the package is called python-xdg(not python-xdsg). You seem like a "newbie" as you proclaim. Do you have experience with Linux, or is this your first time using it?




I do think that if you are in the hardware detection app and you just click "Auto-Install proprietary drivers", it does not give you the option to remove python-xdg.

If that is the case, run sudo pacman -Syu in the terminal and you will get the option.


perfect. this solved it. Thank you very much


It turns out i was to early...i installed it via the hardware detection app, there was no error in the install process.
but my garuda won't boot now...at least it can't start the DE.
I can switch to a different console, and try operating from there....
what can i do? can it be, that the zen kernel is not compatibel with nvidia drivers? or is there something i overlooked?
(i cannot even start from a snapshot)
(My normal process is installing garuda -> updating --> reboot --> install nvidia drivers from the hardware detection app --> reboot)
i can try to install the whole system again, and post the output from the nvidia driver install process...

Those Nvidia Drivers work with the Zen Kernel.

What mode is your graphics card selection set to in your BIOS? On some motherboards, Nvidia cards can't start if it is in "auto" mode.

If you are in "auto" mode, try selecting the slot that the Nvidia graphics card is on

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.