Unable to boot into Garuda linux Dragonized bootable usb in order to install it

As mentioned in the topic, I've created a bootable usb with the help of Etcher of the latest release of Garuda Linux Dragonized version.
My computer specifications:-
AMD A6 7480 Processor
Gigabyte GA-F2A68HM-S1 MOTHERBOARD
8GB RAM
So, as far as I have seen the requirements, it supports my system.
When I boot through the bootable USB pendrive, (I have UEFI boot enabled and secure boot disabled) I get the Garuda Linux menu asking me to select whether to boot with open drivers or proprietary drivers(NVIDIA). Since I do not have an NVIDIA graphics card, I selected the option to boot with open source drivers and I hit enter, but after I do that, I get a text below saying "welcome to grub" and after that, I just get a lit up blank screen. Nothing happens even after an hour of waiting. Based on the suggestion of one of the person in the community telegram group, I tried entering nomodeset instead of noveau.modeset=1 in the grub edit of boot with open source drivers but the same thing persists. I am unable to boot into the live session of Garuda Linux Dragonized version. I tried other versions of Garuda Linux too. They also gave me the exactly same result. I am able to run other distros very well. But, I am unable to install the beautiful Garuda Linux. Hope I find a solution to the problem. Please help. I am attaching the picture of the blank screen. I also tried entering quite splash nomodeset but that gave me a loading type of a screen and then that froze too after sometime. Even after waiting for hours no change was observed on my end. On the advice of the same person in the community, I hit esc after entering quite splash nomodeset instead of noveau.modeset=1 and after I got the loading screen I hit esc. I get some long texts. Nothing happens after that even after hours.
I also tried booting with properietary drivers that too gave the same result.
I am attaching the following files:-

  1. When I hit the escape button after entering quite splash nomodeset on the loading kind of screen, the text which I get after which nothing happens

    The version of iso file that I downloaded from torrents:- garuda-dr460nized-linux-zen-210406

Thank you
Yours Faithfully

2021-04-11T18:30:00Z

I am unable to boot into the live session of Garuda Linux Dragonized version.
Do you dual boot?
Fastboot und secure boot are off?

Read

I am unable to boot into the live session of Garuda Linux Dragonized version.

please
and post

inxi -Fxxxza

from live ISO.
as text! Even if you personally think it is unnecessary.

and
:slight_smile:

1 Like

Hi,
When I installed Garuda, approx one month ago, I had a very similar problem, which I managed to solve by using boot parameter iommu=soft.
I discovered it as a workaround in the Arch forum due to a bug in the kernel at that time (sorry I don't remember the exact version).
A few weeks later, after a kernel update, I tried to remove that parameter and in-fact it worked without it.
So, I assume that the installer starts now with a newer kernel version and this shouldn't be your issue, but if just want to give it a try...

3 Likes

This is a good boot parameter to test, especially with older Gigabyte MOBO's as some of them will not be able to boot off USB properly without it.

2 Likes

Can you please tell me how to use iommu=soft boot parameter? And also can you also tell me what it does and how to remove that parameter
It will be of great help if it works

As suggested, I enabled Iommu and tried, yet I got the same lit up blank screen

differ to

Where you put in this text?

1 Like

I just enabled IOMMU in my BIOS settings

No, you should press button e when you are in the grub line you want to use, then add iommu=soft at the end of the line starting with linux, then ctrl+x

2 Likes

My fault (face palm) - sorry, didn't read the Telegram post properly before replying. :blush:

2 Likes

Tried with entering iommu=soft in boot parameter in the grub, but still I am just getting a lit up blank screen.... Nothing happens after that

Well, don't feel bad. Now you have eliminated one off the list of possibles. :slightly_smiling_face:

1 Like

Sorry about that, I'm not expert enough to give further advices.
What seems strange to me is that the boot seems to stop at the very end of the process.
My final, maybe stupid, suggestion would be to verify the checksum of your iso and recreate the USB with etcher.

2 Likes