Unable to boot after installing nvidia proprietary drivers

I am able to install the drivers however it gets stuck on boot, usually gets stuck on "finished terminate plymouth boot screen" I have tried switching to the LTS kerbal, as mentioned in the FAQ, however I get the same results regardless of which kerbal I'm using zen/lts

We need more details :slight_smile:


and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.



Thanks, I'd like to apologize for my formatting I rarely use forums, it looks like an issue of it not actually installing all the nvidia modules, assuming it's an issue with it being a newer kerbal than is supported, what it says in the FAQ, the only log I have is from installing the drivers, one of the articles you linked said to put ~ at the beginning and end and one said to use `

I'm using garuda dr460nized / garuda210225.iso using the official .torrent from garudalinux.org/downloads

There is no error after installing the nvidia proprietary drivers it starts to boot normally and then gets stuck, usually at "loading initial ramdisk"

I was able to find a few other people with this issue although theirs was solved by doing a system update which I have tried multiple times and doesn't get me any further, I will try removing the zen kernel and see if that's able to get any further

1 Like
==> WARNING: errors were encountered during the build. The image may not be complete.

> Successfully installed video-nvidia-dkms
Graphics:  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: eVga.com. driver: nouveau
           v: kernel bus-ID: 09:00.0 chip-ID: 10de:1e07 class-ID: 0300
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver:
           loaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5")
           s-diag: 1165mm (45.9")
           Monitor-1: HDMI-1 res: 3840x2160 hz: 30 dpi: 52 size: 1872x1053mm (73.7x41.5")
           diag: 2148mm (84.6")
           OpenGL: renderer: NV162 v: 4.3 Mesa 20.3.4 direct render: Yes
driver: loaded: modesetting,nouveau

Driver nvidia ist not installed.


mhwd -li
1 Like

This is the output after installing

And strangely now none of the snapshots are booting

Short text files (< 38,000 chars???) you can post here :slight_smile:

Same on my PC.

 Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2021.02.19                true            PCI
     video-nvidia-dkms            2020.12.19               false            PCI
inxi -G     
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 460.67 
           Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 

Maybe you can install new?
Check sha256sum.

Please also wait for other helpers, I am not the best in log reading :slight_smile:

1 Like

this is my second install, I'll download again, no worries thanks for the quick replies

Do update system before you install nvidia driver.

sudo pacman -Syu



I have run multiple system updates before and after installing the driver

roughly an hour until the iso is done downloading

okay sorry for the late reply had issues with finding my thumbdrive, still freezes when I'm trying to boot with proprietary drivers, gets stuck on the spinning circle

Press Esc at spinning circle, so you see where halts occur - be aware, it can take up to 5min to progress.

If hanging, try booting with free drivers.

Once booted -

sudo pacman -Syu



sudo dkms autoinstall

reboot and test if working nicely.

1 Like

when I boot from live iso I get 1 failure I can see on screen

Failed to start LiveMedia Pacman mirror ranking script See 'systemctl status mirrors-live.service' for details 

then it get's stuck on

[Ok] Finished Permit User Sessions.
     Starting Deactivate Plymouth Boot screen...
     Starting Hold until boot process finishes up...
     Starting Terminate Plymouth Boot Screen...
[OK] Activated swap Swap Block/Partition

I think I've tried the other before but I'll try it again

15 minutes not getting any further, I let it sit for a couple hours after I had installed the drivers yesterday.

Ok, keep us updated as to your progress/problems/symptoms, please. :slightly_smiling_face:

1 Like

bro but dmks will not work in garuda linux.

1 Like

Wouldn't be the first time I've been wrong. :slightly_smiling_face:


sorry for the wait, like king1 mentioned "nothing happened" when I ran sudo dkms autoinstall, video-linux is still the only pci config listed when I run mhwd -li hardware config shows that the nvidia driver isn't installed

Nice to see I am not the only sucker with this exact problem :rofl:

Actually, I have an even better idea: sleep, since its midnight, then tomorrow just make a dual boot of windows 10 and dragonized, then I can use win10 for games and dragonized for everything else.

Also means I can keep playing genshin impact on the laptop LOL

1 Like

yeah I'm getting ready to install manjaro if I can't figure it out within the next few days, just love the look and preinstalled goodies garuda has

Perhaps your rig requires special grub kernel boot parameters.

Search online for any boot params you may need.

Start here:

1 Like