The top panel of the application window disappears when deployed to full screen

System:
Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c1186269-b621-4cd3-84a8-69b7dce0c70d rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME H310-PLUS v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 0401
date: 02/28/2018
CPU:
Info: model: Intel Core i5-9500 bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 800 high: 801 min/max: 800/4400 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 800
5: 801 6: 801 bogomips: 36000
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK driver: nvidia
v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-08) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:1c82 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 80 s-size: 434x241mm (17.09x9.49")
s-diag: 496mm (19.54")
Monitor-1: HDMI-0 pos: primary res: 1366x768 hz: 60 dpi: 80
size: 434x236mm (17.09x9.29") diag: 494mm (19.45") modes: N/A
Monitor-2: None-1-1 size-res: N/A modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.104.05 renderer: NVIDIA GeForce GTX 1050
Ti/PCIe/SSE2 direct-render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter driver: mt7601u type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 148f:7601
class-ID: 0000 serial: <filter>
IF: wlp0s20f0u3 state: down mac: <filter>
Device-3: Ralink RT5370 Wireless Adapter driver: rt2800usb type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-4:3 chip-ID: 148f:5370
class-ID: 0000 serial: <filter>
IF: wlp0s20f0u4 state: down mac: <filter>
Drives:
Local Storage: total: 2.05 TiB used: 34.2 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM2 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 model: UDore 256GB size: 238.47 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD
serial: <filter> fw-rev: 1A0 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: DT01ACA100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A8A0 scheme: GPT
Partition:
ID-1: / raw-size: 237.5 GiB size: 237.5 GiB (100.00%) used: 14.33 GiB (6.0%)
fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 1001 MiB size: 999 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 19.87 GiB (2.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 237.5 GiB size: 237.5 GiB (100.00%)
used: 14.33 GiB (6.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 237.5 GiB size: 237.5 GiB (100.00%)
used: 14.33 GiB (6.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 23.39 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 6 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 29%
Info:
Processes: 263 Uptime: 22m wakeups: 0 Memory: total: 24 GiB
available: 23.39 GiB used: 5.23 GiB (22.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1281 libs: 331 tools: octopi,paru Shell: fish v: 3.6.1
running-in: yakuake inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-09-09
Last full system update: 2023-09-09
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

In kde plasma, I want to change the garuda panel and garuda dock to one panel from the bottom (which is the default in kde breeze). But when I delete garuda panel and garuda dock. When deployed to full screen (not f11, but just the application occupies the entire screen), the application window panel disappears, which is usually always on top of the window (it usually has buttons, full screen, close, minimize, title), but now it is not there. How to fix it?

Try opening ~/.config/kwinrc and go to section [Windows]. Set BorderlessMaximizedWindows=false, logout and login.

4 Likes

Yes, it helped, thank you. It's strange that it's done so it's not obvious

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.