System won't boot and snapshots not working

I am writing from my phone, so please excuse the poor format or the lack of a garuda-inxi output. I will provide screenshots (literally) for what little help it might bring.

A few hours ago, I wanted to install a amd-ffmpeg-git version that would allow me to use hardware acceleration for video compression. To avoid conflicts, I uninstalled ffmpeg using octopi. It seems that ffmpeg took with itself half of the system as dependencies (I should have cancelled when I saw the list, but it's too late for that). Now I can't even log on because there is no wayland or x11 to start a session with.

I tried to use the snapshot functionality to restore to a point before the mess.

But, no matter which one I choose, I keep getting the same error:

I lack the knowledge to solve this on my own and, sincerely, I am about to start pulling my hair off. So, please, any help would be very appreciated.

Thanks in advance.

1 Like

Can you enter a TTY (CTRL+ALT+F2) and use the command sudo snapper-tools list and post the output of that here?


Thanks for your quick response. I hope a picture will suffice:

Run sudo snapper-tools restore 677, reboot and you should be back on track.


It did work. I can't thank you enough!


I might have been a little too optimistic: yes I can log in now. But a lot of the software is missing. System settings app included.
Should I go for a previous restore point, reinstall all packages from Garuda Assistant o just perform a system update?

Apparently, the package keys went obsolete after restoring. Fixed it with
sudo pacman -Sy archlinux-keyring chaotic-keyring
sudo pacman -Syu
And now everything appears to be working. Again, many thanks.

I think normally a garuda-update would have taken care of all this, as it updates keryings automatically.
But the important thing is it's fixed!

And you should replace this with garuda-update anyway. :slight_smile:


Yeah, I normally use Garuda-update to update, but this time I was copy-pasting commands to get a result without fully understanding the means :sweat_smile:
At the end, everything is working, and I have to thank you for that.
Yet I'd like to figure out how did it happen, in the first time, so I can avoid facing this problem again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.