Suggestions for setting up Xfce Garuda

I’ve removed the note about journal size limit from the guide. Many thanks for the info.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

https://forum.garudalinux.org/t/suggestions-for-setting-up-xfce-garuda/34493/42

Something has broken the theming of Garuda utilities such as Garuda Assistant. Other KDE software such as Audacious was not effected and theme correctly.

I restored my OS to its previous state using snapper and the Garuda theming works without issue. The Kvantum settings are unchanged before and after the update.

Does anyone know which of the updates could be causing the issue? Maybe qt6?

Updates:

Packages (39) amdvlk-2024.Q1.2-1  chaotic-mirrorlist-20240306-1  eza-0.18.6-1  fakeroot-1.34-1
              firedragon-1:11.10.5-2  garuda-system-maintenance-3.0.0-2  hwdata-0.380-1
              kcolorpicker-qt5-0.3.1-4  kconfig-6.0.0-1  kimageannotator-qt5-0.7.1-2  kmod-32-1
              knotifications-6.0.0-1  ksnip-1.10.1-4  kstatusnotifieritem-6.0.0-2  kvantum-1.0.10-3
              kwindowsystem-6.0.0-1  lib32-amdvlk-2024.Q1.2-1  lib32-libdrm-2.4.120-1
              lib32-vulkan-icd-loader-1.3.279-1  libnewt-0.52.24-1  libsodium-1.0.19-3
              openexr-3.2.3-1  psmisc-23.7-1  python-3.11.8-1  python-dateutil-2.9.0-2
              qt6-base-6.6.2-4  qt6-declarative-6.6.2-1  qt6-svg-6.6.2-1  qt6-translations-6.6.2-1
              qt6-wayland-6.6.2-1  rtmpdump-1:2.4.r105.6f6bb13-1  sdl2-2.30.1-1  tcl-8.6.14-1
              vim-9.1.0151-2  vim-runtime-9.1.0151-2  vulkan-headers-1:1.3.279-1
              vulkan-icd-loader-1.3.279-1  wavpack-5.7.0-1  xcb-util-cursor-0.1.5-1

1 Like

Or

Set up a hook that clears all but the last cache and the currently installed after every Pacman transaction like so:

sudo micro /etc/pacman.d/hooks/paccache.hook

Paste in the hook:

[Trigger]
Operation = Remove
Operation = Install
Operation = Upgrade
Type = Package
Target = *

[Action]
Description = Keep the last cache and the currently installed.
When = PostTransaction
Exec = /usr/bin/paccache -rk2

You can make the hook as aggressive as you wish. After you have it set up, there is no need to explicitly clear package cache.

1 Like

This is actually written into the guide - I only keep 1 copy of files in the cache.

The problem I’m having is at least one of packages in the aforementioned update breaks the color theming of Garuda items such as Garuda Assistant etc, but it doesn’t break the theming of KDE software such as Audacious, and this is quite baffling. I am wondering if anyone knows which update is causing the issue.

Solution to the problem:

2 Likes

I’ve got a new laptop and I’ve had Xfce Garuda put onto it. I’ve been going through the guide and I’ve found a problem. I’ve been trying to install Fastfetch. On my old laptop Fish was already installed and Fastfetch installed without issue using the following in the guide…

…the above shows it is installed on my laptop. If it isn’t installed on your machine you can install it by entering sudo pacman -S garuda-fish-config in the terminal, and then enter the terminal command sudo cp /etc/skel/.config/fish/config.fish ~/.config/fish/config.fish.

On my new laptop Fish was not installed, but sudo pacman -S garuda-fish-config did the trick - here’s the terminal confirmation:

pacman -Qs garuda-fish-config
local/garuda-fish-config 1.5.23-1
    Fish configuration of Garuda Linux

The problem occurs when I enter sudo cp /etc/skel/.config/fish/config.fish ~/.config/fish/config.fish - nothing happens.

I checked /etc/skel/but there’s nothing in this directory, thus nothing can be copied.

Does anyone know a solution to this problem?

Hmm, that does not sound right. What is your method of checking in this directory?

Keep in mind these are all dotfiles, so you will need to enable viewing hidden files and directories.

❯ eza -al /etc/skel
.rwxr-xr-x  125 root  9 Mar 12:39 .azotebg
.rw-r--r--   21 root 16 Jan 06:48 .bash_logout
.rw-r--r--   57 root 16 Jan 06:48 .bash_profile
.rw-r--r--  172 root 16 Jan 06:48 .bashrc
.rw-r--r-- 3.0k root 27 Jan 22:41 .bashrc_garuda
drwxr-xr-x    - root 24 Feb 18:14 .config
.rw-r--r--  661 root  9 Mar 12:39 .gtkrc-2.0
drwxr-xr-x    - root  9 Mar 12:55 .icons
drwxr-xr-x    - root 24 Feb 18:13 .local
.rw-r--r--  139 root  9 Mar 12:39 .profile
.rw-r--r--  10k root 27 Jan 22:28 .zshrc

Are you actually switching to the Fish shell? If you haven’t set up the custom command in your terminal yet you might still be in Bash. Type fish in the terminal to switch from Bash to Fish.

2 Likes

Problem solved :grin:

I’ll add this to the guide.

Many thanks.

Guide updated.

3 Likes

I had to reinstall Garuda on my laptop again, and I found that…

Then enter the terminal command sudo cp /etc/skel/.config/fish/config.fish ~/.config/fish/config.fish.

…once again caused the following error…

sudo cp /etc/skel/.config/fish/config.fish ~/.config/fish/config.fish
[sudo] password for colin:
cp: cannot create regular file ‘/home/colin/.config/fish/config.fish’: No such file or directory

I did a bit of research and amended the guide with the following…

Then enter the terminal command mkdir ~/.config/fish, press Enter, then sudo cp /etc/skel/.config/fish/config.fish ~/.config/fish/config.fish. …

This resolved the issue.

A little trick if you are interested:

If you use the -p flag with mkdir, it means “make this directory if it doesn’t already exist, and if it does already exist then do nothing.” It avoids hitting an error message if you try to make a directory that already exists (especially handy in scripts, where this error can cause the script to exit).

~ 
❯ mkdir test/

~ 
❯ mkdir test/
mkdir: cannot create directory ‘test/’: File exists

~ 
❯ mkdir -p test/

~ 
❯ 

All that to say: you can have your instruction say something like this if you want to:

Create the Fish config directory if it doesn’t already exist.

mkdir -p ~/.config/fish
2 Likes

Tested and added to the guide :saluting_face:

Thanks for this little nugget.

The guide has been updated significantly.

I found I had the same problem in getting KDE to theme properly as were mentioned in this thread:

I installed the old Kvantum version because I knew it worked on my other laptop - sudo pacman -S kvantum-qt5 - but when I tried to get it working on my Lenovo laptop it just refused to work. In the end I installed the latest Kvantum version alongside the old one and things magically worked. This was added to the guide…

To get a dark theme on KDE software I found two versions of Kvantum had to be downloaded. Open up the terminal and enter the following to download the required files:

sudo pacman -S kvantum
sudo pacman -S kvantum-qt5

Hopefully it works correctly on all setups.

I also applied the -p flag trick suggested by @BluishHumility to adding the icons and themes folders:

mkdir -p ~/.icons ~/.themes

Big time saver.

Other bits have also been updated.

Hopefully everything works correctly.

2 Likes