SDDM.conf has incorrect default variable for numlock

hey all!

i just happened to notice a minor 'bug' in the form of an incorrect default variable in the /etc/SDDM.conf file for the numlock settings on startup.
mine was always on for POST but then getting shut off before i hit the login screen.

when examining my sddm.conf i found it was set with 'true' variable when according to this wiki page it should be "on, off or none". >sddm.conf(5) — Arch manual pages<

i modified my file with the correct entry and it seems to have solved this minor issue.
(tested with system restart)

thank you! =-)

1 Like

If you had posted your garuda-inxi we would know where this is necessary. :slight_smile:
path849

3 Likes

it should be the inxi section of the forums but probably needs updating =-)

here you go!

(my system has a bit of a glitch with fish not showing my account name and such at the prompt and the colors are green, white and yellow instead of the normal red - totally different issue)

 garuda-inxi
System:
  Kernel: 5.16.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8c001618-4d8a-42a9-a618-f7e387490309 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=089e3bf7-32af-45ad-befd-285060f9aa69 loglevel=3
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: MSI model: Z77A-GD55 (MS-7751) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.11
    date: 11/20/2013
CPU:
  Info: model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge
    family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2709 high: 3902 min/max: 1600/3900 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 1701 2: 2473 3: 1797
    4: 3899 5: 2212 6: 3897 7: 1794 8: 3902 bogomips: 55998
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: Micro-Star MSI
    driver: nvidia v: 470.103.01 alternate: nouveau,nvidia_drm pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:11c0 class-ID: 0300
  Device-2: NVIDIA GK106 [GeForce GTX 660] vendor: Micro-Star MSI
    driver: nvidia v: 470.103.01 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.0 chip-ID: 10de:11c0 class-ID: 0300
  Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 95 s-size: 513x292mm (20.2x11.5")
    s-diag: 590mm (23.2")
  Monitor-1: DVI-I-1 res: 1920x1080 hz: 60 dpi: 96
    size: 510x290mm (20.1x11.4") diag: 587mm (23.1")
  OpenGL: renderer: NVIDIA GeForce GTX 660/PCIe/SSE2
    v: 4.6.0 NVIDIA 470.103.01 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0403
  Device-2: NVIDIA GK106 HDMI Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e0b class-ID: 0403
  Device-3: NVIDIA GK106 HDMI Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.1
    chip-ID: 10de:0e0b class-ID: 0403
  Sound Server-1: ALSA v: k5.16.14-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel 82579V Gigabit Network vendor: Micro-Star MSI
    driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503
    class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
  IF-ID-2: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: <filter>
  IF-ID-3: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IF-ID-4: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:
  Local Storage: total: 2.91 TiB used: 551.67 GiB (18.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SH103S3120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BBF0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0107 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 0107 scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 vendor: Kingston model: SH103S3120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: BBF0 scheme: GPT
  ID-5: /dev/sde maj-min: 8:64 vendor: Western Digital
    model: WD20EZRX-00D8PB0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 0A80
    scheme: MBR
Partition:
  ID-1: / raw-size: 39.75 GiB size: 39.75 GiB (100.00%) used: 18 GiB (45.3%)
    fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 71.04 GiB size: 71.04 GiB (100.00%)
    used: 56.09 GiB (79.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 39.75 GiB size: 39.75 GiB (100.00%)
    used: 18 GiB (45.3%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 39.75 GiB size: 39.75 GiB (100.00%)
    used: 18 GiB (45.3%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 512 MiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda4 maj-min: 8:4
  ID-2: swap-2 type: zram size: 23.43 GiB used: 2.8 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Info:
  Processes: 331 Uptime: 25m wakeups: 0 Memory: 23.43 GiB
  used: 3.25 GiB (13.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1847 lib: 522 Shell: fish v: 3.3.1
  running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
  System install date:     2022-03-10
  Last full system update: 2022-03-13
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Timeshift (maybe)
  Failed units:            bluetooth-autoconnect.service systemd-networkd-wait-online.service

Thanks for posting, but if you use the inxi section post the link, please :slight_smile:

BTW, I have no problems with numlock in KDE?

[General]
HaltCommand=/usr/bin/systemctl poweroff
InputMethod=qtvirtualkeyboard
Numlock=true
RebootCommand=/usr/bin/systemctl reboot

Maybe a developer can help _:slight_smile:

1 Like

i'm pretty sure i screwed something up between my fresh install and when i did a full upgrade afterwards but i couldn't begin to figure what that is.
i didn't really mess with much other than adding a couple hard drives to my fstab automount, preventing my audio chipset from going to sleep and some minor aesthetic changes.

i'm probably just gonna do it over again lmao
i'd really like to be able to choose a specific proprietary driver in the OS installer, my machine wants the 470.xx version and the open source one underwent random system hangs were i couldn't even move my mouse.
it happened during an upgrade a couple times and that forced me to use an older iso - the 210809 that has a working proprietary driver for me.

in the long run i intend on getting an AMD rig and move on from intel and nvidia because although their hardware may be great, the corporations making them are owned by crazy people.

SDDM does not provide this file IIRC, and as I checked Arch package. How certain are you that you did not create it?

Also:

  • default sddm settings are applied from this file (default=none), which has always the same setting for a long time (upstream code).
/usr/lib/sddm/sddm.conf.d/default.conf
  • Garuda provides sddm theme, which can alter this value (inside the theme files) and the current value for dragonized is OK. Which version have you installed? What theme have you enabled?
  • KDE System Settings (KCM) modify this value, using a drop-in file (/etc/sddm.conf.d/kde-settings.conf), also overriding the setting/value.
  • IIRC /etc/sddm.conf is deprecated for normally applying settings, but kept for compatibility.
3 Likes

i did not manually create the sddm.conf file, i found it in the etc folder when i looked for it after investigating the numlock issue and found the man page i linked earlier.
i tried to set the numlock to be 'on' in the system settings like normal, but it didn't stick, hence my investigation.

i used the Garuda Dragonized Gaming Edition 210809 iso and when i got to the desktop, the theme was initially set on breeze rather than the sweetified plasma as it should have been.
i had to change the global theme and when i logged in for the first time.

a number of issues manifested with getting it to look like it should, kvantum dark was the same as kvantum visually, there was no difference when switching them. i also had an issue with certain system app windows not using the visuals from any application style theme - the terminal window and the window for the system settings itself.
this seems to have fixed itself with a recent update.

initially the default terminal app was set to bash and when loaded it was an empty window with a command prompt. when i switched the default terminal app to fish with garuda assiatant, the normal garuda 'G' look returned minus the color scheme which is now green, white and yellow instead of red and the command prompt itself contains no text, it's just a cursor.

immediately after installation i added another ssd to automount at boot in fstab - this particular action i did during the live session before restarting and logging in for the first time.

once logged in i changed the background image in grub, the login screen and the desktop and downloaded a splash screen from the list of available stuff in the system settings.
i'm experienced as a windoze system admin, but i'm a linux nub so i avoid messing with stuff without thorough research so i don't brick my rig.

i think a glitch happened during the installation procedure, i have not encountered anything like this before and i was at reinstalling a number of times over a couple days due to the open source driver hanging at random, so i tried a few different iso's.
i think this hang happens to me because i have an nvidia SLI setup, but i can't be sure. (godforsaken nvidia)
i also recreated my partition scheme every time i tried an install to avoid problems.

another potentially related issue is when i try to install a package with garuda assistant's 'add/remove software', i get an error message:
[ unable to satisfy dependency 'python-qtpy>=2.0.1' required by guiscrcpy-git ]
but if i install the chosen app from terminal, it proceeds no problem and i have confirmed that i have this python-qtpy package already installed.

i am of the mind that these issues are related, perhaps a read/write permissions thing?

thank you for your time, i know you folks are busy.

P.S.
sorry for the long-winded 'novel'.
to create my livestick i used balenaEtcher version 1.1.7 from Windoze 7, which i have installed on another separate ssd.

1 Like

I have been messing with this on and off all day, so far this is what I have found:

-I was able to duplicate this issue, and correct by changing /etc/sddm.conf to on from true.
-I have not changed the SDDM theme (installed with ISO prior to garuda-dr460nized-linux-zen-220131), and did not create that file myself.

[sudo] password for richard:            
extra/sddm 0.19.0-8 [installed]
    QML based X11 and Wayland display manager
extra/sddm-kcm 5.24.3-1 (plasma) [installed]

-Could not find a package that provides sddm.conf , using sudo pacman -Fy /etc/sddm.conf
-The above version of SDDM /etc/sddm.conf is valid and the one with precedence over default.conf and any file in /etc/sddm.conf.d according to man page

One thing you mention, I have /etc/sddm.conf.d/dr460nized.conf, but /etc/sddm.conf.d/kde-settings.conf does not exist on my machine.

The last thing I found, which may or not be valid any more is

Which has the incorrect setting of Numlock=true

I was working an MR for this, but will place that on hold, as I am not sure I found the right file, and await your guidance.

3 Likes

I had a few moments so I spun up a VM with the garuda-dr460nized-linux-zen-220308.iso.

-The /etc/sddm.conf file exists in both the live instance, and clean install
-Numlock=true is set in both, instead of Numlock=on

The garuda-lxqt-kwin-linux-zen-220131.iso also has the Numlock=true setting in the live instance, but I have not been able to test an install or check for a new ISO yet.

Just to rule out a "common settings" area possibly, I entered a live instance of garuda-gnome-linux-zen-220131.iso, garuda-sway-linux-zen-220308.iso, and the file does not exist.

Hopefully, I am providing useful information, let me know and I will try to get what is needed...and not being a PITA.

4 Likes

@Michael_joseph @haakoth excellent job. Thanks for your good contribution!

It seems this file is ages old and was missed to get the proper settings.

I have just fixed it at GitLab and it will be OK for the next ISOs and updated packages.
It will be discussed in the Team for further actions, if it needs a deletion or other.

Thanks a lot both of you! :+1:

7 Likes

i'm helping! =-D

(Nelson from Simpson's voice)

3 Likes

i just updated @17:45 EST time and got the new 'dr460nized' package and i have previously used chattr to make the 'theme.conf.user' immutable as suggested here and for the same reason:

i'm curious to know if i need to allow the overwrite for this particular update.
if so, i'm gonna have to do this manually now so i'll just scrape the file out of my package cache and copypasta.

thank you! =-)

Which package exactly? Full package name, please.

1 Like

I guess this is the change.

No relation with that file, so nothing to be done in my opinion.

3 Likes

ugh i closed the terminal window, i have no idea off-hand.
i figured it may be a part of the theme fix you'd just done.

p.s.
thanks filo!

1 Like

No history in fish or bash, sad :smiley:

1 Like

I updated a few minutes ago, and I had only few updates, so that one was fresh in my mind :wink:

1 Like

i know!
my brain is foggy lol
i'm quitting smoking and coffee at the same time so i'm really sub-par in the brain case lately >.>

1 Like

LOL omg just type 'history' at the effin prompt

random experiment success!

i love Arch.
so simple it seems complicated >.>

now i'll snoop around for command variables.

This is irrelevant to Original Topic, but... why not? :smile:

Your previous fix was a dirty workaround, not a solution.

  • We never (normally) modify packages, unless it is designed as such.
  • IIUC you are modifying a theme package file. It seems the theme is provided as is.
  • If you want the same theme with some minor modification(s), you can just clone the theme (folder) with a different folder/theme name (read the files and man pages, for a better understanding of how themes work) and modify it as you like. Then select this new theme from System Settings (it should show up) and congrats for your own theme!

If there is a conflict (overriden values) in some of the sddm configuration files, man sddm.conf shows the file priority. /etc/sddm.conf should be absent, or it will overwrite any settings that conflict.

Check the package owner and report back, so we can fix it. If there is no owner, delete the file and use the drop-in folder and System Settings.

pacman -Qo /etc/sddm.conf
4 Likes