Screen Tearing Problem

System:
  Kernel: 5.15.64-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=866e0b23-19e5-43ac-802b-ce0f5de6cac2
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required> UEFI: INSYDE v: 1.07.10TFB24
    date: 12/06/2021
Battery:
  ID-1: BAT0 charge: 48.3 Wh (100.0%) condition: 48.3/47.2 Wh (102.4%) volts: 16.6 min: 14.4
    model: Notebook BAT type: Li-ion serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB desc: d-6x48
    KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3079 high: 4052 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 2920 2: 2606 3: 1649 4: 3504 5: 3926 6: 3386 7: 2882 8: 4052
    9: 3323 10: 2133 11: 3638 12: 2934 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: CLEVO/KAPOK driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of 2022-07)
    arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:2 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: intel,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080 hz: 144
    dpi: 128 gamma: 1.2 size: 380x210mm (14.96x8.27") diag: 437mm (17.2") ratio: 16:9
    modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.15.64-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
    chi
p-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 12.86 GiB (2.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P2CR048 temp: 41.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 12.83 GiB (5.4%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 29.7 MiB (30.9%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 12.83 GiB (5.4%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 12.83 GiB (5.4%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 12.83 GiB (5.4%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 307 Uptime: 6m wakeups: 1 Memory: 15.41 GiB used: 3.27 GiB (21.2%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pacman: 1239 lib: 317
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-08-31
  Last full system update: 2022-09-01
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

I have screen tearing, how do I fix it?

Your monitor is 144hz. Make sure it is set in display options is set to 144hz, and if you are experiencing the screen tearing elsewhere (like in a game), make sure the application settings are set for a respectable frame limit or to vsync.

2 Likes

144hz is on in settings. And still doing

On just the desktop even?

You can try switching to Wayland. Run

sudo pacman -S plasma-wayland-session

then logout and choose Plasma (Wayland) on login screen. If this introduces more issues, choose Plasma (X11).

3 Likes

Yep. Right

I guess this solved it How can I be sure about that?

Just wait and see :slight_smile:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

System:
  Kernel: 5.19.6-xanmod1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod-anbox
    root=UUID=866e0b23-19e5-43ac-802b-ce0f5de6cac2 rw [email protected] quiet quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required> UEFI: INSYDE v: 1.07.10TFB24
    date: 12/06/2021
Battery:
  ID-1: BAT0 charge: 47.3 Wh (100.0%) condition: 47.3/47.2 Wh (100.4%) volts: 16.6 min: 14.4
    model: Notebook BAT type: Li-ion serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB desc: d-6x48
    KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2697 high: 4155 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 2851 2: 2700 3: 2740 4: 1759 5: 2761 6: 4155 7: 2937 8: 2700
    9: 894 10: 3293 11: 3576 12: 2004 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: CLEVO/KAPOK driver: nvidia
    v: 515.65.01 alternate: nvidiafb,nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-07) arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 4
    speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:2 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: intel,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080 hz: 144
    dpi: 128 gamma: 1.2 size: 380x210mm (14.96x8.27") diag: 437mm (17.2") ratio: 16:9
    modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.19.6-xanmod1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:1
4.3
    chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 17.11 GiB (3.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P2CR048 temp: 37.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 17.08 GiB (7.2%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 29.7 MiB (30.9%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 17.08 GiB (7.2%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 17.08 GiB (7.2%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 17.08 GiB (7.2%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 306 Uptime: 9m wakeups: 1 Memory: 15.42 GiB used: 3.81 GiB (24.7%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pacman: 1378 lib: 333
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2022-08-31
  Last full system update: 2022-09-05
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            systemd-oomd.socket 

How can I fix my screen tearing?

What went wrong after this, which seems to be solved?

I see a different kernel for example, what else?
You could try searching in the forum if there is anything that might help:
https://forum.garudalinux.org/search?q=screen%20tearing%20status%3Asolved
Also here (see "Garuda Screen Problem" thread) working on the compositor settings might help.

2 Likes

Garuda has the same problem in its own kernel.
And I couldn't figure it out

Does screen tearing happen on games or desktop? Battery or wall power? Does disabling compositor (shift+alt+f12) help?

It is barely noticeable in normal use. But in the screen tearing test I see

And I'm using the computer to charge

Configure your browser to run at monitor refresh rate. It is most likely running at 60 Hz instead of 144 Hz. You can also try disabling your compositor, (shift+alt+f12) switching to Wayland or enabling Vsync for the compositor. (from System Settings)

1 Like

firedragon is running at 60hz, how do I make 144? It really looks like it's torn because of that.

I came across this:

1 Like
System:
  Kernel: 5.19.7-lqx1-1-lqx arch: x86_64 bits: 64 compiler: gcc v: 12.2.0 parameters: audit=0
    intel_pstate=disable hpet=disable rcupdate.rcu_expedited=1
    BOOT_IMAGE=/@/boot/vmlinuz-linux-lqx root=UUID=f5ae5af2-c99a-405a-8058-4d6b8d3c8e34 rw
    [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A serial: <superuser required> Chassis:
    type: 10 serial: <superuser required>
  Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required> UEFI: INSYDE v: 1.07.10TFB24
    date: 12/06/2021
Battery:
  ID-1: BAT0 charge: 47.3 Wh (100.0%) condition: 47.3/47.2 Wh (100.4%) volts: 16.4 min: 14.4
    model: Notebook BAT type: Li-ion serial: <filter> status: full
CPU:
  Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP arch: Tiger Lake gen: core 11
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1 microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 480 KiB desc: d-6x48
    KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2803 high: 3838 min/max: 800/2701 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 3369 2: 1800 3: 3838 4: 2701 5: 2859
    6: 2153 7: 2701 8: 3414 9: 2701 10: 2701 11: 2701 12: 2701 bogomips: 64512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK driver: i915 v: kernel
    arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: CLEVO/KAPOK driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of 2022-07)
    arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0300
  Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:2 chip-ID: 04f2:b729
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080 hz: 144 dpi: 128
    gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7 direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.19.7-lqx1-1-lqx running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kerne
l bus-ID: 00:14.3
    chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 18.76 GiB (4.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P2CR048 temp: 40.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.72 GiB (7.8%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 43.8 MiB (45.7%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.72 GiB (7.8%) fs: btrfs
    dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.72 GiB (7.8%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.72 GiB (7.8%)
    fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 65.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 336 Uptime: 21m wakeups: 1 Memory: 15.42 GiB used: 6.36 GiB (41.3%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pacman: 1539 lib: 381
  Client: shell wrapper v: 5.1.16-release inxi: 3.3.20
Garuda (2.6.6-2):
  System install date:     2022-09-07
  Last full system update: 2022-09-07 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            systemd-networkd-wait-online.service systemd-oomd.socket 

I've been searching for days. But I couldn't come to any conclusion. Drivers are installed. I don't know exactly what caused the tear and I'm about to go crazy

https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#Avoid_screen_tearing

As mentioned here, when I create a file, my computer stays on the black garuda linux startup screen.


Section "Device"
        Identifier "NVIDIA Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "ForceFullCompositionPipeline" "on"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

Or

Section "Device"
        Identifier "NVIDIA Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName  "NVIDIA GeForce GTX 1650 Mobile / Max-Q"
EndSection



Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "ForceFullCompositionPipeline" "on"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

There is no option to set "ForceFullCompositionPipeline" "on" in Nvidia-Screen Application.


System:
Kernel: 5.19.7-lqx1-1-lqx arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: audit=0 intel_pstate=disable hpet=disable
rcupdate.rcu_expedited=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-lqx
root=UUID=f5ae5af2-c99a-405a-8058-4d6b8d3c8e34 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: MONSTER product: ABRA A7 V12.5 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: MONSTER model: ABRA A7 V12.5 serial: <superuser required>
UEFI: INSYDE v: 1.07.10TFB24 date: 12/06/2021
Battery:
ID-1: BAT0 charge: 47.3 Wh (100.0%) condition: 47.3/47.2 Wh (100.4%)
volts: 16.4 min: 14.4 model: Notebook BAT type: Li-ion serial: <filter>
status: full
CPU:
Info: model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
model-id: 0x8D (141) stepping: 1 microcode: 0x40
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2432 high: 2701 min/max: 800/2701 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2296 2: 2448
3: 1542 4: 2701 5: 1301 6: 2701 7: 2701 8: 2701 9: 2701 10: 2701 11: 2701
12: 2701 bogomips: 64512
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a68
class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: CLEVO/KAPOK driver: nvidia v: 515.65.01
alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
2022-07) arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie:
gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1f9d class-ID: 0300
Device-3: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-8:2
chip-ID: 04f2:b729 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x0a15 built: 2021 res: 1920x1080
hz: 144 dpi: 128 gamma: 1.2 size: 381x214mm (15x8.43") diag: 437mm (17.2")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.19.7-lqx1-1-lqx running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: CLEVO/KAPOK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 18.78 GiB (4.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P2CR048
temp: 37.9 C scheme: GPT
Partition:
ID-1: / raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.73 GiB
(7.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 43.8 MiB
(45.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.73
GiB (7.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.73
GiB (7.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 238.82 GiB size: 238.82 GiB (100.00%) used: 18.73
GiB (7.8%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 337 Uptime: 33m wakeups: 1 Memory: 15.42 GiB used: 6.95 GiB
(45.1%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1539 lib: 381 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20

2022-09-07_23-36

Did you've checked the compositor settings?
Whatever application you're using in the end it needs to go through the compositor. I had a tearing issue myself until I solved it through reactivating the compositor.
There you have a screenshot of the setting on KDE (Garuda Gaming with sweetify theme) although it is a German overlay you'll identify the compositor settings, I guess.
You'll find it here: