Rsync returned an error. Failed to create a new snapshot

Hello.
Yesterday I've experienced very ugly crash (simlar to marcsitkin where he described
here) . My situatiom was almost the same - but it started while I was browsing regular web pages. Kdialog was crashed and after computer restart the fun part began :slight_smile:

I wasn't able to do anything to bring back my system up. Nothing adviced here

was helpful. So I gave up, formated a partition installed again garuda, and finally I was able to restore from my "gold" snapshot which was stored on separate partition. Luicky everything back to normal. Which I was super happy about , because I have put a lot of effort to adjust my system to my needs and spend countless hours googling and solving problems..

However I have noticed that not everything is fine. Currently I'm not able to create a new snapshot. Looks like cron problem.
Bellow is my snapshot log which was generated after my attempt of preparing :

sudo timeshift --create --comments "my longer comment describing what is about that backup" --tags D

[10:21:58] Main: check_dependencies()
[10:21:58] Main: add_default_exclude_entries()
[10:21:58] Main: add_default_exclude_entries(): exit
[10:21:58] update_partitions()
[10:21:58] Device: get_disk_space_using_df(): 2
[10:21:58] Device: get_mounted_filesystems_using_mtab(): 2
[10:21:58] Device: get_filesystems(): 25
[10:21:58] partition list updated
[10:21:58] detect_system_devices()
[10:21:58] Searching subvolume for system at path: /
[10:21:58] Found subvolume: @, on device: /dev/sda3
[10:21:58] Users: zawier root guest
[10:21:58] Encrypted home users: 
[10:21:58] Encrypted home dirs:

[10:21:58] Encrypted private dirs:

[10:21:58] Main: load_app_config()
[10:21:58] IconManager: init()
[10:21:58] bin_path: /usr/bin/timeshift
[10:21:58] found images directory: /usr/share/timeshift/images
[10:21:58] Main(): ok
[10:21:58] AppConsole: parse_arguments()
[10:21:58] Main: initialize_repo()
[10:21:58] backup_uuid=6615c19d-d1a2-461e-9bef-08aa80d7b441
[10:21:58] backup_parent_uuid=
[10:21:58] Setting snapshot device from config file
[10:21:58] repo: creating from uuid
[10:21:58] SnapshotRepo: from_uuid(): RSYNC
[10:21:58] uuid=6615c19d-d1a2-461e-9bef-08aa80d7b441
[10:21:58] SnapshotRepo: init_from_device()
[10:21:58] 
[10:21:58] SnapshotRepo: unlock_and_mount_devices()
[10:21:58] device=/dev/sda2
[10:21:58] SnapshotRepo: unlock_and_mount_device()
[10:21:58] device=/dev/sda2
[10:21:58] Device: get_mounted_filesystems_using_mtab(): 2
[10:21:58] ------------------
[10:21:58] arg=6615c19d-d1a2-461e-9bef-08aa80d7b441, device=/dev/sda2
[10:21:58] /run/timeshift/backup
[10:21:58] ------------------
[10:21:58] 
/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime

[10:21:58] SnapshotRepo: load_snapshots()
[10:21:58] loading snapshots from '/run/timeshift/backup/timeshift/snapshots': 1 found
[10:21:58] SnapshotRepo: unlock_and_mount_device(): exit
[10:21:58] Selected snapshot device: /dev/sda2
[10:21:58] Free space: 192.1 GB
[10:21:58] SnapshotRepo: check_status()
[10:21:58] SnapshotRepo: available()
[10:21:58] is_available: ok
[10:21:58] SnapshotRepo: has_snapshots()
[10:21:58] SnapshotRepo: has_space()
[10:21:58] Device: get_disk_space_using_df(): 1
[10:21:58] SnapshotRepo: check_status(): exit
[10:21:58] SnapshotRepo: init_from_device(): exit
[10:21:58] SnapshotRepo: from_uuid(): exit
[10:21:58] Main: initialize_repo(): exit
[10:21:58] AppConsole: start_application()
[10:21:58] Main: create_snapshot()
[10:21:58] SnapshotRepo: has_space()
[10:21:58] Device: get_disk_space_using_df(): 1
[10:21:58] Main: backup_and_rotate()
[10:21:58] SnapshotRepo: available()
[10:21:58] is_available: ok
[10:21:58] SnapshotRepo: has_space()
[10:21:58] Device: get_disk_space_using_df(): 1
[10:21:58] ------------------------------------------------------------------------------
[10:21:58] Creating new snapshot...(RSYNC)
[10:21:58] Saving to device: /dev/sda2, mounted at path: /run/timeshift/backup
[10:21:58] Main: save_exclude_list_for_backup()
[10:21:58] Main: create_exclude_list_for_backup()
[10:21:58] Main: create_exclude_list_for_backup(): exit
[10:21:58] Synching files with rsync...
[10:21:58] RsyncTask:execute()
[10:21:58] rsync -aii --recursive --verbose --delete --force --stats --sparse --delete-excluded --log-file='/run/timeshift/backup/timeshift/snapshots/2022-04-28_10-21-58/rsync-log' --exclude-from='/run/timeshift/backup/timeshift/snapshots/2022-04-28_10-21-58/exclude.list' --delete-excluded '/' '/run/timeshift/backup/timeshift/snapshots/2022-04-28_10-21-58/localhost/'
[10:21:58] RsyncTask:prepare(): saved: /tmp/VxpHDt21/2022-04-28_10-21-58/script.sh
[10:21:58] AsyncTask: child_pid: 81729
[10:40:23] AsyncTask: finish(): enter
[10:40:23] exit_code: 0
[10:40:24] E: rsync returned an error
[10:40:24] E: Failed to create new snapshot
[10:40:24] Failed to create snapshot
[10:40:24] ------------------------------------------------------------------------------
[10:40:24] SnapshotRepo: load_snapshots()
[10:40:24] loading snapshots from '/run/timeshift/backup/timeshift/snapshots': 1 found
[10:40:24] SnapshotRepo: auto_remove()
[10:40:24] SnapshotRepo: remove_untagged()
[10:40:24] SnapshotRepo: load_snapshots()
[10:40:24] loading snapshots from '/run/timeshift/backup/timeshift/snapshots': 1 found
[10:40:24] SnapshotRepo: load_snapshots()
[10:40:24] loading snapshots from '/run/timeshift/backup/timeshift/snapshots': 1 found
[10:40:24] Removing snapshots (incomplete):
[10:40:24] ------------------------------------------------------------------------------
[10:40:24] Removing '2022-04-28_10-21-58'...
[10:40:24] RsyncTask:execute()
[10:40:24] rm -rfv '/run/timeshift/backup/timeshift/snapshots/2022-04-28_10-21-58/'
[10:40:24] RsyncTask:prepare(): saved: /tmp/VxpHDt21/2022-04-28_10-40-24/script.sh
[10:40:24] AsyncTask: child_pid: 84792
[10:41:02] AsyncTask: finish(): enter
[10:41:02] exit_code: 0
[10:41:03] Removed '2022-04-28_10-21-58'
[10:41:03] ------------------------------------------------------------------------------
[10:41:03] SnapshotRepo: load_snapshots()
[10:41:03] loading snapshots from '/run/timeshift/backup/timeshift/snapshots': 1 found
[10:41:03] SnapshotRepo: load_snapshots()
[10:41:03] loading snapshots from '/run/timeshift/backup/timeshift/snapshots': 1 found
[10:41:03] Symlinks updated
[10:41:03] exit_app()
[10:41:03] crontab -l
[10:41:03] Failed to read cron tab
[10:41:03] crontab -l
[10:41:03] Failed to read cron tab
[10:41:03] Cron task exists: /etc/cron.d/timeshift-hourly
[10:41:03] Cron task exists: /etc/cron.d/timeshift-boot
[10:41:03] unmount_target_device()
[10:41:03] clean_logs()
[10:41:03] rm -rf '/tmp/VxpHDt21'

My garuda-inxi info:

╰─λ garuda-inxi
System:
Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=20aec52d-3c03-4c92-9591-0f03b67c1af2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: P55-US3L serial: <superuser required>
BIOS: Award v: FE date: 03/05/2010
CPU:
Info: model: Intel Core i5 750 bits: 64 type: MCP arch: Nehalem family: 6
model-id: 0x1E (30) stepping: 5 microcode: 0xA
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 2798 min/max: 1197/2661 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 2798 2: 2798 3: 2798
4: 2798 bogomips: 21319
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds
status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730] vendor: Gigabyte
driver: radeon v: kernel alternate: amdgpu pcie: gen: 2 speed: 5 GT/s
lanes: 16 ports: active: HDMI-A-1 empty: DVI-I-1,VGA-1 bus-ID: 01:00.0
chip-ID: 1002:68d8 class-ID: 0300
Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1.2:3 chip-ID: 046d:0843 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-0 model: AOC 2757M serial: <filter>
built: 2012 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL:
renderer: AMD REDWOOD (DRM 2.50.0 / 5.17.4-zen1-1-zen LLVM 13.0.1)
v: 3.3 Mesa 22.0.2 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
class-ID: 0403
Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series] vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 1002:aa60 class-ID: 0403
Device-3: Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series]
driver: snd_ca0106 v: kernel bus-ID: 06:04.0 chip-ID: 1102:0007
class-ID: 0401
Device-4: Philips s SAA7131/SAA7133/SAA7135 Video Broadcast Decoder
vendor: Avermedia DVB-T Super 007 driver: saa7134 v: 0, 2, 17
bus-ID: 06:05.0 chip-ID: 1131:7133 class-ID: 0480
Device-5: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1.2:3 chip-ID: 046d:0843 class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: ee00 bus-ID: 02:00.0
chip-ID: 10ec:818b class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: ce00 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Drives:
Local Storage: total: 447.13 GiB used: 152.29 GiB (34.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: GOODRAM model: N/A size: 447.13 GiB
block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD
serial: <filter> rev: 01.7 scheme: MBR
Partition:
ID-1: / raw-size: 195.31 GiB size: 195.31 GiB (100.00%)
used: 66.42 GiB (34.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.68 GiB used: 1.78 GiB (15.3%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 63.0 C mobo: N/A gpu: radeon temp: 58.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 303 Uptime: 1h 37m wakeups: 0 Memory: 11.68 GiB
used: 3.61 GiB (30.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: apt: 0 pacman: 1777 lib: 388
Shell: fish v: 3.4.1 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2021-05-29
Last full system update: 2022-04-28 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Timeshift
Failed units:            bluetooth-autoconnect.service

Any idea how to solve that?
Best regards

BTW. Yesterday I was forced to work on Windows because of Linux crash. And I have to addmit it was horrifying ! I had never thought that after using Garuda around a 1 year now I love it so much! :slight_smile: So Thank you guys from Garuda Team for that awesome distro!!!

1 Like

Hmm, I wonder if the fact that you restored to a new partition caused some wonkiness. Did you compare lsblk -f with /etc/fstab to make sure UUIDs are accurate for your subvolumes?

Is this the correct target for your snapshot? There is also a subvolume found on another partition:

Have you tried deleting (or otherwise removing) any old snapshots and starting over?

2 Likes

Bellow my lsblk -f with /etc/fstab


My /dev/sda2 is snapshot storrage (to keep them separated just in case like that).
/dev/sda3 is my main point:

Yes, sda2 is correct then.

Yes, removed 2 old snapshots. I wanted be 100% sure there will be enought space to store a snapshot (in my case one backup is arount 80GB in current shape, older was much ligher). Also removed them because at first system complained that there were less than 8,5 Gb of free space, which was weird while I'm almost sure there were at least more than 50Gb of free space.

I have also shrinked my main point (sda3) to around 200Gb and resized sda2 to ~250Gb. So basically moved 100Gb from system to backup storrage:


That's it.

Reminder:
No pictures from terminal output. Please.

1 Like

SGS sorry , I've thought that's be fine while it's not inxi.. Should I paste text again? Besides that way was convinent to show comparison between 2 outputs.

Text for outputs is the recommended method.

I think your non-standard approach to restoring your system is responsible for your issues as well.

3 Likes

I believe it so, but here I am. There wasn't much I could do. Terminal outputs was usulally : command not found, or missing something. Simple upgrade system failed. So decided to reinstall it and restore from snapshot. At least my system now is working. So it was good call in my opinion. If it would be simple situation I would't post a new topic. I know you guys have great knowledge about system :wink:

I do not have much experience dealing with your type of scenario as I keep proper backups in case of a full system melt down. I simply restore my system from a working backup if a snapshot does not work.

Snapshots are not a proper backup, you need to make proper backups on an external drive. Sorry, I know that's not very helpful in your current situation, but it's something to consider for the future.

2 Likes

All my others 7 hdd are bying backuped. I used for that purpose Macronium Reflect which is awesome tool while everything go wrong. Unfortunatelly it doesn't support btrfs file system. That's why I pay more attention for snapshot in case of garuda partition. Have to admit I'm impressed how well it works! In the end of the day my system is fully restored, right? Personally for me it's victory :slight_smile:

But now would like to create a new snapshot, and I can't . That's why I'm asking for help or suggestion.

As I wrote on the begining - looks like cron problem, not timeshift itself. As you see at log - backup WAS created! Also I was able to see it on dedicated partition where snapshot are stored. The problem is fact that while I send command :slight_smile:

crontab -e

a blank file is opened with name file:///tmp/crontab.yv9qWM. Is taht normal? I mean this weird extention. What should be inside crontab file?
I highly belive we should focus on crontab. Timeshift looks ok for me :wink:

At least it's my best shoot.

Additionaly I have checked

✦  ╰─λ cat /etc/cron.d/timeshift-hourly
File: /etc/cron.d/timeshift-hourly
SHELL=/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=""

0 * * * * root timeshift --check --scripted

and

✦  ╰─λ cat /etc/cron.d/timeshift-boot
File: /etc/cron.d/timeshift-boot
SHELL=/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=""

@reboot root sleep 10m && timeshift --create --scripted --tags B

Nothing fancy here.

Just a thought, but have you considered migrating to snapper if timeshift is causing you these kinds of issues.

2 Likes

Bying honest I know nothing at all about snapper. I need to educate myself :wink: So I'm not able to
replay on your question.

This can't be right. Your etc/fstab only has one entry?

1 Like

Indeed , just single entry.

✦  ╰─λ cat /etc/fstab
File: /etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>

UUID=20aec52d-3c03-4c92-9591-0f03b67c1af2   /   btrfs   subvol=/@,defaults,noatime,space_cache,noautodefrag,co
mpress=zstd,ssd   0   1
tmpfs   /tmp    tmpfs   defaults,noatime,mode=1777  0   0

In that case, not being able to create a new snapshot is the least of your worries; that system won't even survive a reboot unless you are able to fix that up a bit. At the very least you need to get your EFI partition back in there.

What's odd is a fresh installation of Garuda would have a much more fleshed-out fstab entry than this, so restoring the snapshot is actually breaking your system somehow.

2 Likes

Ok, but as far as I know I don't use EFI. I have GPT if that make a difference.

This appears to be an EFI partition:

How did you do that? Installer? Which version? What did you choose during installation?

How did you do that? What command, or with which program?

Why do you think cron is the problem, since cron is only responsible for automation and you can't create a snapshot manually?

And the most important question is "What type of snapshots" had you configured and using with Timeshift? btrfs or rsync?
Also, was the original system installed on a Garuda btrfs partition/subvol layout, or on a single partition, or something else?

Do you see where I am going with this?... :wink:

3 Likes

Perhaps this bug:

That only applies if using rsync.

I have prepared one year ago bootable usb stick with garuda image. I'm not sure about version , but it was rather old as it was so long ago :wink: Options which I have chossen were rather standard like location, language +some addition package. Different only was disk manual assignment. Above in my past respond there is screen of it. Bellow again it's pasted for following explanation.

Simply. Firstly updated & upgaded fresh system to current version. After that I used Timeshift gui to restore that snapshot. The same off course I could achieve with timeshift restore command but at that moment I was more convinent to use gui. Previously I used both (command and gui) and they worked perfectly fine.

Well that was my susicious object while in rsync log file pointed that. Also my cron table were empty so I've thought that might be a some reason..

Rsync, always, while I'm able to restore all system back and save snapshot on different partition. Bying honest I don't understand of atomic btrfs and why should I preffer it above rsync? Ok I do realize that time to restore here matters, but if everything will go terribly wrong (like my case) then I'm totally grounded, aren't I?


As you see : yes-btrfs, single partition (/dev/sda3). Sda2 is my storrage for timeshifts, sda1 is dedicated for grub.

Actually I'm not, Please, light me up :wink:

tbg - thank you sir! for that link!!
At first thought -"no way .." :wink: But after that checked rsync version which was 3.2.4. Thats why decided to downgrade it as adviced in your link.

sudo downgrade rsync

Choosed :

rsync (3.2.4-1 => 3.2.3-4)

After that one more time attempted with creating a new snapshot with (sorry for PL lang , but that moment I forgot to switched and what's more didn't believe it going to work :wink:):

╰─λ sudo timeshift --create --comments "po powaznej awrii systemu po przywruceniu z backupu" --tags D
[sudo] hasło użytkownika zawier:

/dev/sda2 is mounted at: /run/timeshift/backup, options: rw,relatime

------------------------------------------------------------------------------
Creating new snapshot...(RSYNC)
Saving to device: /dev/sda2, mounted at path: /run/timeshift/backup
Synching files with rsync...
Created control file: /run/timeshift/backup/timeshift/snapshots/2022-05-06_19-25-54/info.json
RSYNC Snapshot saved successfully (1030s)
Tagged snapshot '2022-05-06_19-25-54': ondemand
------------------------------------------------------------------------------

But as you can see it was succesfull! :pray:

I'm going to upgrade system one more time and chack if the problem be back again. I'm curious about that what will heppen.. I will let know about results after done.

Any way thank you ALL who responded on that post. I was really lost then. And vision of reinstalling everything one more time was horrible once I have spend countless hours solving many problems during my jurney with garuda . I have to admit and say it loud - I've folloved in love with that geourges distro! :heart: I swear! Thank you Garuda Team one more time!!!

2 Likes