After a night off, I can't boot Garuda

Looks like after using my computer on battery power, I closed the lid and left it unplugged overnight. This morning, I can't boot into any kernel or restore my system from a snapshot.

I get a dark grey screen followed by a black screen after choosing an option from grub and hitting enter. Can't seem to get a terminal up either, or boot from a USB.

Hardware is a 2015 Macbook pro retina, running Garuda XFCE on bare metal. Please let me know if there is anything I can do to get running again. Thanks!

Please provide specific details/examples/cases with what you have tried and what doesn't work.

For example, if you can't boot a USB live environment then this isn't an issue with the Garuda installation.

3 Likes

I've tried using the Grub menu booting into the 3 kernels I have installed, as well as their images. I also tried using a timeshift snapshot to restore from a couple days ago.

I plugged in a Manjaro USB, selected it as my boot from the mac "control" choice, and it starts to load then quits.

Beginning to think it may be hardware (battery?) as the Macbook has been on a/c for a while now and still seems to be charging.

Thanks

1 Like

It might be a hard drive fail try replacing it?

1 Like

It may be, I'm still investigating. I've been able to boot into MacOS via a clone on an external drive. Mac disk utility shows the internal drive as a small linux swap partition.

I'm going to try a restart back into Garuda, and if that fails, try to restore an earlier snapshot once again. If that fails, I'll try to do a full reinstall and go from there.

update: I'm still unable to boot or restore any version of garuda from the grub menu.

I've created a Garuda live USB and booted into it, (it's the KDE Dragonized version). I tried the chroot route outlined here;https://forum.garudalinux.org/t/computer-doesn-t-boot-boots-to-a-black-screen-or-stops-at-a-message/2953 with no success. I'm taking this as a learning experience, and would like to try to restore my broken system. Any further advice would be appreciated. Thanks

What did you try, and what didn't work? Most issues can be solved via a chroot (as you're operating on the installation as if you had it booted).

1 Like

I can't get into a terminal on boot (although the system seems to be running)
First step in the chroot app on the Welcome screen:

grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
==> Mounting (Garuda_Linux) [/dev/sda2]
 --> mount: [/mnt]
mount: /mnt: /dev/sda2 already mounted on /mnt.
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]
 --> mount: [/mnt/root]
 --> mount: [/mnt/srv]
 --> mount: [/mnt/var/cache]
 --> mount: [/mnt/var/log]
 --> mount: [/mnt/var/tmp]
mount: /mnt/dev: udev already mounted on /mnt/dev.
[[email protected] /]# reflector --country US -a6 -f5 --save /etc/pacman.d/mirrorlist
[2021-03-12 10:50:44] WARNING: failed to rate http(s) download (https://mirrors.lug.mtu.edu/archlinux/community/os/x86_64/community.db): Download timed out after 5 second(s).

Then:
[[email protected]garuda-dr460nized /]# reflector --country US -a6 -f5 --download-timeout 60 --save /etc/pacman.d/mirrorlist
[2021-03-12 10:52:06] WARNING: failed to rate http(s) download (https://mirrors.lug.mtu.edu/archlinux/community/os/x86_64/community.db): <urlopen error timed out>

(A FEW OF THESE)

Skipping past the above attempts to update,

[[email protected] /]# pacman -Syyu
:: Synchronizing package databases...
 core                                  131.1 KiB   749 KiB/s 00:00 [------------------------------------] 100%
 extra                                1646.1 KiB  5.54 MiB/s 00:00 [------------------------------------] 100%
 community                               5.4 MiB  9.57 MiB/s 00:01 [------------------------------------] 100%
 multilib                              151.4 KiB  7.04 MiB/s 00:00 [------------------------------------] 100%
 chaotic-aur                           918.5 KiB   369 KiB/s 00:02 [------------------------------------] 100%
:: Starting full system upgrade...
warning: paleofetch-garuda: local (r196.aaaae08-1) is newer than chaotic-aur (r3.6471340-1)
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: performance-tweaks and auto-cpufreq-git are in conflict

That seemed like a good point to stop.

Also tried the grub repair on the welcome screen, nothing worked
I can see my filesystem on Dolphin.
Timeshift running from USB can't find any snapshots.

Are you booting in BIOS/legacy mode with a GPT partition table?

It's a warning, letting you know (in this case) that the mirror timed out (like how a website sometimes won't load).

This has been covered on the forum a few times already, and should be visible using the forum search function (e.g. there are threads with that exact title).

2 Likes

I believe it's an efi boot ( when I use the option/boot combo on the mac, I get two icons, both are labeled efi boot

I got a rash of timeouts at 5 sec, but going to 60 sec didn't fix the issue.

I'll look up that topic, but is it something that needs to be addressed to get to a normal boot?

Thanks

There's no way of knowing until it has been fixed.

2 Likes

Tried again with updates after fixing the performance-tweaks and auto-cpufreq-git are in conflict, failed for a couple different reasons.

I've decided to install the KDE version to play around with.

I'd love to know what caused the complete system failure after closing the lid of the computer and not being on battery overnight. Seems to be a hibernation or related issue,

Thanks for your help, sorry I couldn't take it further.

1 Like