Retroarch-autoconfig-udev-git invalid or corrupted package

tried updating from garuda assistant. this error, can't update.

error: retroarch-autoconfig-udev-git: signature from "Pedro Henrique Lara Campos <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/retroarch-autoconfig-udev-git-r2004.d0a8540-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
Press enter to exit

tried this thread, not solved

inxi faz

Try if this tutorial helps

1 Like


sudo pacman -Sy archlinux-keyring chaotic-keyring
sudo pacman -Syu

same error.

  1. checked on google, system time is accurate
  2. file doesn't exist maybe because i press y to delete while updating.
sudo pacman-key --refresh-keys --keyserver hkps:// 

solved, though i saw a failed notification of previous command.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.