Garuda-common-settings-r91.33e02af-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)

Well I guess if you can't figure out a proper solution you could temporarily ignore the package, but that's not really recommended.

Okay, for now I will ignore garauda-common-settings & garuda-kde-settings

Having same issue.

Perhaps someone should contact "Pedro Henrique Lara Campos [email protected]". The signature is invalid.

1 Like

How to update my Garuda? I have fresh install and i want to install something or update all packages.
What i should do?

Here the same. Tried the solutions but nothing works yet. Anyone a workaround ?

There is a way how to ignore this damaged packages, just skip?

The entry for "garuda-common-settings" was outdated in the database, please try again (after -Sy).

4 Likes

It's working i successfully run sudo pacman -Syu!

2 Likes

I just installed Garuda and I am getting the same issue, but with a different package:

retroarch-autoconfig-udev-git-r1862.c1131d5-1-any 79,3 KiB 211 KiB/s 00:00 [----------------------------------------------] 99%
(454/454) checking keys in keyring [----------------------------------------------] 100%
(454/454) checking package integrity [----------------------------------------------] 100%
error: retroarch-autoconfig-udev-git: signature from "Pedro Henrique Lara Campos [email protected]" is invalid
:: File /var/cache/pacman/pkg/retroarch-autoconfig-udev-git-r1862.c1131d5-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

1 Like

Did you sudo pacman -Syu again?

2 Likes

I did try that multiple times, still the same issue :confused:

I am trying to update my system after a fresh install.

I also had same issue with a different package retroarch-autoconfig-udev-git-r1862.c1131d5-1-any.pkg.tar.zst

The things I tried are :


1. Refresh Packman keyring

sudo pacman-key --refresh-keys

2. Install chaotic-keyring (install or upgrade)

sudo pacman -Sy chaotic-keyring

3. Query the Package

command

pacman -Q chaotic-keyring;

output

chaotic-keyring 20201229-1

4. Delete the key associated with it, and again populate

sudo pacman-key --delete EF925EA60F33D0CB85C44AD13056513887B78AEB;
sudo pacman-key --populate chaotic;

5. Tried same command multiple times.

sudo pacman -Syu; 

Result



error: retroarch-autoconfig-udev-git: signature from "Pedro Henrique Lara Campos <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/retroarch-autoconfig-udev-git-r1862.c1131d5-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded

I am unable to solve it, please help.

1 Like

answer y
then try again
with

sudo pacman -Syyuu
7 Likes

Thank you so much ! This worked !!

And thank you for your so fast reply !

Hi, I am also having the same issue with a new install, with file garuda-setup-assistant-r24.1ab4be6-1-any.pkg.tar.zst. I have tried all the suggestions in this post, but keep coming back to the same error.

Please open new thread this one is solved, read

and post

inxi -Fxxxza

and
:slight_smile:

2 Likes