Restoring default Konsole ASCII art

Sorry if this is a really trivial topic but I rather liked the default ASCII art that came with Konsole. Somehow it's gone now and I'm trying to restore it. I've tried resetting configs with Garuda assistant, I searched this forum, and tried the solution in this post:

I tried reinstalling the Konsole package in octopi. I've also spent a good deal of time poking around in all of the konsole settings where I learned about some cool customization options in the process but couldn't find anything pertaining to the ASCII startup art that's the default on Garuda.

System:
Kernel: 5.15.50-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=285dc42e-3e8b-4156-b54a-00cb7a9ca722 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> BIOS: American Megatrends v: 4801
date: 03/02/2022
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3 gen: 4
built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
stepping: 2 microcode: 0xA201205
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3611 high: 3888 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3888 2: 3593
3: 3592 4: 3592 5: 3592 6: 3592 7: 3585 8: 3591 9: 3591 10: 3591 11: 3592
12: 3586 13: 3740 14: 3596 15: 3592 16: 3588 17: 3660 18: 3588 19: 3592
20: 3578 21: 3586 22: 3589 23: 3587 24: 3593 bogomips: 177262
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA 2
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,HDMI-A-1 empty: DP-1,DP-3 bus-ID: 11:00.0
chip-ID: 1002:73bf class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,right
model: Sceptre L27 built: 2020 res: 1920x1080 dpi: 81 gamma: 1.2
size: 600x330mm (23.62x12.99") diag: 685mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: Sceptre L27
serial: <filter> built: 2020 res: 1920x1080 dpi: 81 gamma: 1.2
size: 600x330mm (23.62x12.99") diag: 685mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 6900 XT (sienna_cichlid LLVM 13.0.1 DRM
3.42 5.15.50-1-lts)
v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: bus-ID: 3-2:3 gen: 4 chip-ID: 0d8c:0158 class-ID: 0300 speed: 16 GT/s
lanes: 16 bus-ID: 11:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 14:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: C-Media Hifi Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.15.50-1-lts running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 0a:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 9.1 TiB used: 28.79 GiB (0.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Smart Modular Tech.
model: SHGP31-1000GM-2 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 41062C20 temp: 45.9 C scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Smart Modular Tech.
model: SHGP31-1000GM-2 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 41062C20 temp: 43.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000NE001-2MA101
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: EN01 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST4000NE001
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: SN07 scheme: GPT
Partition:
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 28.79 GiB (3.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 28.79 GiB (3.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 28.79 GiB (3.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 28.79 GiB (3.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 58.0 C
mem: 60.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 472 Uptime: 52m wakeups: 0 Memory: 31.27 GiB
used: 5.93 GiB (19.0%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1986
lib: 550 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-06-17
Last full system update: 2022-06-26 โ†ป
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Do you mean you are not getting the Neofetch MOTD when you open the terminal?

(This:)

                                                   [email protected]
                     .%;888:8898898:               -----------------------
                   x;XxXB%89b8:b8%b88:             OS: Garuda Linux x86_64
                .8Xxd                8X:.          Host: Framework FRANBMCP0B
              .8Xx;                    8x:.        Kernel: 5.18.6-zen1-1-zen
            .tt8x          .d            x88;      Uptime: 1 min
         [email protected];          .db:              [email protected];    Packages: 1281 (pacman)
       ,tSXXยฐ          [email protected];   Shell: bash 5.1.16
     .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;   Resolution: 2256x1504
   ,888S                                     pd!   DE: sway (Wayland)
  8X88/                                       q    Theme: Nordic-darker [GTK2/3]
  GBB.                                             Icons: Tela-circle-dark [GTK2/3]
   x%88        [email protected]@[email protected]@[email protected]@[email protected]@[email protected]@X.         Terminal: alacritty
     dxXd    dB8b8b8B8B08bB88b998888b88x.          Terminal Font: JetbrainsMonoNL
      dxx8o                      [email protected]@;.             CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700
        dx88                   [email protected]               GPU: Intel TigerLake-LP GT2 [Iris Xe Grap
          d:[email protected]                 Memory: 2986MiB / 15784MiB
            .d988999889889899dd.


I think the relevant config to reset in Garuda Assistant would be Fish. Did you try that yet?

G is neofetch.git
Eaglehead is neofetch

But maybe my translation app failed :slight_smile:

2 Likes

Wow, that's awesome! Not to drag the thread off-topic, but I did not realize the eagle was still available. I love it!

                  __,,,,,,,_                         [email protected]
            _โ•“โ•—โ•ฃโ•ซโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ••โ•—โ•—โ”_                  -----------------------
         โ•ฅโ•ขโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฅ,               OS: Garuda Linux x86_64
       โ•—โ• โ• โ• โ• โ• โ• โ• โ•โ•œโ•œโ•œโ•œโ•โ•ขโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ”             Host: Laptop AB
      โ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ•ขโ•ฃโ•ขโ•—โ•• , `"โ•˜โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•”โ•ฅ_          Kernel: 5.18.6-zen1-1-zen
    โ•’โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ••โ•™โ•ฅโ•ฅโ•œ   `"โ•œโ• โ•ฌโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฅ,       Uptime: 10 mins
    โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—โ•ฅโ•ฅโ•ฅโ•ฅโ•—โ•—โ•ฌโ• โ• โ• โ• โ• โ• โ• โ•โ•™โ• โ• โ•ฃโ• โ• โ• โ• โ•ขโ”     Packages: 1281 (pacman)
   โ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฅโ•ฌโ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ•—    Shell: bash 5.1.16
  โ•’โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—   Resolution: 2256x1504
  โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•    WM: sway
  โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฌ     ```"โ•œโ•โ•ขโ• โ• โ•ก   Theme: Nordic-darker [GTK2/3]
 โ•’โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฃ,         โ•˜โ• โ•ช    Icons: Tela-circle-dark [GTK2/3]
 โ•žโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ขโ”        โ•œ     Terminal: alacritty
 `โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—             Terminal Font: JetbrainsMonoNL
 ,โ•ฌโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• "โ••            CPU: 11th Gen Intel i7-1165G7 (8) @ 4.7
 โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—              GPU: Intel TigerLake-LP GT2 [Iris Xe Gr
 โ•^โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•โ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ก              Memory: 2892MiB / 15784MiB
  โ•”โ•œ`โ•žโ”˜โ•ขโ•›โ•œ โ•กโ•ขโ• "โ•šโ• โ• โ•œโ•โ”Œโ•žโ•ž"โ•ขโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฃโ•ฉโ•ขโ•ช
     โ•œโ•’"   `โ•œ    `      โ•œโ•™โ••  โ””โ•ฃโ• โ• โ• โ• โ•• โ•žโ•™โ•–
                                โ• โ• โ• 
                                 โ•œ
1 Like

Yes, this is the image I meant. I did try resetting configs for Fish in Garuda Assistant to no avail.

Try to take a reboot after and see if it makes any difference.

open new konsole if you edit ~/.config/fish/config.fish

So I tried resetting fish configs again and restarting with no results. I also tried reinstalling the neofetch-git package with no results either. I might try installing the regular neofetch package to see if there's an eagle.

Edit: I went ahead and did this along with a restart and still no change.

Search there with Kate for "neofetch"

if status --is-interactive
  neofetch
end
2 Likes

Can you take a peek at your Fish config?

micro ~/.config/fish/config.fish

The last few lines should say something like this:

## Run neofetch if session is interactive
if status --is-interactive && type -q neofetch
   neofetch
end

EDIT

SGS I didn't see your post, I just parroted you. :joy: :parrot:

2 Likes

This is what my last few lines read:

## Run fastfetch if session is interactive
if status --is-interactive && type -q fastfetch
   fastfetch --load-config neofetch
end

I changed the config to the settings you guys provided and it worked. Thank you!

edit: I also went back to mark solutions in my older forum posts.

Edit to @BluishHumility text.
Save!
Then open new konsole.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.