Proton-ge not updating (possible dep issues)

Greetings all.

Recently, I went to update proton--ge-custom and got the following message:

error: can't build python-fontpens-0.2.4-3, deps not satisfied: python-fontparts
error: can't build python-fontparts-0.10.8-1, deps not satisfied: python-fontpens
error: can't build python-ufoprocessor-1.9.0-5, deps not satisfied: python-fontparts
error: can't build afdko-3.9.1-1, deps not satisfied: python-fontparts  python-fontpens  python-ufoprocessor
error: can't build proton-ge-custom-2:GE.Proton7.39-2, deps not satisfied: afdko
error: packages failed to build: python-fontpens-0.2.4-3  python-fontparts-0.10.8-1  python-ufoprocessor-1.9.0-5  afdko-3.9.1-1  proton-ge-custom-2:GE.Proton7.39-2

From this Brodie Robertson upload Arch Linux Has a Problem and Git is to Blame, it seems that Proton's failure to update comes from submodule dependencies, python-fontpens, python-fontparts, and possibly python-ufotools. But I could also be wrong.

Thus far I tried the following command git config --global protocol.file.allow always as a quick and dirty fix, but that didn't seem to do the trick. I also tried other AUR helpers, namely yay, but to no avail.

As a quick fix, I installed protonup. But I'd really prefer a more sustainable solution (preferably one I can understand. Thank you all for your time.

We're having some issues building packages. Take a look at this thread: Pamac wants to update Proton-Ge-Custom - #13 by Technetium


Using ProtonUp-Qt is not a possibility? It works quite well and I think it is quite handy. Every games should have it installed IMO.

So, I was able to fix the situation by removing proton-ge-custom and replacing it with proton-ge-custom-bin. Since the bin version is already compiled, the dependencies were already baked in. So those python dependencies were no longer a problem.

wine-ge-custom-1:GE.Proton7.34-1 is done compiling now!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.