Problems with Garuda installation

I have problems installing Garuda XFCE on my Dell Latitude E6340. I have 3 partitions on my hard drive, one empty, one with Windows and one with Antix. After the first installation on the empty partition I got a black screen and the message "Invalid partition table".
I reinstalled it again, now it asked me to make an EFI Fat32 partition again, I did it. I could not access it either, I did a reinstall of Grub from Antix and now I can only access Antix. From Garuda I cannot reinstall Grub.
Any advice? Thanks.

Maybe there is no solution?

Are you trying to manually partition your drives? If yes, why not let calamares automatically handle it? If you are not doing such a thing then please use your garuda live usb to provide the following details

lsblk -f

also the contents of /etc/fstab would be nice you can obtain this from either chroot or through TTY.

To chroot into your system from live usb you can either search forum for the topic chroot or just use the chroot option available in garuda's welcome application.


2 posts were split to a new topic: Problem with the latest ISO

Thank you. Here is the information. Sorry, I tried to restore grub doing chroot but I can't do it, maybe I don't understand the process.

  Kernel: 6.1.26-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda root=miso:LABEL=GARUDA_XFCE_RAPTOR quiet
    systemd.show_status=1 ibt=off systemd.unified_cgroup_hierarchy=1
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude E6430 v: 01
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 0CPWYR v: A00 serial: <superuser required> BIOS: Dell
    v: A22 date: 02/21/2018
  ID-1: BAT0 charge: 26.3 Wh (100.0%) condition: 26.3/62.2 Wh (42.2%)
    volts: 12.4 min: 11.1 model: Sanyo DELL NH6K933 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i7-3540M bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1200 min/max: 1200/3700 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 1200 2: 1200 3: 1200 4: 1200 bogomips: 23930
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: LVDS-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3,
    VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: LG Display 0x033e built: 2012 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1366x768
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  API: ALSA v: k6.1.26-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
    v: kernel port: f060 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter vendor: Dell
    driver: bcma-pci-bridge v: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:4727 class-ID: 0280
  IF-ID-1: wlp2s0b1 state: up mac: <filter>
  Local Storage: total: 247.34 GiB used: 4.16 GiB (1.7%)
  ID-1: /dev/sda maj-min: 8:0 type: USB vendor: Toshiba model: TransMemory
    size: 14.45 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS250G2B0A-00SM50 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
    scheme: MBR
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 53.0 C mobo: 38.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 2698
  Processes: 226 Uptime: 19m wakeups: 1 Memory: 7.67 GiB used: 2.4 GiB (31.3%)
  Init: systemd v: 253 default: graphical tool: systemctl Compilers:
  gcc: 12.2.1 Packages: pm: pacman pkgs: 1286 libs: 359 tools: paru
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.26
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.16-1):
  System install date:     2023-08-19
  Last full system update: 2023-08-19 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            snapper-cleanup.service 

     vfat   FAT12 MISO_EFI
│    vfat   FAT32       552D-739B                                           
│    ntfs         SYSTEM
│                       4858A27A58A26682                                    
│    ext4   1.0   rootantiX21
│                       c2dcb6c9-9994-48ea-a960-54686d4b19f2                
     btrfs              05c90dcc-bb1d-45a2-846d-572e9fb6eb56   78.3G     5% /mnt

 ╭─garuda@garuda in ~ as 🧙 took 12ms

# /etc/fstab: static file system information
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/mapper/root-image /             auto      defaults           0      0

Well, it seems I got it right, I installed Grub by doing grub-install /dev/sdb, I can now access Garuda, however it recognizes Antix but not Windows.

Is this really the fstab entry from the chroot terminal? because if it is then it's empty there is no mount point for any subvolumes created at all which would explain why you can't boot into your system.

  1. enter chroot, don't bother with repairing grub.
  2. using your favorite text editor in terminal open the /etc/fstab file. garuda comes with micro and nano by default so you can use them or download something of your choice like vim using pacman.
  3. make sure your fstab entry is similar to this
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=xxxx-xxxx                            /boot/efi      vfat    umask=0077 0 2
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /              btrfs   subvol=/@,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd,discard=async,ssd 0 0
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

I have places xxx in place of actual UUID values because the one's you provided via lsblk -f were kind of hard to map to their respective drives. So I have left that job to you.

please look at the output of lsblk -f to properly fill this

  • Replace UUID of /boot/efi entry with the UUID of /dev/sdb1
  • The UUID for entry / upto /var/tmp would be replaced with the UUID disk that's labelled as btrfs by the output of lsblk -f
  • The UUID for entry swap will be the UUID of the disk labelled swap. If it's not or you haven't chosen swap at all while installing garuda then you can remove this entry. Please be careful and don't accidentally consider zram in the output of lsblk to be your swap partition, you don't have to care about zram.

and that's it save the file and exit chroot then try to reboot.


Yes, the output of etc/fstab was the one from the USB, sorry, I got confused.
Everything seems to be fine now, but still no Windows appears in Grub, I don't know what the problem is.

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=552D-739B                            /boot/efi      vfat    defaults,noatime 0 2
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=05c90dcc-bb1d-45a2-846d-572e9fb6eb56 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

│    vfat   FAT32             552D-739B                             498,4M     0% /boot/efi
│    ntfs         SYSTEM      4858A27A58A26682                                    
│    ext4   1.0   rootantiX21 c2dcb6c9-9994-48ea-a960-54686d4b19f2                
     btrfs                    05c90dcc-bb1d-45a2-846d-572e9fb6eb56                /var/log

 ╭─luis@luis in ~ took 16ms

so I can assume you are able to boot into your garuda machine? If yes then from inside your garuda machine

can you check if this

sudo os-prober

detects windows? If it does then can you check

grep GRUB_DISABLE_OS_PROBER /etc/default/grub


# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this

Please note there should be no # in front of GRUB_DISABLE_OS_PROBER=false line otherwise it means this line is commented out.

You can also just post the outputs of the commands if you feel confused.

If everything matches then can you please perform

sudo update-grub

and post it's output

1 Like

Windows is not detected.

sudo os-prober
[sudo] contraseña para luis:       
/dev/sda3:antiX 21 (21):antiX:linux

Hmm that's strange. Can you check if


detects your windows boot loader? If you can then maybe we should go for manually adding windows to grub.

1 Like


EFI variables are not supported on this system.

Ah my bad I didn't notice that you were using BIOS and not UEFI. Can you check if you can boot into your windows installation at all from your BIOS? I am asking because it's quite possible the windows boot loader has somehow been deleted which is perhaps why os-prober is unable to detect it.

1 Like

I can't, the only one that appears is Garuda.

Which means I was right and your windows boot loader has been somehow removed. :sweat: . The garuda entry refers to grub which is needed to boot linux like operating systems that's why you can still boot into your two linux installations and not the windows one.

The suggestions I am about to give out are going to be lengthy but that's the only way out I can think of at the moment if you can find a faster recovery process online or someone else can offer a more efficient method please do so.

  1. boot into your linux system and mount the ntfs partition of the drive somewhere you want on your filesystem using mount command and then backup important personal data that you need. Also backup your data from linux installations just in case.

  2. Reinstall windows, no other way around it sadly windows doesn't have any boot repair options.

  3. Once done you will notice that now only windows is available on your system and grub is gone, don't panic windows does this $h*t its known for causing issues when multibooting. Use your garuda live USB to chroot into your system and reinstall grub.

Yes, you don't need to reinstall your two linux OSes just reinstalling grub would do. Finally boot into your system using grub and see if you can detect windows.

1 Like

I was fearing that had been the problem.
Well, I hardly used that partition with Windows, but yes, I will save the information there and reinstall it, if there is no other choice.
By the way, should I use UEFI instead of Bios or does it make no difference?

I honestly don't think you should touch your BIOS or UEFI unless you are facing unexplainable errors while using your system. Don't fix what ain't broke. Plus the switch you are mentioning is quite dangerous and could brick your system forever not something I would recommend.

Additional hint. When possible use 2 different physical drives for Linux / Win dual boot. In my case Grub picks up all system OSes and adds them to the boot menu. It works well for me.

When I need to delete or reinstall any of the OS'es I can do it indepenent of the other drive.

Ok, I will leave everything as it is and when I have time I will fix the Windows issue.
Thanks for all your help!

Thanks for the advice, I will take it into consideration, although it is complicated to do it on a laptop. Regards.

1 Like