Problem with updates

hello all.
I am having problem with updates/
pacman.conf:

# /etc/pacman.conf
# 
# 
# See the pacman.conf(5) manpage for option and repository directives

# 
# GENERAL OPTIONS
# 
[options]
# RootDir = /
# DBPath = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
# LogFile = /var/log/pacman.log
# GPGDir = /etc/pacman.d/gnupg/
# HookDir = /etc/pacman.d/hooks/
HoldPkg = pacman glibc garuda-system
# XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
# XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
# CleanMethod = KeepInstalled
Architecture = auto
#IgnorePkg   =
#IgnorePkg   =
# IgnoreGroup = 
# NoUpgrade = 
# NoExtract = 
# UseSyslog
Color
TotalDownload
CheckSpace
ILoveCandy
# VerbosePkgLists
SigLevel = Required DatabaseOptional
LocalFileSigLevel = Optional
# RemoteFileSigLevel = Required

# [testing]
# Include = /etc/pacman.d/mirrorlist

# [kde-unstable]
# Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

# [community-testing]
# Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# [multilib-testing]
# Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# [custom]
# SigLevel = Optional TrustAll
# Server = file:///home/custompkgs

[chaotic-aur]
SigLevel = Never
Include = /etc/pacman.d/chaotic-mirrorlist

updates are failing:

upd
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2021-03-08 22:27:19 UTC
# From:       https://www.archlinux.org/mirrors/status/json/
# Retrieved:  2021-03-08 22:27:09 UTC
# Last Check: 2021-03-08 20:31:59 UTC

Server = https://mirror.pkgbuild.com/$repo/os/$arch
Server = https://mirror.pseudoform.org/$repo/os/$arch
Server = https://arch.mirror.constant.com/$repo/os/$arch
Server = https://arch.mirror.square-r00t.net/$repo/os/$arch
Server = https://mirrors.neusoft.edu.cn/archlinux/$repo/os/$arch
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: kcmutils-git and kcmutils are in conflict. Remove kcmutils? [y/N] y
:: kdeclarative-git and kdeclarative are in conflict. Remove kdeclarative? [y/N] y
:: kio-git and kio are in conflict. Remove kio? [y/N] y
:: solid-git and solid are in conflict. Remove solid? [y/N] y
:: kjobwidgets-git and kjobwidgets are in conflict. Remove kjobwidgets? [y/N] y
:: kcoreaddons-git and kcoreaddons are in conflict. Remove kcoreaddons? [y/N] y
:: kwidgetsaddons-git and kwidgetsaddons are in conflict. Remove kwidgetsaddons? [y/N] y
:: kbookmarks-git and kbookmarks are in conflict. Remove kbookmarks? [y/N] y
:: kxmlgui-git and kxmlgui are in conflict. Remove kxmlgui? [y/N] y
:: kglobalaccel-git and kglobalaccel are in conflict. Remove kglobalaccel? [y/N] y
:: kdbusaddons-git and kdbusaddons are in conflict. Remove kdbusaddons? [y/N] y
:: kconfig-git and kconfig are in conflict. Remove kconfig? [y/N] y
:: kcrash-git and kcrash are in conflict. Remove kcrash? [y/N] y
:: kwindowsystem-git and kwindowsystem are in conflict. Remove kwindowsystem? [y/N] y
:: kiconthemes-git and kiconthemes are in conflict. Remove kiconthemes? [y/N] y
:: kconfigwidgets-git and kconfigwidgets are in conflict. Remove kconfigwidgets? [y/N] y
:: kauth-git and kauth are in conflict. Remove kauth? [y/N] y
:: kcodecs-git and kcodecs are in conflict. Remove kcodecs? [y/N] y
:: kguiaddons-git and kguiaddons are in conflict. Remove kguiaddons? [y/N] y
:: ki18n-git and ki18n are in conflict. Remove ki18n? [y/N] y
:: kitemviews-git and kitemviews are in conflict. Remove kitemviews? [y/N] y
:: karchive-git and karchive are in conflict. Remove karchive? [y/N] y
:: attica-git and attica are in conflict. Remove attica? [y/N] y
:: kwallet-git and kwallet are in conflict. Remove kwallet? [y/N] y
:: knotifications-git and knotifications are in conflict. Remove knotifications? [y/N] y
:: kservice-git and kservice are in conflict. Remove kservice? [y/N] y
:: ktextwidgets-git and ktextwidgets are in conflict. Remove ktextwidgets? [y/N] y
:: kcompletion-git and kcompletion are in conflict. Remove kcompletion? [y/N] y
:: sonnet-git and sonnet are in conflict. Remove sonnet? [y/N] y
:: kded-git and kded are in conflict. Remove kded? [y/N] y
:: kpackage-git and kpackage are in conflict. Remove kpackage? [y/N] y
:: kwayland-git and kwayland are in conflict. Remove kwayland? [y/N] y
:: qca-qt5-git and qca are in conflict (qca-qt5). Remove qca? [y/N] y
:: kpeoplevcard-git and kpeoplevcard are in conflict. Remove kpeoplevcard? [y/N] y
:: kpeople-git and kpeople are in conflict. Remove kpeople? [y/N] y
:: kcontacts-git and kcontacts are in conflict. Remove kcontacts? [y/N] y
:: kirigami-git and kirigami2 are in conflict. Remove kirigami2? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing qca breaks dependency 'qca' required by kdepim-runtime
:: removing qca breaks dependency 'qca' required by kget
:: removing qca breaks dependency 'qca' required by kpmcore
:: removing qca breaks dependency 'qca' required by messagelib
:: removing qca breaks dependency 'qca' required by plasma-nm

I can't say no to removing the conflicts or it won't proceed.
Add/Remove app shows:

Resolving dependencies...
Checking inter-conflicts...
Failed to prepare transaction:
could not satisfy dependencies:
- removing kdepim-runtime breaks dependency 'kdepim-runtime' required by kmail,
- if possible, remove kmail and retry
- removing messagelib breaks dependency 'messagelib' required by mailcommon,
- if possible, remove mailcommon and retry
- removing kpmcore breaks dependency 'kpmcore' required by partitionmanager,
- if possible, remove partitionmanager and retry

Should I disable chaotic-aur repo? It was enabled by default
thanks in advance

I wouldn't recommend using -git packages.

What is the output of pacman -Syu ?

3 Likes

but I am not insisting on using git packages. System is forcing them for some reason. do I have enabled repo I shouldn't have? or chaotic aur got higher priority over stock? I didn't touch priorities, don't even know where to look for it.

sudo pacman -Syu
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: kcmutils-git and kcmutils are in conflict. Remove kcmutils? [y/N] y
:: kdeclarative-git and kdeclarative are in conflict. Remove kdeclarative? [y/N] y
:: kio-git and kio are in conflict. Remove kio? [y/N] y
:: solid-git and solid are in conflict. Remove solid? [y/N] y
:: kjobwidgets-git and kjobwidgets are in conflict. Remove kjobwidgets? [y/N] y
:: kcoreaddons-git and kcoreaddons are in conflict. Remove kcoreaddons? [y/N] y
:: kwidgetsaddons-git and kwidgetsaddons are in conflict. Remove kwidgetsaddons? [y/N] y
:: kbookmarks-git and kbookmarks are in conflict. Remove kbookmarks? [y/N] y
:: kxmlgui-git and kxmlgui are in conflict. Remove kxmlgui? [y/N] y
:: kglobalaccel-git and kglobalaccel are in conflict. Remove kglobalaccel? [y/N] y
:: kdbusaddons-git and kdbusaddons are in conflict. Remove kdbusaddons? [y/N] y
:: kconfig-git and kconfig are in conflict. Remove kconfig? [y/N] y
:: kcrash-git and kcrash are in conflict. Remove kcrash? [y/N] y
:: kwindowsystem-git and kwindowsystem are in conflict. Remove kwindowsystem? [y/N] y
:: kiconthemes-git and kiconthemes are in conflict. Remove kiconthemes? [y/N] y
:: kconfigwidgets-git and kconfigwidgets are in conflict. Remove kconfigwidgets? [y/N] y
:: kauth-git and kauth are in conflict. Remove kauth? [y/N] y
:: kcodecs-git and kcodecs are in conflict. Remove kcodecs? [y/N] y
:: kguiaddons-git and kguiaddons are in conflict. Remove kguiaddons? [y/N] y
:: ki18n-git and ki18n are in conflict. Remove ki18n? [y/N] y
:: kitemviews-git and kitemviews are in conflict. Remove kitemviews? [y/N] y
:: karchive-git and karchive are in conflict. Remove karchive? [y/N] y
:: attica-git and attica are in conflict. Remove attica? [y/N] y
:: kwallet-git and kwallet are in conflict. Remove kwallet? [y/N] y
:: knotifications-git and knotifications are in conflict. Remove knotifications? [y/N] y
:: kservice-git and kservice are in conflict. Remove kservice? [y/N] y
:: ktextwidgets-git and ktextwidgets are in conflict. Remove ktextwidgets? [y/N] y
:: kcompletion-git and kcompletion are in conflict. Remove kcompletion? [y/N] y
:: sonnet-git and sonnet are in conflict. Remove sonnet? [y/N] y
:: kded-git and kded are in conflict. Remove kded? [y/N] y
:: kpackage-git and kpackage are in conflict. Remove kpackage? [y/N] y
:: kwayland-git and kwayland are in conflict. Remove kwayland? [y/N] y
:: qca-qt5-git and qca are in conflict (qca-qt5). Remove qca? [y/N] y
:: kpeoplevcard-git and kpeoplevcard are in conflict. Remove kpeoplevcard? [y/N] y
:: kpeople-git and kpeople are in conflict. Remove kpeople? [y/N] y
:: kcontacts-git and kcontacts are in conflict. Remove kcontacts? [y/N] y
:: kirigami-git and kirigami2 are in conflict. Remove kirigami2? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing qca breaks dependency 'qca' required by kdepim-runtime
:: removing qca breaks dependency 'qca' required by kget
:: removing qca breaks dependency 'qca' required by kpmcore
:: removing qca breaks dependency 'qca' required by messagelib
:: removing qca breaks dependency 'qca' required by plasma-nm

I wonder if its somehow possible to find out which package is causing this?
There have been improvements to our KDE-git packages in the repo yesterday so that might be related :face_with_monocle:
Even though I dont understand why - the PKGBUILDs have been adjusted to fit ABS so there shouldnt be issues :face_with_monocle:

4 Likes

We need hard evidence :wink:
Please, post your /var/log/pacman.log at bin.garudalinux.org

2 Likes

I have uninstalled all apps that required qca. Chaotic is providing qca-qt5-git instead. kmail won't install now because it needs qca non qt5 version.

Post

grep '^Server' /etc/pacman.d/chaotic-mirrorlist
3 Likes

grep '^Server' /etc/pacman.d/chaotic-mirrorlist
Server = https://random-mirror.chaotic.cx/$repo/$arch
Server = https://us-tx-mirror.chaotic.cx/$repo/$arch
Server = https://us-wa-mirror.chaotic.cx/$repo/$arch
Server = https://us-ut-mirror.chaotic.cx/$repo/$arch
Server = https://us-ca-mirror.chaotic.cx/$repo/$arch
Server = https://nl-mirror.chaotic.cx/$repo/$arch
Server = https://es-mirror.chaotic.cx/$repo/$arch
Server = https://de-1-mirror.chaotic.cx/$repo/$arch
Server = http://de-2-mirror.chaotic.cx/$repo/$arch
Server = https://be-bru-mirror.chaotic.cx/$repo/$arch
Server = https://kr-mirror.chaotic.cx/$repo/$arch
Server = https://sg-mirror.chaotic.cx/$repo/$arch
Server = https://bg-mirror.chaotic.cx/$repo/$arch
Server = https://ca-mirror.chaotic.cx/$repo/$arch

[2021-03-12 11:56:31] WARNING: failed to rate http(s) download (https://europe.mirror.pkgbuild.com/community/os/x86_64/community.db): Download timed out after 5 second(s).
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2021-03-12 11:56:33 UTC
# From:       https://www.archlinux.org/mirrors/status/json/
# Retrieved:  2021-03-12 11:56:23 UTC
# Last Check: 2021-03-12 10:31:15 UTC

Server = https://archlinux.uk.mirror.allworldit.com/archlinux/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
Server = https://mirror.pseudoform.org/$repo/os/$arch
Server = https://america.mirror.pkgbuild.com/$repo/os/$arch
Server = https://europe.mirror.pkgbuild.com/$repo/os/$arch
:: Synchronising package databases...
 core                                                             131.1 KiB  2.56 MiB/s 00:00 [------------------------------------------------------] 100%
 extra                                                           1646.0 KiB   576 KiB/s 00:03 [------------------------------------------------------] 100%
 community                                                          5.4 MiB   775 KiB/s 00:07 [------------------------------------------------------] 100%
 multilib                                                         151.4 KiB   946 KiB/s 00:00 [------------------------------------------------------] 100%
 chaotic-aur                                                      944.0 KiB  2.79 MiB/s 00:00 [------------------------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: libqalculate-git and libqalculate are in conflict. Remove libqalculate? [y/N] y
:: kde-cli-tools-git and kde-cli-tools are in conflict. Remove kde-cli-tools? [y/N] y
:: kdesu-git and kdesu are in conflict. Remove kdesu? [y/N] y
:: kpty-git and kpty are in conflict. Remove kpty? [y/N] y
:: kactivitymanagerd-git and kactivitymanagerd are in conflict. Remove kactivitymanagerd? [y/N] y
:: plasma-integration-git and plasma-integration are in conflict. Remove plasma-integration? [y/N] y
:: qqc2-desktop-style-git and qqc2-desktop-style are in conflict. Remove qqc2-desktop-style? [y/N] y
:: kirigami2-git and kirigami-git are in conflict (kirigami2). Remove kirigami-git? [y/N] y
:: kdelibs4support-git and kdelibs4support are in conflict. Remove kdelibs4support? [y/N] y
:: kunitconversion-git and kunitconversion are in conflict. Remove kunitconversion? [y/N] y
:: kemoticons-git and kemoticons are in conflict. Remove kemoticons? [y/N] y
:: kactivities-stats-git and kactivities-stats are in conflict. Remove kactivities-stats? [y/N] y
:: kquickcharts-git and kquickcharts are in conflict. Remove kquickcharts? [y/N] y
:: kuserfeedback-git and kuserfeedback are in conflict. Remove kuserfeedback? [y/N] y


Packages (76) ananicy-git-2.2.1.r41.gee9f517-1  audacious-plugins-4.1-3  beautyline-20210311-1  breeze-icons-git-5.80.0_r1715.gba656561-1
              btrfs-progs-5.11-1  cht.sh-git-r844.42097e2-1  cryptsetup-2.3.5-1  garuda-dr460nized-r165.1f09f58-1  garuda-fish-config-r54.ca6f73e-1
              garuda-hooks-0.0.1-31  gnutls-3.7.1-1  hblock-3.2.1-1  kactivities-stats-5.79.0-1 [removal]  kactivities-stats-git-5.80.0_r337.g332d2d7-1
              kactivitymanagerd-5.21.2-1 [removal]  kactivitymanagerd-git-5.21.2_r1327.gbdb7071-1  kcmutils-git-5.80.0_r484.gf6b3ad9-1
              kde-cli-tools-5.21.2-1 [removal]  kde-cli-tools-git-5.21.80_r1827.g87fa438-1  kdeconnect-git-21.03.70_r3148.g7193cfc9-1
              kdelibs4support-5.79.0-1 [removal]  kdelibs4support-git-5.80.0_r1001.g75eac4eb-1  kdesu-5.79.0-1 [removal]  kdesu-git-5.80.0_r441.g63ca7d6-1
              kemoticons-5.79.0-1 [removal]  kemoticons-git-5.80.0_r358.ga9ea0da-1  kernel-modules-hook-0.1.7-1  kio-git-5.80.0_r4582.gc8bd41b5-1
              kirigami-git-v2.2.0.r1588.g0f11883d-1 [removal]  kirigami2-git-5.80.0_r2705.gd3fbbd05-1  kpty-5.79.0-1 [removal]
              kpty-git-5.80.0_r308.g7bb4adc-1  kquickcharts-5.79.0-1 [removal]  kquickcharts-git-5.80.0_r425.g3ec3ab8-1
              ktexteditor-git-5.80.0_r2756.g79bf0c9c-1  kunitconversion-5.79.0-1 [removal]  kunitconversion-git-5.80.0_r346.gf6cb766-1
              kuserfeedback-1.0.0-1 [removal]  kuserfeedback-git-1.0.0_r709.g3cf9f38-1  kwallet-git-5.80.0_r1048.gc5c882b-1
              kwayland-server-git-5.21.80.r1235.gce9c5768-1  kwin-git-5.21.80_r19073.g9786ea3c5-1  latte-dock-git-r5141.32f4c3f7-1
              lib32-vulkan-icd-loader-1.2.172-1  libinput-gestures-2.61-1  libksysguard-git-5.21.80_r2080.g0c0e4af-1  libqalculate-3.17.0-1 [removal]
              libqalculate-git-r992.c007906-1  libsidplayfp-2.1.1-1  linux-lts-5.10.23-1  linux-lts-headers-5.10.23-1  linux-tkg-bmq-goldmont-5.11.5-135
              linux-tkg-bmq-goldmont-headers-5.11.5-135  linux-tkg-muqss-goldmont-5.11.6-137  linux-tkg-muqss-goldmont-headers-5.11.6-137
              mercurial-5.7.1-1  networkmanager-qt-git-5.80.0_r1083.g421580e-1  pacman-pkgfile-hook-1.0.0-1  pacman-sync-1.0.0-1  pamac-aur-10.0.5-1
              pango-1:1.48.3-1  plasma-framework-git-5.80.0_r15775.g1b9b03529-1  plasma-integration-5.21.2-1 [removal]
              plasma-integration-git-5.21.80_r507.g23a1490-1  plasma-workspace-git-5.21.80_r10021.g5a2d973e0-1  plymouth-git-0.9.5.r45.g5784567-1
              qpdf-10.3.1-1  qqc2-desktop-style-5.79.0-1 [removal]  qqc2-desktop-style-git-5.80.0_r462.gd3b4380-1  rlwrap-0.43-4  spirv-tools-2020.7-1
              starship-git-0.50.0.1431.g3bc3c003-1  syntax-highlighting-git-5.80.0_r1539.g94260da3-1  vulkan-icd-loader-1.2.172-1  vulkan-tools-1.2.172-1
              xsel-1.2.0.20190821-1

Total Download Size:   430.40 MiB
Total Installed Size:  942.42 MiB
Net Upgrade Size:       -7.31 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 cryptsetup-2.3.5-1-x86_64                                        620.5 KiB  1149 KiB/s 00:01 [------------------------------------------------------]   0%
 gnutls-3.7.1-1-x86_64                                              3.5 MiB  2.52 MiB/s 00:01 [------------------------------------------------------]   0%
 btrfs-progs-5.11-1-x86_64                                          4.3 MiB  2.77 MiB/s 00:02 [------------------------------------------------------]   1%
 linux-lts-5.10.23-1-x86_64                                        78.7 MiB  10.3 MiB/s 00:08 [------------------------------------------------------]  18%
 linux-lts-headers-5.10.23-1-x86_64                               101.6 MiB  10.8 MiB/s 00:09 [------------------------------------------------------]  23%
 libsidplayfp-2.1.1-1-x86_64                                      101.8 MiB  10.8 MiB/s 00:09 [------------------------------------------------------]  23%
 vulkan-icd-loader-1.2.172-1-x86_64                               101.9 MiB  10.7 MiB/s 00:10 [------------------------------------------------------]  23%
 audacious-plugins-4.1-3-x86_64                                   103.3 MiB  10.7 MiB/s 00:10 [------------------------------------------------------]  24%
 pango-1:1.48.3-1-x86_64                                          103.7 MiB  10.6 MiB/s 00:10 [------------------------------------------------------]  24%
 mercurial-5.7.1-1-x86_64                                         108.4 MiB  10.7 MiB/s 00:10 [------------------------------------------------------]  25%
 qpdf-10.3.1-1-x86_64                                             109.5 MiB  10.7 MiB/s 00:10 [------------------------------------------------------]  25%
 spirv-tools-2020.7-1-x86_64                                      111.0 MiB  10.7 MiB/s 00:10 [------------------------------------------------------]  25%
 vulkan-tools-1.2.172-1-x86_64                                    111.2 MiB  10.7 MiB/s 00:10 [------------------------------------------------------]  25%
 xsel-1.2.0.20190821-1-x86_64                                     111.2 MiB  10.6 MiB/s 00:10 [------------------------------------------------------]  25%
 rlwrap-0.43-4-x86_64                                             111.3 MiB  10.6 MiB/s 00:11 [------------------------------------------------------]  25%
 lib32-vulkan-icd-loader-1.2.172-1-x86_64                         111.4 MiB  10.6 MiB/s 00:11 [------------------------------------------------------]  25%
 ananicy-git-2.2.1.r41.gee9f517-1-any                             111.5 MiB  8.39 MiB/s 00:13 [------------------------------------------------------]  25%
error: failed retrieving file 'beautyline-20210311-1-any.pkg.tar.zst' from random-mirror.chaotic.cx : Connection timed out after 10005 milliseconds
 beautyline-20210311-1-any                                        116.0 MiB  4.48 MiB/s 00:26 [------------------------------------------------------]  26%
 breeze-icons-git-5.80.0_r1715.gba656561-1-x86_64                 128.6 MiB  4.63 MiB/s 00:28 [------------------------------------------------------]  29%
 syntax-highlighting-git-5.80.0_r1539.g94260da3-1-x86_64          130.2 MiB  4.57 MiB/s 00:29 [------------------------------------------------------]  30%
 kwallet-git-5.80.0_r1048.gc5c882b-1-x86_64                       130.6 MiB  4.32 MiB/s 00:30 [------------------------------------------------------]  30%
 kio-git-5.80.0_r4582.gc8bd41b5-1-x86_64                          136.3 MiB  4.30 MiB/s 00:32 [------------------------------------------------------]  31%
 ktexteditor-git-5.80.0_r2756.g79bf0c9c-1-x86_64                  139.0 MiB  4.23 MiB/s 00:33 [------------------------------------------------------]  32%
 kcmutils-git-5.80.0_r484.gf6b3ad9-1-x86_64                       139.5 MiB  4.15 MiB/s 00:34 [------------------------------------------------------]  32%
 kwayland-server-git-5.21.80.r1235.gce9c5768-1-x86_64             140.0 MiB  4.06 MiB/s 00:34 [------------------------------------------------------]  32%
 kirigami2-git-5.80.0_r2705.gd3fbbd05-1-x86_64                    140.6 MiB  3.97 MiB/s 00:35 [------------------------------------------------------]  32%
 plasma-framework-git-5.80.0_r15775.g1b9b03529-1-x86_64           145.3 MiB  1976 KiB/s 01:15 [------------------------------------------------------]  33%
 kwin-git-5.21.80_r19073.g9786ea3c5-1-x86_64                      151.4 MiB  2030 KiB/s 01:16 [------------------------------------------------------]  35%
 libksysguard-git-5.21.80_r2080.g0c0e4af-1-x86_64                 151.9 MiB  1996 KiB/s 01:18 [------------------------------------------------------]  35%
 libqalculate-git-r992.c007906-1-x86_64                           154.4 MiB  1963 KiB/s 01:21 [------------------------------------------------------]  35%
error: failed retrieving file 'kpty-git-5.80.0_r308.g7bb4adc-1-x86_64.pkg.tar.zst' from random-mirror.chaotic.cx : Connection timed out after 10002 milliseconds
 kpty-git-5.80.0_r308.g7bb4adc-1-x86_64                           154.5 MiB  1710 KiB/s 01:33 [------------------------------------------------------]  35%
 kdesu-git-5.80.0_r441.g63ca7d6-1-x86_64                          154.8 MiB  1666 KiB/s 01:35 [------------------------------------------------------]  35%
 kde-cli-tools-git-5.21.80_r1827.g87fa438-1-x86_64                155.0 MiB  1655 KiB/s 01:36 [------------------------------------------------------]  36%
 kactivitymanagerd-git-5.21.2_r1327.gbdb7071-1-x86_64             155.2 MiB  1630 KiB/s 01:37 [------------------------------------------------------]  36%
 qqc2-desktop-style-git-5.80.0_r462.gd3b4380-1-x86_64             155.3 MiB  1626 KiB/s 01:38 [------------------------------------------------------]  36%
 plasma-integration-git-5.21.80_r507.g23a1490-1-x86_64            155.5 MiB  1613 KiB/s 01:39 [------------------------------------------------------]  36%
 kunitconversion-git-5.80.0_r346.gf6cb766-1-x86_64                155.7 MiB  1601 KiB/s 01:40 [------------------------------------------------------]  36%
 kemoticons-git-5.80.0_r358.ga9ea0da-1-x86_64                     157.6 MiB  1524 KiB/s 01:46 [------------------------------------------------------]  36%
 kdelibs4support-git-5.80.0_r1001.g75eac4eb-1-x86_64              159.8 MiB  1506 KiB/s 01:49 [------------------------------------------------------]  37%
 kactivities-stats-git-5.80.0_r337.g332d2d7-1-x86_64              160.1 MiB  1489 KiB/s 01:50 [------------------------------------------------------]  37%
 kquickcharts-git-5.80.0_r425.g3ec3ab8-1-x86_64                   160.2 MiB  1483 KiB/s 01:51 [------------------------------------------------------]  37%
 kuserfeedback-git-1.0.0_r709.g3cf9f38-1-x86_64                   160.6 MiB  1459 KiB/s 01:53 [------------------------------------------------------]  37%
 plasma-workspace-git-5.21.80_r10021.g5a2d973e0-1-x86_64          169.8 MiB  1519 KiB/s 01:54 [------------------------------------------------------]  39%
 garuda-dr460nized-r165.1f09f58-1-any                             177.1 MiB  1573 KiB/s 01:55 [------------------------------------------------------]  41%
 cht.sh-git-r844.42097e2-1-any                                    177.1 MiB  1566 KiB/s 01:56 [------------------------------------------------------]  41%
 starship-git-0.50.0.1431.g3bc3c003-1-x86_64                      180.5 MiB  1584 KiB/s 01:57 [------------------------------------------------------]  41%
 garuda-fish-config-r54.ca6f73e-1-any                             180.5 MiB  1580 KiB/s 01:57 [------------------------------------------------------]  41%
 pacman-pkgfile-hook-1.0.0-1-any                                  180.5 MiB  1571 KiB/s 01:58 [------------------------------------------------------]  41%
 pacman-sync-1.0.0-1-any                                          180.5 MiB  1559 KiB/s 01:59 [------------------------------------------------------]  41%
 kernel-modules-hook-0.1.7-1-any                                  180.5 MiB  1554 KiB/s 01:59 [------------------------------------------------------]  41%
error: failed retrieving file 'garuda-hooks-0.0.1-31-any.pkg.tar.zst' from random-mirror.chaotic.cx : Connection timed out after 10005 milliseconds
 garuda-hooks-0.0.1-31-any                                        180.5 MiB  1425 KiB/s 02:10 [------------------------------------------------------]  41%
 hblock-3.2.1-1-any                                               180.5 MiB  1420 KiB/s 02:10 [------------------------------------------------------]  41%
 kdeconnect-git-21.03.70_r3148.g7193cfc9-1-x86_64                 181.3 MiB  1367 KiB/s 02:16 [------------------------------------------------------]  42%
 latte-dock-git-r5141.32f4c3f7-1-x86_64                           182.5 MiB  1346 KiB/s 02:19 [------------------------------------------------------]  42%
 libinput-gestures-2.61-1-any                                     182.5 MiB  1338 KiB/s 02:20 [------------------------------------------------------]  42%
 linux-tkg-bmq-goldmont-5.11.5-135-x86_64                         274.8 MiB  1893 KiB/s 02:29 [------------------------------------------------------]  63%
 linux-tkg-bmq-goldmont-headers-5.11.5-135-x86_64                 304.3 MiB  2023 KiB/s 02:34 [------------------------------------------------------]  70%
 linux-tkg-muqss-goldmont-5.11.6-137-x86_64                       396.7 MiB  2.25 MiB/s 02:57 [------------------------------------------------------]  92%
 linux-tkg-muqss-goldmont-headers-5.11.6-137-x86_64               426.4 MiB  2.35 MiB/s 03:02 [------------------------------------------------------]  99%
 networkmanager-qt-git-5.80.0_r1083.g421580e-1-x86_64             428.3 MiB  2.35 MiB/s 03:03 [------------------------------------------------------]  99%
 pamac-aur-10.0.5-1-x86_64                                        429.3 MiB  2.33 MiB/s 03:05 [------------------------------------------------------]  99%
 plymouth-git-0.9.5.r45.g5784567-1-x86_64                         430.4 MiB  2.32 MiB/s 03:05 [------------------------------------------------------] 100%
(62/62) checking keys in keyring                                                              [------------------------------------------------------] 100%
(62/62) checking package integrity                                                            [------------------------------------------------------] 100%
(62/62) loading package files                                                                 [------------------------------------------------------] 100%
(62/62) checking for file conflicts                                                           [------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
plasma-workspace-git: /etc/pam.d/kde exists in filesystem (owned by kscreenlocker-git)
Errors occurred, no packages were upgraded.

This is fixed already, gotta reinstall kscreenlocker-git (its version didnt change after removing the kde file so there is no update for that file as of now). Actually you could also just use --overwrite "*" in this case.
Without that file kscreenlocker wasnt able to unlock the lockscreen properly.

We still have no evidency of why the -gits have been pulled :slightly_frowning_face:

3 Likes

Post

pacman -Qs "\-git"

Also,

4 Likes
sudo pacman -Qs "\-git"
local/alacritty-ligatures-git 0.8.0.1772.g3ed0430-1
    A cross-platform, GPU-accelerated terminal emulator(GIT VERSION)
local/ananicy-git 2.2.1.r40.ge66fa22-1
    Ananicy - is Another auto nice daemon, with community rules support
local/attica-git 5.80.0_r795.g39baccb-1 (kf5-git)
    Qt library that implements the Open Collaboration Services API
local/baloo-git 5.80.0_r2924.g9998bf63-1 (kf5-git)
    A framework for searching and managing metadata
local/breeze-git 5.21.80_r2156.g35f8d527-1 (plasma-git)
    Artwork, styles and assets for the Breeze visual style for the Plasma Desktop
local/breeze-icons-git 5.80.0_r1714.geb9fb128-1 (kf5-git)
    Breeze icon themes
local/eruption-git 0.1.19-25
    Linux user-mode input and LED driver for keyboards, mice and other devices
local/frameworkintegration-git 5.80.0_r570.g0f49ed3-1 (kf5-git)
    Framework providing components to allow applications to integrate with a KDE Workspace
local/garuda-assistant-git r28.c3acfcc-1 (garuda-git)
    A assistant app for Garuda Linux
local/garuda-boot-options-git r20.98d4ca8-1 (garuda-git)
    A Boot options utility for Garuda Linux
local/garuda-gamer-git r16.83cbdb2-1 (garuda-git)
    A app for Garuda Linux
local/garuda-network-assistant-git r23.918837e-1 (garuda-git)
    A Boot options utility for Garuda Linux
local/garuda-settings-manager-git r24.4646d26-1
    Garuda Linux System Settings Tool (manjaro settings manager ported to work with arch standards and limited to only dkms drivers)
local/garuda-settings-manager-kcm-git r24.4646d26-1
    Garuda Linux System Settings Tool (KCM for Plasma 5) (manjaro settings manager ported to work with arch standards and limited to only dkms drivers)
local/garuda-settings-manager-knotifier-git r24.4646d26-1
    Garuda Linux System Settings Tool (Notifier for Plasma 5) (manjaro settings manager ported to work with arch standards and limited to only dkms
    drivers)
local/garuda-welcome-git r97.7b3916a-1 (garuda-git)
    A Welcome app for Garuda Linux
local/gst-plugin-viper4linux-git r36.a5c1b03-2
    ViPER FX core wrapper plugin for gstreamer
local/kactivities-git 5.80.0_r1331.gd5ca108-1 (kf5-git)
    Core components for the KDE's Activities
local/karchive-git 5.80.0_r460.gf2c02f7-1 (kf5-git)
    Qt 5 addon providing access to numerous types of archives
local/kauth-git 5.80.0_r417.gd427254-1 (kf5-git)
    Abstraction to system policy and authentication features
local/kbookmarks-git 5.80.0_r391.g8cfd751-1 (kf5-git)
    Support for bookmarks and the XBEL format
local/kcmutils-git 5.80.0_r483.gaab1c93-1 (kf5-git)
    Utilities for interacting with KCModules
local/kcodecs-git 5.80.0_r351.g2f30820-1 (kf5-git)
    Provide a collection of methods to manipulate strings using various encodings
local/kcompletion-git 5.80.0_r423.g3e14934-1 (kf5-git)
    Text completion helpers and widgets
local/kconfig-git 5.80.0_r801.gd5ca63b-1 (kf5-git)
    Configuration system
local/kconfigwidgets-git 5.80.0_r546.g6bb1826-1 (kf5-git)
    Widgets for KConfig
local/kcontacts-git 5.80.0_r3218.g713ff23f-1 (kf5-git)
    Address book API for KDE
local/kcoreaddons-git 5.80.0_r1191.g9eaa9957-1 (kf5-git)
    Addons to QtCore
local/kcrash-git 5.80.0_r357.g03b8fd7-1 (kf5-git)
    Support for application crash analysis and bug report from apps
local/kdbusaddons-git 5.80.0_r344.g4684bfd-1 (kf5-git)
    Addons to QtDBus
local/kdeclarative-git 5.80.0_r873.gdfc9e3d-1 (kf5-git)
    Provides integration of QML and KDE Frameworks
local/kdeconnect-git 21.03.70_r3147.gdc25d8ef-1 (kde-applications-git kde-network-git)
    Adds communication between KDE and your smartphone
local/kdecoration-git 5.21.80_r250.g6257c39-1 (plasma-git)
    Plugin based library to create window decorations
local/kded-git 5.80.0_r384.g87fe64a-1 (kf5-git)
    Extensible deamon for providing system level services
local/kdnssd-git 5.80.0_r293.gfbd474a-1 (kf5-git)
    Abstraction to system DNSSD features
local/kdoctools-git 5.80.0_r593.g6352583-1 (kf5-git)
    Documentation generation from docbook
local/kdsoap-git 1.99.50_r1615.ga6dec7e2-1
    Qt-based client-side and server-side SOAP component
local/kdsoap-ws-discovery-client-git 0_r62.gdcefb65-1
    WS-Discovery client library based on KDSoap
local/kfilemetadata-git 5.80.0_r766.g5e3dcd9-1 (kf5-git)
    A library for extracting file metadata
local/kglobalaccel-git 5.80.0_r419.g0e750f7-1 (kf5-git)
    Add support for global workspace shortcuts
local/kguiaddons-git 5.80.0_r347.g621a2e5-1 (kf5-git)
    Addons to QtGui
local/khelpcenter-git 21.03.70_r2651.g220bbd0d-1 (kde-applications-git kde-system-git)
    Application to show KDE Applications' documentation
local/kholidays-git 1:5.80.0_r909.g0dfe855-1 (kf5-git)
    KDE library for regional holiday information
local/khtml-git 5.80.0_r531.gfa84253-1 (kf5-aids-git)
    KHTML APIs
local/ki18n-git 5.80.0_r447.g90ccb3b-1 (kf5-git)
    Advanced internationalization framework
local/kiconthemes-git 5.80.0_r486.g11fd56b-1 (kf5-git)
    Support for icon themes
local/kidletime-git 5.80.0_r286.g7e272f5-1 (kf5-git)
    Monitoring user activity
local/kinit-git 5.80.0_r381.gdf7d2bd-1 (kf5-git)
    Process launcher to speed up launching KDE applications
local/kio-extras-git 21.03.70_r6983.g5abd1e8e-1 (kde-applications-git kde-network-git)
    Additional components to increase the functionality of KIO
local/kio-git 5.80.0_r4579.g33a28297-1 (kf5-git)
    Resource and network access abstraction
local/kirigami-git v2.2.0.r1588.g0f11883d-1 (plasma)
    A set of QML components for mobile/desktop convergent applications made by KDE
local/kitemmodels-git 5.80.0_r521.g7327fee-1 (kf5-git)
    Models for Qt Model/View system
local/kitemviews-git 5.80.0_r311.g4d5caf4-1 (kf5-git)
    Widget addons for Qt Model/View
local/kjobwidgets-git 5.80.0_r344.g19e4cc4-1 (kf5-git)
    Widgets for tracking KJob instances
local/kjs-git 5.80.0_r314.g2c2d403-1 (kf5-aids-git)
    Support for JS scripting in applications
local/kjsembed-git 5.80.0_r279.gf21c08c-1 (kf5-aids-git)
    Embedded JS
local/knewstuff-git 5.80.0_r1058.g715129cf-1 (kf5-git)
    Support for downloading application assets from the network
local/knotifications-git 5.80.0_r620.g36390f3-1 (kf5-git)
    Abstraction for system notifications
local/knotifyconfig-git 5.80.0_r322.g783fb55-1 (kf5-git)
    Configuration system for KNotify
local/kpackage-git 5.80.0_r642.gf896503-1 (kf5-git)
    Framework that lets applications manage user installable packages of non-binary assets
local/kparts-git 5.80.0_r481.gca3e6d5-1 (kf5-git)
    Document centric plugin system
local/kpeople-git 5.80.0_r1296.gcb96d19-1 (kf5-git)
    A library that provides access to all contacts and the people who hold them
local/kpeoplevcard-git 0.1_r41.gb10c103-1
    Makes it possible to expose vcards to KPeople
local/krunner-git 5.80.0_r584.g3b58e21-1 (kf5-git)
    Framework for providing different actions given a string query
local/kscreenlocker-git 5.21.80.r823.g5fc9d6d-1
    Library and components for secure lock screen architecture
local/kservice-git 5.80.0_r881.gf25c7d7-1 (kf5-git)
    Advanced plugin and service introspection
local/ktexteditor-git 5.80.0_r2750.g69603b54-1 (kf5-git)
    Advanced embeddable text editor
local/ktextwidgets-git 5.80.0_r376.ge4e0d24-1 (kf5-git)
    Advanced text editing widgets
local/kwallet-git 5.80.0_r1047.g41a76c3-1 (kf5-git)
    Secure and unified container for user passwords
local/kwayland-git 5.80.0_r1055.gfc4f209-1 (kf5-git)
    Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-server-git 5.21.80.r1223.g87fa37a1-1 (kf5-git)
    Wayland Server Components built on KDE Frameworks
local/kwidgetsaddons-git 5.80.0_r778.g1f5e2329-1 (kf5-git)
    Addons to QtWidgets
local/kwin-git 5.21.80_r19037.g7cc95d931-1 (plasma-git)
    An easy to use, but flexible, composited Window Manager
local/kwindowsystem-git 5.80.0_r564.g53daf6b-1 (kf5-git)
    Access to the windowing system
local/kxmlgui-git 5.80.0_r723.g23dfc4b-1 (kf5-git)
    User configurable main windows
local/kxmlrpcclient-git 5.80.0_r432.g4c174da36-1 (kf5-aids-git)
    XML-RPC client library for KDE
local/latte-dock-git r5127.f9e277a9-1
    Latte is a dock based on plasma frameworks that provides an elegant and intuitive experience for your tasks and plasmoids
local/libbuddy-git 0.3.3.r1.g819cd6d-1
    Simple library for managing iBuddy and Blync devices
local/libkscreen-git 5.21.80_r1567.g8615b0b-1 (plasma-git)
    KDE screen management software
local/libksysguard-git 5.21.80_r2078.gb64edc5-1 (plasma-git)
    Library to retrieve information on the current status of computer hardware
local/libqaccessibilityclient-git v0.4.0.r18.893c6b7-1
    Helper library to make writing accessibility tools easier git version
local/memavaild-git 0.6.r3.g2603a8c-1
    Improve responsiveness during heavy swapping: keep amount of available memory.
local/mhwd-db-garuda-git r51.3fcc25b-1
    mhwd-db-garuda(manjaro's mhwd-db backported to archlinux with additional features and limited to only dkms drivers)
local/mhwd-garuda-git r19.6658e66-1
    mhwd-garuda(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)
local/milou-git 5.21.80_r731.g137b4ae-1 (plasma-git)
    A dedicated search application built on top of Baloo
local/modemmanager-qt-git 5.80.0_r490.g328a5f4-1 (kf5-git)
    Qt wrapper for ModemManager DBus API
local/networkmanager-qt-git 5.80.0_r1082.g7a633d8-1 (kf5-git)
    Qt wrapper for NetworkManager API
local/nohang-git 0.2.0.r7.gb025479-1
    A sophisticated low memory handler
local/plasma-framework-git 5.80.0_r15762.gf33d8b795-1 (kf5-git)
    Plasma library and runtime components based upon KF5 and Qt5
local/plasma-nm-git 5.21.80.r3019.ge0b2eea7-1 (plasma-git)
    Plasma applet written in QML for managing network connections
local/plasma-workspace-git 5.21.80.r9890.g2c758a1ad-1 (plasma)
    KDE Plasma Workspace
local/plymouth-git 0.9.5.r38.g8c249a4-1
    A graphical boot splash screen with kernel mode-setting support (Development version)
local/prelockd-git 0.9.r3.g72c7131-1
    prelockd is a daemon that locks memory mapped binaries and libraries in memory to improve system responsiveness under low-memory conditions.
local/prison-git 5.80.0_r299.ge2d0c4c-1 (kf5-git)
    A barcode API to produce QRCode barcodes and DataMatrix barcodes
local/python-usbtmc-git 0.8.r18.gd9bfb20-1
    A Python USBTMC driver for controlling instruments over USB.
local/qca-qt5-git v2.3.2.3.gecdd0538-1
    Qt Cryptographic Architecture. Qt5 Build (GIT Version)
local/solid-git 5.80.0_r647.gf8d6ab4-1 (kf5-git)
    Hardware integration and detection
local/sonnet-git 5.80.0_r592.gd6d4e94-1 (kf5-git)
    Spelling framework for Qt5
local/starship-git 0.50.0.1424.g7385dc27-1
    The cross-shell prompt for astronauts
local/syntax-highlighting-git 5.80.0_r1521.gba797384-1 (kf5-git)
    Syntax highlighting engine for structured text and code
local/threadweaver-git 5.80.0_r480.ge7c4d60-1 (kf5-git)
    High-level multithreading framework
local/viper4linux-git 1:r16.7577724-1
    Implementation of the libviper library for modern Linux desktops.

Am I the only one experiencing such issues with upgrades?

A post was split to a new topic: System pulling in git packages?

It is obvious you already have git versions, but what is weird is that you seem to also have non-git versions.
You have done something really wrong, or some ghost is in your place :ghost:

Inspect your pacman.log to see what and when has happened.
For example, post:

pacman  -Qs kcmutils
grep -i "kcmutils\|starting full" /var/log/pacman.log
2 Likes