On login, Background on one screen is missing and right-click menu doesn't display

Hello forum family. I am having a strange issue that has persisted for a while. I thought that it may have been kernel related so I didn't want to post anything until I ruled that out. After trying a few different kernels, the problem is still present. When powering on the system, the left monitor display will sometimes be blank. The wallpaper is missing but Latte Dock is present and fully functional. If I attempt to right-click, the menu does no appear. Moving to other monitor on the right, I can bring the right-click menu up without issue. I tried to search for a solution but did not find anything similar.

I have an MSI RX 580 Armor 4GB Graphics Card that is basically new and have run UNIGINE Benchmarks with no issues reported. Overall everything looks and runs great. When I reboot, it sometimes clears the issue. Any help or tips would be most welcomed.

inxi -Fxxxza

System:    Kernel: 5.14.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0f1c478d-0b21-4122-8956-f50d08c853da 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <filter> UEFI: American Megatrends 
v: P3.90 date: 12/09/2019 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
model-id: 71 (113) stepping: 0 microcode: 8701013 cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86239 
Speed: 4085 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 4085 2: 3552 
3: 3855 4: 4079 5: 3523 6: 4061 7: 3762 8: 3880 9: 3767 10: 3674 11: 3674 12: 3854 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Micro-Star MSI 
driver: amdgpu v: kernel bus-ID: 06:00.0 chip-ID: 1002:67df class-ID: 0300 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 3839x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") s-diag: 1052mm (41.4") 
Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") 
diag: 598mm (23.5") 
Monitor-2: DisplayPort-1 res: 1920x1080 dpi: 94 size: 521x293mm (20.5x11.5") 
diag: 598mm (23.5") 
OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.42.0 5.14.12-zen1-1-zen LLVM 12.0.1) 
v: 4.6 Mesa 21.2.3 direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI 
driver: snd_hda_intel v: kernel bus-ID: 06:00.1 chip-ID: 1002:aaf0 class-ID: 0403 
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403 
Device-3: C-Media Audio Adapter (Unitek Y-247A) type: USB 
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4.1:5 chip-ID: 0d8c:0014 class-ID: 0300 
Device-4: Logitech [G533 Wireless Headset Dongle] type: USB 
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-6:4 chip-ID: 046d:0a66 class-ID: 0300 
Sound Server-1: ALSA v: k5.14.12-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: yes 
Sound Server-4: PipeWire v: 0.3.38 running: yes 
Network:   Device-1: Broadcom BCM4352 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: wl 
v: kernel modules: bcma bus-ID: 03:00.0 chip-ID: 14e4:43b1 class-ID: 0280 
IF: wlp3s0 state: up mac: <filter> 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 
v: kernel port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp4s0 state: down mac: <filter> 
IF-ID-1: anbox0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.8 TiB used: 210.36 GiB (11.4%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB block-size: 
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 032 scheme: GPT 
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDS500G2B0A-00SM50 size: 465.76 GiB 
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 40WD 
scheme: GPT 
ID-3: /dev/sdc maj-min: 8:32 model: SSDSC2KB480G8R size: 447.13 GiB block-size: 
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: DL63 
scheme: GPT 
Partition: ID-1: / raw-size: 471.64 GiB size: 471.64 GiB (100.00%) used: 210.34 GiB (44.6%) fs: btrfs 
dev: /dev/sda5 maj-min: 8:5 
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 25.6 MiB (26.6%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 471.64 GiB size: 471.64 GiB (100.00%) used: 210.34 GiB (44.6%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 471.64 GiB size: 471.64 GiB (100.00%) used: 210.34 GiB (44.6%)
fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 471.64 GiB size: 471.64 GiB (100.00%) used: 210.34 GiB (44.6%)
fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.73 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 213
Info:      Processes: 333 Uptime: 16m wakeups: 0 Memory: 62.73 GiB used: 3.35 GiB (5.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1910 lib: 549
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
network-broadcom-wl            2021.08.05                true            PCI
video-linux            2021.02.19                true            PCI

xrandr

Screen 0: minimum 320 x 200, current 3839 x 1080, maximum 16384 x 16384
DisplayPort-0 connected 1920x1080+1919+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080     60.00*+ 165.00   143.85   119.98    99.93    50.00    59.94  
1680x1050     59.95  
1280x1024     75.02    60.02  
1440x900      59.89  
1280x960      60.00  
1280x800      60.00  
1152x864      75.00  
1280x720      60.00    50.00    59.94  
1440x576      50.00  
1024x768      75.03    70.07    60.00  
1440x480      60.00    59.94  
800x600       72.19    75.00    60.32    56.25  
720x576       50.00  
720x480       60.00    59.94  
640x480       75.00    72.81    66.67    60.00    59.94  
720x400       70.08  
DisplayPort-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080     60.00 + 165.00   143.85*  119.98    99.93    50.00    59.94  
1680x1050     59.95  
1280x1024     75.02    60.02  
1440x900      59.89  
1280x960      60.00
1280x800      60.00
1152x864      75.00
1280x720      60.00    50.00    59.94
1440x576      50.00
1024x768      75.03    70.07    60.00
1440x480      60.00    59.94
800x600       72.19    75.00    60.32    56.25
720x576       50.00
720x480       60.00    59.94
640x480       75.00    72.81    66.67    60.00    59.94
720x400       70.08
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)

let see screenshots

Trying to reproduce now but I am unable to provide you with the screen shot you requested. Everything looks good after a reboot. This seems to only happens when the system has been powered down for a while, at least a few hours. I'm making some assumptions here. I would happily provide you with any command output you wish, I'm just unable to provide the screenshot at this time. I will capture it tomorrow. It usually happens when I get home from work and power the system on.

I unfortunately do not have a solution for your problem but just to add:
I have the same problem and I blamed the driver but now I think it may be more related to the compositor. I'm using the zen kernel with an NVidia RTX 3080 (Inxi [email protected])

Temporally switching the primary monitor brings back the background and any windows/menus. That means I click on the Display Configuration, Advanced Display Settings and on any of the secondary monitors click on "Primary" and apply. Then you can switch back to your preferred primary and apply again. A bit annoying but at least you don't have to reboot.

2 Likes

Here is the screen shot you requested. Sorry it took me so long. The issue is intermittent. As you can see, the left monitor does not have the wallpaper and you do not see a menu pop-up if you right click. The Latte Dock is there, which functions fine, and the application menu and top panel are also there with full functionality as well. Not sure what to make of this.

I did try your work around but alas, it did not work for me. Rebooting is the only thing that clears the issue.

what openGL's version do you use ?
try "linux-lts" kernel and default openGL version (2.0)

glxinfo | grep OpenGL

OpenGL vendor string: AMD
OpenGL renderer string: Radeon RX 580 Series (POLARIS10, DRM 3.42.0, 5.14.12-zen1-1-zen, LLVM 12.0.1)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.2.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.2.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.2.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

I installed the "linux-lts" kernel. I am facing the same issue.

I'm not sure about the OpenGL version (2.0). I don't think that is the default version. The graphics card definitely supports up to version 4.5. MSI Radeon RX 580 ARMOR 4G OC - DataSheet

I'm not sure how to even go about changing the OpenGL version.

Here is the output from:
glxgears

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
793 frames in 5.0 seconds = 158.488 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.851 FPS
720 frames in 5.0 seconds = 143.849 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.851 FPS
720 frames in 5.0 seconds = 143.849 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.851 FPS
720 frames in 5.0 seconds = 143.849 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.851 FPS
720 frames in 5.0 seconds = 143.850 FPS
720 frames in 5.0 seconds = 143.850 FPS

Output from:
glxinfo | grep "OpenGL vendor string" | cut -f2 -d":" | xargs

AMD

@thunder-son I did eventually find where I could switch the OpenGL versions in Display Configuration > Compositor. I tried that as well with the "linux-lts" kernel and it did not work. I had the same issue. This is so strange. BTW, when I loaded the "linux-lts" kernel, it would not allow me to connect to wifi. I'm sure this was just something I would need to configure by enabling some driver, but I thought since we were troubleshooting, it was worth mentioning.

works for me!, i have this same issue in others kde distro, idk what is it

I'm happy that solved your issue but I did not solve mine. If there is more information that is needed to assist with troubleshooting, please let me know and I will provide it. At this point, I have tried the suggestions and the issue persists.

A couple of troubleshooting suggestions you might want to test.

Do not start Latte automatically, disable it from autostarting. After boot up, then start Latte manually in the terminal. Post any error messages thrown by latte.

Restart the kwin compositor after you are logged in to see if there is any difference.

2 Likes

I will try that and post back with results.

I would also like to ask, are there any log files that would be useful. I can reboot and post the results if that would also help. I may just need a nudge on what command to run and where the logs you may need are located. Apologies for my ignorance, I am very green when it comes to Arch but my google-fu is strong :grin:

Thank you Garuda Team!

I disabled Latte from autostarting and ran it manually in the terminal. Here is the output:

latte-dock

Icon theme "gnome" not found.
[51843:51843:1031/113539.630537:ERROR:sharing_service.cc(222)] Device registration failed with fatal error
[51884:51884:1031/113539.643027:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
Fontconfig error: Cannot load default config file: No such file: (null)
[51843:51863:1031/113539.694464:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51949:1031/113540.132010:ERROR:get_updates_processor.cc(260)] PostClientToServerMessage() failed during GetUpdates with error 2
[51843:51862:1031/113540.740002:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51862:1031/113540.747376:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51862:1031/113540.747417:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51949:1031/113540.748428:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51948:1031/113540.777965:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51948:1031/113540.778017:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51919:1031/113540.778943:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51949:1031/113540.818144:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51947:1031/113540.978960:ERROR:chrome_browser_main_extra_parts_metrics.cc(228)] crbug.com/1216328: Checking Bluetooth availability started. Please report if there is no report that this ends.
[51843:51947:1031/113540.978984:ERROR:chrome_browser_main_extra_parts_metrics.cc(231)] crbug.com/1216328: Checking Bluetooth availability ended.
[51843:51947:1031/113540.978989:ERROR:chrome_browser_main_extra_parts_metrics.cc(234)] crbug.com/1216328: Checking default browser status started. Please report if there is no report that this ends.
[51843:51947:1031/113541.030033:ERROR:chrome_browser_main_extra_parts_metrics.cc(238)] crbug.com/1216328: Checking default browser status ended.
[51843:51949:1031/113541.035097:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51949:1031/113541.035149:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51877:1031/113541.035956:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51919:1031/113541.113474:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51948:1031/113541.540751:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51952:1031/113551.254858:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51952:1031/113551.254909:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51952:1031/113551.257433:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51952:1031/113551.290877:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113551.704544:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51947:1031/113609.297389:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE visit_time >= ? AND visit_time < ?ORDER BY visit_time LIMIT ?
[51843:51947:1031/113613.107892:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113615.217246:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51865:1031/113615.217291:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113615.220686:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51862:1031/113621.221483:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51862:1031/113621.221522:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51862:1031/113621.225254:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113624.053140:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51861:1031/113628.139480:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51861:1031/113629.282708:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113639.299768:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE visit_time >= ? AND visit_time < ? AND (transition & ?) == ?ORDER BY visit_time LIMIT ?
[51843:51862:1031/113640.941214:ERROR:get_updates_processor.cc(260)] PostClientToServerMessage() failed during GetUpdates with error 2
[51843:51861:1031/113647.297876:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51862:1031/113648.046927:ERROR:get_updates_processor.cc(260)] PostClientToServerMessage() failed during GetUpdates with error 2
[51843:51862:1031/113655.102726:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:51862:1031/113655.102774:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113655.104381:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51865:1031/113655.299801:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:58201:1031/113703.143039:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:58201:1031/113703.143083:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:58201:1031/113703.144772:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:58199:1031/113703.240359:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:51952:1031/113703.675928:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:58200:1031/113711.489564:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE id=?
[51843:58200:1031/113711.489621:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?
[51843:58200:1031/113711.490252:ERROR:database.cc(1761)] History SQLite error: code 1 errno 0: no such column: publicly_routable sql: SELECT id,url,visit_time,from_visit,transition,segment_id,visit_duration,incremented_omnibox_typed_score,publicly_routable FROM visits WHERE url=? ORDER BY visit_time DESC, id DESC LIMIT ?

I also restarted the Kwin compositor and the functionality comes back. This is the command I used:

kwin_x11 --replace

Icon theme "gnome" not found.
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 180, resource id: 8388621, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 181, resource id: 8388621, major code: 20 (GetProperty), minor code: 0
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5089:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5091:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5093:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5097:47: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5099:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5107:48: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5111:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5113:46: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5117:45: this compose sequence is a duplicate of another; skipping line
kwin_xkbcommon: XKB: /usr/share/X11/locale/en_US.UTF-8/Compose:5120:46: this compose sequence is a duplicate of another; skipping line
Module 'org.kde.kwin.decoration' does not contain a module identifier directive - it cannot be protected from external registrations.
OpenGL vendor string:                   AMD
OpenGL renderer string:                 Radeon RX 580 Series (POLARIS10, DRM 3.42.0, 5.14.12-zen1-1-zen, LLVM 12.0.1)
OpenGL version string:                  4.6 (Compatibility Profile) Mesa 21.2.3
OpenGL shading language version string: 4.60
Driver:                                 RadeonSI
GPU class:                              Arctic Islands
OpenGL version:                         4.6
GLSL version:                           4.60
Mesa version:                           21.2.3
X server version:                       1.20.13
Linux kernel version:                   5.14.12
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
qml: FORCE-BLUR: starting the script
qml: ["peek"]
kwin_core: XCB error: 10 (BadAccess), sequence: 2807, resource id: 1737, major code: 142 (Composite), minor code: 2 (RedirectSubwindows)

Well that is somewhat good news. Kwin has been causing issues on a few other threads I've responded to as well. I have suggested switching to one of the alternate versions of kwin (there are quite a few), but that supposedly did not help in that case. However, it still may be worth trying the different kwin variations as your cause could be different than the other case I was dealing with.

It also wouldn't hurt to try various different combinations of settings for your compositor in the KDE System Settings.

2 Likes

I have tried alternating them. The problem persists. As of right now, there does not seem to be a widespread issue affecting multiple users. This may just affect my system and it is intermittent. As such, I think it prudent to ask the Garuda Team if they would like me to mark this as being solved to close the thread out since the suggestions presented here have worked for other members?

If your issue still persists I would leave your thread open.

1 Like

I will keep it open at your direction until a solution has been identified.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.