Octopi not launching

System:
  Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=62f24ed7-81ec-4c6c-aec8-a039b2cfc0be
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.7 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: MEDION product: MD35261 v: N/A serial: <superuser required> Chassis:
    type: 3 serial: <superuser required>
  Mobo: MEDION model: B460H6-EM v: 1.0 serial: <superuser required> UEFI: American Megatrends
    v: 460H6W0X.107 date: 11/16/2021
CPU:
  Info: model: Intel Core i5-10400F bits: 64 type: MT MCP arch: Comet Lake gen: core 10 level: v3
    note: check built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165) stepping: 3
    microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4000 high: 4008 min/max: 800/4300 scaling: driver: intel_pstate
    governor: powersave cores: 1: 4002 2: 3996 3: 4000 4: 3999 5: 3994 6: 4001 7: 4000 8: 4000
    9: 4006 10: 4001 11: 3999 12: 4008 bogomips: 69597
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] vendor: ZOTAC driver: nvidia
    v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+ status: current (as of 2022-10)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2489 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5 compositor: kwin_x11 driver: N/A
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 93 s-size: 524x292mm (20.63x11.50") s-diag: 600mm (23.62")
  Monitor-1: DP-4 res: 1920x1080 dpi: 94 size: 521x293mm (20.51x11.54") diag: 598mm (23.53")
    modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2
    direct render: Yes
Audio:
  Device-1: Intel Comet Lake PCH-V cAVS vendor: MEDION AG driver: snd_hda_intel bus-ID: 1-9:4
    v: kernel chip-ID: 0d8c:0012 alternate: snd_sof_pci_intel_cnl class-ID: 0300 bus-ID: 00:1f.3
    chip-ID: 8086:a3f0 class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1
    chip-ID: 10de:228b class-ID: 0403
  Device-3: C-Media KLIM PUMA type: USB driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: MEDION AG driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
RAID:
  Hardware-1: Intel Device driver: ahci v: 3.0 port: 5020 bus-ID: 00:17.0 chip-ID: 8086:a386 rev:
    class-ID: 0104
Drives:
  Local Storage: total: 942.7 GiB used: 61.25 GiB (6.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID
-1: /dev/sda maj-min: 8:0 vendor: Phison model: S11-512G-SSD-B27 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: J1.3 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 4B6Q
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 11.87 GiB (2.5%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB (0.2%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 11.87 GiB (2.5%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 11.87 GiB (2.5%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 11.87 GiB (2.5%) fs: btrfs
    dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.43 GiB used: 72.5 MiB (0.5%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 30 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 36%
Info:
  Processes: 329 Uptime: 21m wakeups: 0 Memory: 15.43 GiB used: 4.28 GiB (27.8%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1418
  libs: 409 tools: octopi,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-07
  Last full system update: 2022-11-07 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            

Hello,

I'm unable to launch Octopi, even after a reboot and uninstalling/reinstalling Octopi.
I launched it from the Terminal, and it says that :

octopi: symbol lookup error: octopi: undefined symbol: _ZN11QTermWidget20setScrollBarPositionENS_17ScrollBarPo
sitionE

I tried to search what the error was, but I couldn't find anything..

1 Like

All fine here.

what did you change?

1 Like

Nothing related to Octopi I guess, I did a clean install today then I installed EasyEffects, some plugins for it, gnome-disk-utility, steam,.. I installed Pamac, it's working fine.

Funny, I was using Octopi the other day, but I am now getting the same error..

[[email protected] ~]$ octopi
octopi: symbol lookup error: octopi: undefined symbol: _ZN11QTermWidget20setScrollBarPositionENS_17ScrollBarPositionE

1 Like

Post

cat /var/log/pacman.log | grep '2022-11' | egrep 'installed|upgraded|remov

maybe in https://bin.garudalinux.org/

or grep -E :wink: for egrep
1 Like

It's honestly better to learn to use pacman -Ss and similar to search, that way you're also never tempted to use something like Octopi or Pamac for something other than just searching, cause it's going to make you pay if you do some way or another.

Just search in octopi, pamac or pacseek, but use pacman for install.

1 Like

It is a convenient tool that Garuda pre-installs, I don't see what the problem is with the fact that I use it. But I have no problem if it's needed to use the terminal or whatever..

Actually, it's post-installed, not pre-installed. It's in the post-install tool after installation has completed. Frankly I'm not sure why either octopi or pamac are included in that post-install application, but it needs to be clear that use of it is not recommended beyond searching at best. And for searching.... pacman is just as simple and complete.

1 Like

I was looking for something like synaptic for Arch, and I tried Octopi. Not even close, and it also uses Qt and I prefer GTK+ as I use Gnome. Looking around I have found tkPacman and loved it! Probably the most underrated Arch app ever.

A liitle bit out datet

First Submitted: 2013-08-25 14:25 (UTC)
Last Updated: 2021-02-08 16:01 (UTC)

If it works fine and has all the needed features, then why update? IMO it works much better than Octopi.

So I can close this topic?

Octopi working as-designed on a brand new vanilla Arch + Plasma installation.

I had a similar thought not too long ago: Maybe we should stop shipping GUI software centers

The GUI package managers do tend to break things or create unnecessary problems sometimes, but the gyst of the linked discussion was if we got rid of them we'd likely just have different problems and breakages in the forum.

I guess they generally work well enough that sooner or later we'll probably have to accept that people are going to keep using them. At least Octopi, which I think is a good piece of software.

Pamac, on the other hand, is more or less a time bomb. :smirk: :clock10: :bomb:

2 Likes

even the word pamac makes me shudder these days. Octopi on the other hand, along with octopi-notifier installed (for a convenient visual reminder of how many updates are waiting), - never had an issue with either, but pamac....

Hmmm... Most of those are bad, though still, especially when it comes to updating the system. Never ever use these to do anything more than search. Though, Tcl/Tk? 1994's calling. :slight_smile:

Huh. It's unfortunate that that thread topic got closed before I could pop in on it. :slight_smile: I definitely have some thoughts on the matter.

Something I use, personally, to maintain my updates is kalu, configured specifically to run /usr/lib/garuda/launch-terminal "update; read -p 'Press enter to exit'" on clicking the update button on the notification it presents. So, updates are handled. Pacseek, that's an interesting idea for sure. :slight_smile:

1 Like

Hey guys, for me Octopi is not working since I updated, if I can live without it, I'd love to know how...