Nvidia drivers not working as expected

Hello

I am new to Garuda linux (and linux in general). I'm trying to install Garuda on my old computers first so I don't lose my stuff, but I'm having trouble getting my Nvidia GPU to work. I have an intel core i7 - 3537u, 2.0GHz CPU with integrated graphics and an Nvidia Geforce 710m.
I tried following the Arch linux wiki on the installation procedure, but it says I need to install the nvidia-470xx-dkms, while the Garuda assistant journal error says I need the 390 version... I tried installing both but in both scenario when I get to the point where I have to configure Xorg, Garuda doesn't want to boot again, it's just stuck on the booting screen. I have to load the snapshot from before I edit the files for it to work again.

I'm out of options, I might never have used linux before but I'm not a noob in computers (and Garuda works perfectly fine on my other computer that only has Intel and no Nvidia, so...)

Welcome

Can you provide your

garuda-inxi

3 Likes

He meant type it in as a command, not open it up! :joy:

It is a special script that pulls helpful system info--looking at the script itself will be less helpful.

1 Like

Yeah sorry just noticed myself lol...

System:
Kernel: 5.16.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=86eec3f3-9454-4429-a344-54b40637c4d3 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: X550CL v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: X550CL v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: X550CL.204 date: 10/17/2013
Battery:
ID-1: BAT0 charge: 31.7 Wh (99.4%) condition: 31.9/37.4 Wh (85.2%)
volts: 14.4 min: 14.4 model: ASUSTeK X550A26 type: Li-ion serial: N/A
status: N/A cycles: 374
CPU:
Info: model: Intel Core i7-3537U bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2417 high: 2965 min/max: 800/3100 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2893 2: 1690 3: 2965
4: 2123 bogomips: 19952
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK
driver: i915 v: kernel ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
620M/625M/630M/720M]
vendor: ASUSTeK driver: N/A alternate: nouveau, nvidia_drm, nvidia pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:1140 class-ID: 0302
Device-3: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 1-1.3:3 chip-ID: 04f2:b40a class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: LVDS1 mapped: LVDS-1 built: 2010 res: 1366x768 hz: 60 dpi: 99
gamma: 1.2 size: 350x190mm (13.8x7.5") diag: 398mm (15.7") ratio: 16:9
modes: 1366x768
OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
v: 4.2 Mesa 21.3.7 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Sound Server-1: ALSA v: k5.16.15-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lite-On
driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 168c:0032 class-ID: 0280
IF: wlp3s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 04:00.2 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0f2 state: down mac: <filter>
IF-ID-1: enp0s20u2 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: Samsung Galaxy series misc. (tethering mode) type: USB
driver: rndis_host v: kernel bus-ID: 3-2:2 chip-ID: 04e8:6863
class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 465.76 GiB used: 16.96 GiB (3.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
Partition:
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 16.96 GiB (3.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 16.96 GiB (3.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 16.96 GiB (3.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 16.96 GiB (3.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.68 GiB used: 170 MiB (2.9%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 63.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2900
Info:
Processes: 220 Uptime: 1h 12m wakeups: 1 Memory: 5.68 GiB
used: 2.99 GiB (52.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1735 lib: 518
Shell: garuda-inxi default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-18
Last full system update: 2022-03-18 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

much better lol

2 Likes

I think your card requires drivers nvidia-390xx-dkms. But I see you already tried them.
Are you sure (but this is normally the case) your kernel headers are installed?
Maybe try a
sudo pacman -S linux-zen-headers
then
sudo pacman -S nvidia-390xx-dkms

1 Like

I saw the linux-zen-headers being updated during the system update,so yeah they are installed

1 Like

Maybe it's worth trying with the linux-lts kernel (and headers, of course).

1 Like

That is the correct driver for the 710 i know i use it remove that xorg config and the driver use pacman to set it up with nvidia-470xx-dkms driver nvidia-settings nvidia-470xx-utils

Hey don't wanna doubt you but watch out the 710 and 710m are not the exact same, as I said in the first post, I tried both 470xx and 390xx and none work for me, unless there is a workaround I don't know about

390xx looks to be the correct driver, so how are you installing it? It shouldn't need any more than

sudo pacman -Syu nvidia-390xx-dkms

to get the driver installed. Therefore, what specifically are you doing here:

?

4 Likes

I am doing what the arch linux wiki says I have to do to get nvidia as my primary GPU cause installing the drivers in itself is no issue but it keeps using my intel graphics when I play (for example minecraft, which says what graphic card it's using)

You have to use prime-run when you need the Nvidia card. E.g. see:

1 Like

The 710M is Optimus technology from nVidia, so you may want to also look at this:

https://wiki.archlinux.org/title/NVIDIA_Optimus

Also, you appear to be a bit behind on your BIOS which could help:

And as filo pointed out, you may need to prepend prime-run to the launch command. I have a few games that I have to do that too.

1 Like

prime-run won't work on Nvidia drivers earlier than 435xx.

1 Like

Nvidia drivers not working as expected

My question would be, if you never expected the Nvidia drivers to work in the first place, why in the world didn't you go with AMD. :stuck_out_tongue_winking_eye:

Sorry but, after reading your thread title more than once I just couldn't resist that quip any longer. :rofl:

5 Likes

Nvidia drivers not working, as expected.
A comma that makes the difference... :wink:

4 Likes

Awww... c'mon, I wasn't expecting a visit from the grammer police. :policeman: :wink:

4 Likes

No, not me! I already don't respect grammar in Italian, go figure in English... :blush:

1 Like

Wasn't me...

2 Likes