Ntfs-3g driver must be used in fstab to properly mount NTFS format drives

Hey, so I tried booting into Zen Kernel and Bore kernel and am getting the same error about being booted into emergency mode and to check the journal. I would post logs of that but I can't get into the system to copy that text so I'll post some pictures they hopefully will help. I didn't do anything significant to cause this afaik. All I did was some updates and an rsync backup and booted into Windows in order to use TeamViewer to help my sister out with some problems on her laptop. Please help if you can I would really appreciate it as I don't know what to do here.





Can you boot and restore a snapshot from before the update?

1 Like

Unfortunately it doesn't seem so. Keep getting the same thing on snapshots

Hang on, one of my snapshots just worked...lemme investigate this be right back

Post:

cat /etc/fstab

sudo blkid -o list
1 Like

Seems I fixed it through restoring a snapshot. Panicked and didn't think that would help but i ended up restoring one form a few days ago so not sure why my system broke considering I used my laptop yesterday. I wonder if it could have had something to do with me mounting my Windows 11 drive in fstab as this problem only happened after booting into Windows 11 like an hour ago to help my sister. Could mounting it in fstab and then booting into it cause these problems somehow? Anyway, it is no longer in my fstab but here is the output as you asked incase there is anything noteworthy to see. Thanks

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=DD47-0165                            /boot/efi      vfat    umask=0077 0 2
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf / btrfs subvol=/@,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf /home btrfs subvol=/@home,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf /root btrfs subvol=/@root,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf /srv btrfs subvol=/@srv,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf /var/cache btrfs subvol=/@cache,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf /var/log btrfs subvol=/@log,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=95b636ca-42a5-47b4-9b7a-038581af6cdf /var/tmp btrfs subvol=/@tmp,defaults,noatime,noautodefrag,compress=zstd,discard=async,ssd 0 0 #Modified_by_garuda-hotfixes(1)
UUID=41193397-191d-45b5-8c2b-405cf71e73b2 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

device                                                               fs_type         label            mount point                                                              UUID
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
/dev/sdb2                                                                           ntfs                                   (not mounted)                                                                           5AFA22EAFA22C1DD
/dev/sdb1                                                                                                                  (not mounted)                                                                           
/dev/sda2                                                                           btrfs                                  (in use)                                                                                95b636ca-42a5-47b4-9b7a-038581af6cdf
/dev/sda3                                                                           swap               swap                [SWAP]                                                                                  41193397-191d-45b5-8c2b-405cf71e73b2
/dev/sda1                                                                           vfat               NO_LABEL            /boot/efi                                                                               DD47-0165
/dev/zram0                                                                          swap               zram0               [SWAP]                                                                                  50e17f19-a0e7-4b9e-a4ae-2bf426b2a0b3

I'll perform an update in the meantime to make sure it wasn't that

Yes.

Look at your errors, failed mount unit, sdb2 (NTFS).

Seems like their is a bug mounting the junk NTFS file system this week from recent reports.

Be sure to use the nofail flag if you mount via fstab.

2 Likes

Ah that's pretty shit. I had it mounted for rsync reasons as it's an internal SSD.

Seems I'm getting another issue now though. When in Dolphin, I select Basic Data Partition which is my Windows Install. It says the following when clicking on it.

An error occurred while accessing 'Home', the system responded: The requested operation has failed: Error mounting /dev/sdb2 at /run/media/adamj/5AFA22EAFA22C1DD: wrong fs type, bad option, bad superblock on /dev/sdb2, missing codepage or helper program, or other error
man fstab

NTFS is useless for backing up Linux. It wont preserve Linux file permissions (unless contained in an archive).

2 Likes

Oh I see, I'll use an external disk in the future then thanks. But in the meantime, any idea how to fix that problem in Dolphin? I'm not trying to mount it anymore in fstab but it used to work without a problem.

It's a bug from the looks of things.

External hard disk mount problem

Try mounting the drive in fstab using ntfs-3g flag.

2 Likes

Seems to be a bug like you said which is unfortunate. When selecting my Windows drive through Dolphin it says:

An error occurred while accessing 'Home', the system responded: The requested operation has failed: Error mounting /dev/sdb2 at /run/media/adamj/5AFA22EAFA22C1DD: wrong fs type, bad option, bad superblock on /dev/sdb2, missing codepage or helper program, or other error

I entered your text into the fstab file and when running sudo mount -a it didn't give an error for once but I still can't access the drive from within Linux.

Try the linux-lts kernel.

1 Like

Good idea and I will try, but I just managed to fix the problem. I replaced ntfsprogs with ntfs-3g and rebooted and it just worked. Could this be because my fstab contained the wrong ntfs package you gave me or because there's a bug in one package but not the other? I'm very intrigued now so I'm gonna investigate this a bit deeper

As I figured, likely a new kernel bug, as the NTFS driver is in-kernel now, (bad mistake IMO).

2 Likes

Replaced the package name in fstab and same problem again. Gonna just stick to the one that works for now I think. No clue what is different between these packages though

Oh I see, so it may be better to stick with ntfs-3g? Any reason to go with one or the other really?