My Garuda Dr460nized install is no longer showing up in grub after installing Garuda Hyprland

Today I decided to try out Hyprland and after installing Garuda Hyprland to it’s own partition my Garuda Dr460nized install is no longer showing up in grub and I can’t boot into it. all the files are still there, also bear with me as I have basically no experience with Grub.

Boot all drives and

sudo update-grub

check if os-prober is activ.



Tried that still only showing my Garuda Hyprland and windows install.

Where you check

lsblk -f
cat /etc/fstab
1 Like
  Kernel: 6.6.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    available: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: Hyprland info: waybar vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: X670 AORUS ELITE AX v: -CF serial: <superuser required>
  Mobo: Gigabyte model: X670 AORUS ELITE AX v: x.x serial: <superuser required> UEFI: American
    Megatrends LLC. v: F9 date: 06/06/2023
  Info: model: AMD Ryzen 7 7800X3D bits: 64 type: MT MCP arch: Zen 4 gen: 5 level: v4 note: check
    built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25) model-id: 0x61 (97) stepping: 2
    microcode: 0xA601203
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 2408 high: 4989 min/max: 400/5050 scaling: driver: amd-pstate-epp
    governor: powersave cores: 1: 3972 2: 400 3: 400 4: 3840 5: 3370 6: 400 7: 3669 8: 3978 9: 400
    10: 400 11: 3972 12: 3972 13: 400 14: 4989 15: 400 16: 3975 bogomips: 134147
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: driver: nouveau v: kernel
    non-free: 545.xx+ status: current (as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: DP-2 empty: DP-1, DP-3, DVI-D-1, HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1c03 class-ID: 0300 temp: 60.0 C
  Device-2: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-4, DP-5, DP-6, HDMI-A-2 bus-ID: 15:00.0 chip-ID: 1002:164e class-ID: 0300
    temp: 45.0 C
  Display: wayland server: v: with: Xwayland v: 23.2.3 compositor: Hyprland
    driver: X: loaded: amdgpu,nouveau unloaded: modesetting alternate: fbdev,nv,vesa
    dri: nouveau,radeonsi gpu: nouveau display-ID: 1
  Monitor-1: DP-2 model: Acer XV272U V serial: <filter> built: 2023 res: 2560x1440 hz: 60
    dpi: 109 gamma: 1.2 scale: 1 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: Vulkan v: 1.3.274 layers: 3 device: 0 type: integrated-gpu name: AMD Radeon Graphics
    (RADV RAPHAEL_MENDOCINO) driver: mesa radv v: 23.3.2-arch1.2 device-ID: 1002:164e
    surfaces: xcb,xlib,wayland device: 1 type: cpu name: llvmpipe (LLVM 16.0.6 256 bits)
    driver: mesa llvmpipe v: 23.3.2-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: NVIDIA GP106 High Definition Audio vendor: driver: snd_hda_intel v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 10de:10f1 class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 15:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 15:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: DCMT USB Condenser Microphone driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-5:2 chip-ID: 31b2:0011 class-ID: 0300
    serial: <filter>
  Device-5: HP HyperX Virtual Surround Sound driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-1:2 chip-ID: 03f0:0b92 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.6.10-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A stat
us: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter driver: mt7921e
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 0f:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp15s0 state: down mac: <filter>
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 3-7:4 chip-ID: 0e8d:0616 class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2 lmp-v: 11 status:
    discoverable: no pairing: no class-ID: 6c0104
  Local Storage: total: 6.02 TiB used: 2.22 TiB (36.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 4B2QEXM7 temp: 35.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB size: 931.51 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 2B6Q
    scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: CC26 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 2B6Q scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Western Digital model: WD20SDRW-11VUUS0 size: 1.82 TiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s lanes: 1
    mode: 3.2 gen-1x1 tech: HDD rpm: 5400 serial: <filter> fw-rev: 1026 scheme: GPT
  ID-6: /dev/sde maj-min: 8:64 vendor: SanDisk model: USB 3.2Gen1 size: 114.6 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: N/A serial: <filter> fw-rev: 1.00 scheme: MBR
  ID-1: / raw-size: 32 GiB size: 32 GiB (100.00%) used: 8.5 GiB (26.6%) fs: btrfs
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 32 GiB size: 32 GiB (100.00%) used: 8.5 GiB (26.6%) fs: btrfs
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 32 GiB size: 32 GiB (100.00%) used: 8.5 GiB (26.6%) fs: btrfs
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-5: /var/tmp raw-size: 32 GiB size: 32 GiB (100.00%) used: 8.5 GiB (26.6%) fs: btrfs
    dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 61.95 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 55.2 C mobo: 38.0 C
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 45.0 C device: nouveau temp: 60.0 C fan: 0
  Processes: 389 Uptime: 16m wakeups: 0 Memory: total: 64 GiB available: 61.95 GiB
  used: 2.8 GiB (4.5%) Init: systemd v: 255 default: graphical tool: systemctl Compilers:
  gcc: 13.2.1 Packages: 1211 pm: pacman pkgs: 1206 libs: 360 tools: paru pm: flatpak pkgs: 5
  Client: shell wrapper v: 5.2.21-release inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2024-01-08
  Last full system update: 2024-01-08 ↻
  Is partially upgraded:   No
  Relevant software:
       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Please answer and post the termial output from
lsblk -f
cat /etc/fstab

NAME        FSTYPE FSVER LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─sda2      ntfs         Modding  62B29B88B29B5F7B                      194.4G    79% /run/media/flugel/Modding
├─sdb2      ntfs                  1C6448D76448B4F4                                    
└─sdb3      btrfs                 c056f176-2dee-4733-98cc-8795b41ffa8e                
├─sdc1      ntfs         Recovery B00EBEDE0EBE9D32                                    
├─sdc2      vfat   FAT32          2ABF-3E9C                                           
├─sdc4      ntfs                  2ACEC0F9CEC0BDF7                                    
└─sdc5      ntfs                  10F01464F01451F8                                    
└─sdd1      ntfs         Elements 0C0CE4210CE40792                      335.2G    82% /run/media/flugel/Elements
├─sde1      exfat  1.0   Ventoy   4E21-0000                                           
└─sde2      vfat   FAT16 VTOYEFI  B2C8-40D2                                           
zram0                                                                                 [SWAP]
├─nvme0n1p1 vfat   FAT32          4147-9B7C                             298.8M     0% /boot/efi
├─nvme0n1p2 btrfs                 0967e0da-c230-40ed-905e-eca5b71d28ad                
└─nvme0n1p3 btrfs                 89e1f2a6-9768-4a0c-948a-2755c504dea6   22.8G    27% /var/log
File: /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4147-9B7C                            /boot/efi      vfat    defaults,noatime 0 2
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=89e1f2a6-9768-4a0c-948a-2755c504dea6 /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

I’m not sure if this will help but when I installed hyprland a few days ago i had to use the live CD and garuda boot repair making sure to point it at the kde install. I used Repair Grub option. It took two times but after It showed up in grub.

There is M$ dual boot and the ventoy USB-Stick


Boot from garuda and post again.

Not sure if you’re asking for the output of os-prober or not but it is active. also thanks for the help so far.

/dev/sdb3:Garuda Linux:Garuda:linux:btrfs:UUID=c056f176-2dee-4733-98cc-8795b41ffa8e:subvol=@
/dev/sdc2@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.

Double checked and yeah os-prober is enabled and active.

Are there grub updates in pacman log?
There are nice blue info text from them after updates, I must then use my custom.cfg to boot my favorite garuda on the multiboot Nvme.

So try

I assume that’s in Garuda boot options which unfortunately will not even launch for me on hyprland. could it be because my Garuda Dr460nized and my Garuda hyprland install are both just called “Garuda Linux”? I have no idea how grub works so forgive me if this idea is dumb.

Maybe use this as help. Its the custom.cfg in /boot/grub

menuentry "Garuda Linux i3wm auf nvme0n1p7" {
   insmod btrfs
   search --no-floppy --fs-uuid --set=root 21e02e96-0ed6-4629-9a39-85ffee7a4359
   configfile /@/boot/grub/grub.cfg
menuentry "Garuda Hypr-SGS auf nvme0n1p8" {
   insmod btrfs
   search --no-floppy --fs-uuid --set=root b147dd48-f302-484d-80b0-661e7ff40a76
   configfile /@/boot/grub/grub.cfg
menuentry "Garuda Linux KDE auf nvme0n1p5" {
   insmod btrfs
   search --no-floppy --fs-uuid --set=root fc62cc44-07ab-497b-ac89-15704c290993
   configfile /@/boot/grub/grub.cfg
menuentry "Garuda Linux Hyprland-Test auf nvme0n1p6" {
   insmod btrfs
   search --no-floppy --fs-uuid --set=root 4c17a9ec-6a7a-4114-8443-65c4d6e1d121
   configfile /@/boot/grub/grub.cfg
menuentry 'Windows auf nvme0n1p1' --class windows --class os $menuentry_id_option 'osprober-efi-94BA-ECE1' {
	insmod part_gpt
	insmod fat
	search --no-floppy --fs-uuid --set=root 94BA-ECE1
	chainloader /EFI/Microsoft/Boot/bootmgfw.efi

Search UUID from KDE and edit my sample, normally sudo update-grub find M$ and other OS, now I am out of ideas.

i used the kde live iso. hyprland one was not working on the 6th

[edit] to restore grub.

By default, Grub will be installed with the bootloader ID “Garuda”, which will add the bootloader files to /boot/efi/EFI/Garuda. If your two installations are sharing an EFI partition, the second installation will have overwritten this directory from the first one.

To set them up with separate bootloader files, boot to whichever one is still working (Hyprland I guess), and rename this directory to something else, for example “garuda_hyprland”:

sudo mv /boot/efi/EFI/Garuda /boot/efi/EFI/garuda_hyprland

Next, change the GRUB_DISTRIBUTOR= line in /etc/default/grub to match whatever you just named the boot directory in /boot/efi/EFI/.

sudo micro /etc/default/grub

Run the Grub installation script. Probably grub-install or grub-install --no-nvram (to not add another NVRAM entry) will be enough. If you are not sure, or want to learn more about the options, refer to the document here: GRUB - ArchWiki

sudo grub-install --no-nvram

Regenerate the Grub configuration file.

sudo update-grub

Next, you will have to reinstall Grub on the first installation from a chroot as described here: How to chroot Garuda Linux

After you get Grub reinstalled on the first installation, you should be able to boot to either one because they will have separate bootloader files.


Okay this sorta worked it completely broke my hyprland install but thanks to the chroot guide I was able to get my original Dr460nized system back so I guess problem solved and thanks. now to clean up this mess of partitions.

Oops! What happened? How is it broken?

No idea and at this point idc. I’m just glad to have my main system back only problem now is I think my mouse driver is a little broken after this so that’s fun.