My favorite Games are unplayable (<1fps) and it would be really nice if they weren't

My hardware is a little old at this point but my games worked before and i don’t want to change distro again if i don’t have to because i kinda like it here already.

For now i only installed Final Fantasy XIV, Divinity 2 Original Sin, Guild Wars 2 and Stardew Valley.
And except Stardew Valley they are all completely unplayable.
Well i can walk around in Guild Wars 2 with about one or two fps, Final Fantasy feels even worse than that, if you believe it, and Divinity seems to just die in the menu screen for some reason.
I thought my cpu was just overworked when i saw it reach 99% usage but Guildwars actually drops to 30-50% and the frames per minute stay the same.
Also rest of the os still works smoothly while this is happening in any game.
I can’t find any way to see gpu performance.

I searched for lag and just found system lag posts, which i don’t believe i have and i searched for games or gaming and found garuda users sharing what games they play which is cute.
I tried lutris, steam, just pure wine and downloaded proton-ge at the end which didn’t help either.
I read somewhere to turn off the compositor but the mentioned Alt Shift F12 doesn’t work and i can’t find a button anywhere to turn it off either.
I’ve been looking through a bunch of the buttons in this os, like in garuda welcome, assistant, settings etc., though somehow octopi died at some point after updating i think and one or two buttons on the garuda welcome page don’t work anymore either. (Edit: ocopti lives \o/ and it is Garuda Settings Manager and Partition Manager that just refresh the garuda welcome screen and don’t start)

I also looked into lutris logs and started steam through terminal once to see if i can spot any errors but i didn’t see anything at all? The games were just slow af for no reason from what i could see.
System ssd is btrfs, games are on my second mounted ssd, which is also btrfs.
Clean installs too on both of those, formatted and everything.

Any usual steps one should take when trying to find out why games are slow and if they could be faster?
Do i have to swap to a more lightweight distro or something? because i kinda don’t wanna
I’ve played on Solus before for about a year and a half and my games worked well enough for me, but at some point steam stopped working, which was a bummer, and then my favorite game stopped working too so i tried manjaro which really just broke everything even more, so i chose to make a clean install with this garuda os thingy and it’s pretty :3

Kernel: 6.9.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=786fdf56-7a51-45e7-894b-59f6783ea031 rw rootflags=subvol=@
quiet resume=UUID=7a68cc1c-d962-4781-8e17-be673fe348ce loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: M5A97 EVO R2.0 v: Rev 1.xx
serial: <superuser required> part-nu: SKU uuid: <superuser required>
UEFI: American Megatrends v: 2201 date: 11/25/2013
Info: model: AMD FX-6300 bits: 64 type: MT MCP arch: Piledriver level: v2
built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
microcode: 0x6000852
Topology: cpus: 1x cores: 3 tpc: 2 threads: 6 smt: enabled cache:
L1: 288 KiB desc: d-6x16 KiB; i-3x64 KiB L2: 6 MiB desc: 3x2 MiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 3228 high: 3500 min/max: 1400/3500 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3500 2: 1868
3: 3500 4: 3500 5: 3500 6: 3500 bogomips: 45516
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Curacao PRO [Radeon R7 370 / R9 270/370 OEM] vendor: ASUSTeK
driver: radeon v: kernel alternate: amdgpu arch: GCN-1
code: Southern Islands process: TSMC 28nm built: 2011-20 pcie: gen: 2
speed: 5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
active: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1 bus-ID: 01:00.0
chip-ID: 1002:6811 class-ID: 0300 temp: 47.0 C
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: radeon display-ID: :1 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
s-diag: 485mm (19.11")
Monitor-1: DVI-I-1 mapped: DVI-0 model: Acer X203H serial: <filter>
built: 2009 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
size: 443x249mm (17.44x9.8") diag: 508mm (20") ratio: 16:9 modes:
max: 1600x900 min: 720x400
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi x11:
drv: radeonsi inactive: wayland
API: OpenGL v: 4.5 vendor: amd mesa v: 24.0.7-arch1.3 glx-v: 1.4
direct-render: yes renderer: PITCAIRN (radeonsi LLVM 17.0.6 DRM 2.50
6.9.1-zen1-1-zen) device-ID: 1002:6811 memory: 1.95 GiB unified: no
API: Vulkan v: 1.3.279 layers: 13 device: 0 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD SBx00 Azalia vendor: ASUSTeK M4A89GTD PRO/USB3
driver: snd_hda_intel v: kernel bus-ID: 00:14.2 chip-ID: 1002:4383
class-ID: 0403
Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
Series] vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
chip-ID: 1002:aab0 class-ID: 0403
API: ALSA v: k6.9.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK P8 series driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 7-3:2 chip-ID: 0bda:8771
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 1.03 TiB used: 252.54 GiB (24.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD Blue SA510 2.5 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0100
scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS725050A7E630
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A420 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Plextor model: PX-128M6S
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 1.03 scheme: GPT
ID-1: / raw-size: 101.87 GiB size: 101.87 GiB (100.00%)
used: 21.16 GiB (20.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
ID-3: /home raw-size: 101.87 GiB size: 101.87 GiB (100.00%)
used: 21.16 GiB (20.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-4: /var/log raw-size: 101.87 GiB size: 101.87 GiB (100.00%)
used: 21.16 GiB (20.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
ID-5: /var/tmp raw-size: 101.87 GiB size: 101.87 GiB (100.00%)
used: 21.16 GiB (20.8%) fs: btrfs dev: /dev/sdc2 maj-min: 8:34
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 6 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.07 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdc3 maj-min: 8:35
System Temperatures: cpu: 26.9 C mobo: N/A gpu: radeon temp: 47.0 C
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.52 GiB used: 1.41 GiB (9.1%)
Processes: 262 Power: uptime: 4m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.2 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1919 pm: pacman pkgs: 1909 libs: 570 tools: octopi,pamac,paru
pm: flatpak pkgs: 10 Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-19
Last full system update: 2024-05-20
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

There was an issue with the kernels, 6.8, etc, but for me, all is corrected in 6.9 which is what you are running, so I assume we can rule that out. I would suggest looking at my links from this post, make sure you have everything needed installed, GPU to wine. I use Lutris mostly, and am not having issues with any of my games, Skyrim, BG3, et.

1 Like

Ty for answering!

Include = /etc/pacman.d/mirrorlist

This line was not commented to begin with, so i guess i should already have that?

And i think i will go down that list of the ultimate guide tomorrow after i wake up since it seems there is a bit more to read and i may need my brain for it before i break anything important

1 Like

Also, I use wine-staging, not the regular wine, as I think the guide suggests, just fyi.

Try running sudo pacman -S linux linux-headers and reboot.
Check for the issues then.

Zen has betrayed me sometimes with same symptoms as yours.

The best WINE for games it’s wine-staging-wow64, with this I can run all my games just install & play (Battlefield Hardline, Burnout Paradise, CRSED, Deux Ex, Fast & Furious, Football Manager 24, GTA IV, GTA V, Football Life 24, NFS 12, NFS Rivals, NFS Payback) install with Heroic and activate Esync and Fsync.

1 Like

I’ve read somewhere that ananicy cpp can cause problems and i tried to turn it off - didn’t change anything.
The ‘ultimate guide’ told me to update drivers,
use zen kernel(i tried the linux headers command thing instead since i had zen already),
put RADV_PERFTEST=aco into /etc/environment,
install wine dependencie including wine staging(it said before installing lutris, so i removed that before running commands),
turn on esync(ulimit -Hn is at 1048576 so it was already running i believe),
install and use gamemode(was already installed, i didn’t know it was the same FeralGamemode i’ve seen in lutris) i used it on and off in steam per gamemoderun %command% before because it didn’t really change anything as far as i noticed,
and lastly custom proton(which is protonGE which i already installed previously).

running wine manually for Guild Wars2 had at most a difference of 1 fps. (now i’m at 3fps \o/)
using Steam with gamemoderun and protonGE had to ‘process vulkan shaders’ for the time that it took to write this comment and it is stuck at 66% now.
While that was happening i found the compositor settings and made it not enable at startup, will reboot when shaders are done processing in steam and i had time to look if running the game is any different already.

Edit: I’ve rebooted now, and no compositor apparently means some graphic artifacts, game is now at 4fps. i will turn compositor on again :'D

I am not sure if i bricked something when i tried things out or if this was the problem from the beginning and i just didn’t find it.
I had a problem finding system monitors or other data about my gpu and when trying a little harder i found 0% gpu load in mangohud and then these

radeon: Failed to get PCI ID, error number -13
ERROR: […/mesa-24.0.7/src/amd/vulkan/radv_physical_device.c:1828] Code 0 : Device ‘/dev/dri/renderD128’ is not using the AMDGPU kernel driver: Invalid argument (VK_ERROR_INCOMPATIBLE_DRIVER)

Is my pci id wrong? do i just not have gpu drivers? or is there maybe a fault with other software/drivers that interfere with my gpu?
Anyways i went to the amd website and downloaded the linux 64bit drivers for my radeon r9 270(had to look at my gpu and it had a little sticker with the number on it)
i’m reading through their installation notes right now but none of their instructions work so i 'll see how far i will get

Your Bios looks outdated maybe you should install the last update from here

Version 2603

3.07 MB


I downloaded that once and then forgot. Looks like this now:
Type: Desktop Mobo: ASUSTeK model: M5A97 EVO R2.0 v: Rev 1.xx serial:
part-nu: SKU uuid: UEFI: American Megatrends v: 2603 date: 02/12/2015

This is a driver problem.
You have a GCN-1 card (Volcanic Islands) and the amdgpu driver is the right one.
Don’t try to install the proprietary amdgpu-pro driver from the amd site, it’s only for GCN 3 and later.

OpenGL and Vulkan fail for you.
Check whether you have the following packages installed:


Which kernel did you have on Solus Linux?


Sorry i fell asleep.

If volcano radeon is meant to be vulkan-radeon, all of those are installed otherwise i don’t see volcano under the packages.
And tbh i may have tried linux, lts and zen kernel in garuda but i hadn’t even heard of the word kernel in solus. Though Wikipedia says their kernel type is Monolithic (Linux)

╰─λ inxi -G

Device-1: AMD Curacao PRO [Radeon R7 370 / R9 270/370 OEM] driver: radeon

I am guessing this needs to say driver:amdgpu ?

Sorry, typo :rofl:
I edited it :slightly_smiling_face:

Post the output of:

pacman -Qs 'mesa|vulkan|xf86-video-amdgpu'

Solus runs with linux-lts.

1 Like

Sorry again i was stuck trying to get gpt to explain me how to fix it and ofc i just managed to boot into a black screen now xD
Liveusb says there is an error accessing root can’t read superblock :x

How do you come up with the idea of ​​questioning an idiotic pseudo-AI? :thinking:
Can you load and restore a snapshot?

That was my plan but can i do that without accessing my root drive? Snapper is empty
Searching for solutions didn’t help me either and random machine learning programs at least give me things that look like they could be solutions.

I’m trying to check and repair through partition manager since btrfs check command couldn’t find the drive at all.
Ok partition manager just got errors and aborted after 9 seconds. I only added like 2 config files from gpt with two lines each how could it do that to me xD

Root is back online. Just need to redo all my settings i guess

i will try to fix that too because it crashed on my computer too. i have all stuff installed but still a big error list. Ive already send a Email to the support with my e-mail.Waiting for answer =) i have the amdgpu installed but the game error says 0MB memory =) iv i got the solution i will let u know :wink:

btw on linux Garuda you have the Software called Goverlay that shows me no error 60FPS on Vulcan actually when i have the launcher open =)

You have now changed so much to the system that I think it would make sense if you reinstalled it - so you would have a solid foundation again. The installation is only 3 days old.

1 Like

It didn’t even crash for me! Just 30fps loading screen and no visible fps after character select ,_,
Isn’t goverlay just mangohud? I think it popped up first when i searched my system for mangohud

Did that and I’ve already rebooted and am updatin now :q