Steam will not launch and is asking for an older 32 bit package (this is an error from 2013?)

You need the 32 bit packages. Make sure you have the multilib repo enabled, here is a guide to do so and after that, it should pull in Steam’s 32 bit files.

Arch Linux - How to enable multilib and install Steam using pacman

Here is also a handy guide for gaming, making sure you have pulled in all the necessary GPU drivers and dependencies for gaming, along with installing wine-staging/lutris, etc.

The Ultimate Linux Gaming Guide