My favorite Games are unplayable (<1fps) and it would be really nice if they weren't

You’re right, I missed that. I got the info about amdgpu from the error message in the running text - and misread it. I just now saw that you edited the post.

Sorry if i am editing too much, i believe i forgot to post that specific edit for half an hour while i was distracted elsewhere.

I’m all out of replies for the next two hours.

Was trying to go through your replies again before i install anything else.

mesa
lib32-mesa
xf86-video-amdgpu
vulkan-radeon
lib32-vulkan-radeon

all installed.
lts too for that matter though i personally didn’t notice any difference between the kernels yet.
not sure if this helps after a fresh install but here is
pacman -Qs ‘mesa|vulkan|xf86-video-amdgpu’:

pacman -Qs 'mesa|vulkan|xf86-video-amdgpu'
local/dxvk-mingw-git 2.3.1.r51.g3420cd78-1
A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux
using Wine. Windows DLL version)
local/glu 9.0.3-1
Mesa OpenGL utility library
local/goverlay-git 1.1.1.r7.g6cfcfb8-1
A GUI to help manage Vulkan/OpenGL overlays
local/lib32-glu 9.0.3-1
Mesa OpenGL utility library (32 bits)
local/lib32-libva-mesa-driver 1:24.0.7-3
Open-source VA-API drivers - 32-bit
local/lib32-mesa 1:24.0.7-3
Open-source OpenGL drivers - 32-bit
local/lib32-mesa-demos 9.0.0-1
Mesa demos (32-bit)
local/lib32-mesa-vdpau 1:24.0.7-3
Open-source VDPAU drivers - 32-bit
local/lib32-vkbasalt 0.3.2.10-1
A Vulkan post-processing layer. Some of the effects are CAS, FXAA, SMAA, deband.
local/lib32-vkd3d 1.11-1
Direct3D 12 to Vulkan translation library By WineHQ
local/lib32-vulkan-icd-loader 1.3.279-1
Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/lib32-vulkan-intel 1:24.0.7-3
Open-source Vulkan driver for Intel GPUs - 32-bit
local/lib32-vulkan-mesa-layers 1:24.0.7-3
Mesa's Vulkan layers - 32-bit
local/lib32-vulkan-radeon 1:24.0.7-3
Open-source Vulkan driver for AMD GPUs - 32-bit
local/libva-mesa-driver 1:24.0.7-3
Open-source VA-API drivers
local/mangohud 0.7.1-1
A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more.
local/mesa 1:24.0.7-3
Open-source OpenGL drivers
local/mesa-demos 9.0.0-4
Mesa demos
local/mesa-utils 9.0.0-4
Essential Mesa utilities
local/mesa-vdpau 1:24.0.7-3
Open-source VDPAU drivers
local/qt6-shadertools 6.7.0-1 (qt6)
Provides functionality for the shader pipeline that allows Qt Quick to operate on Vulkan, Metal, and
Direct3D, in addition to OpenGL
local/spirv-tools 2024.1-1 (vulkan-devel)
API and commands for processing SPIR-V modules
local/vkbasalt 0.3.2.10-1
A Vulkan post-processing layer. Some of the effects are CAS, FXAA, SMAA, deband.
local/vkd3d 1.11-1
Direct3D 12 to Vulkan translation library By WineHQ
local/vulkan-headers 1:1.3.285-1 (vulkan-devel)
Vulkan header files
local/vulkan-icd-loader 1.3.285-1
Vulkan Installable Client Driver (ICD) Loader
local/vulkan-intel 1:24.0.7-3
Open-source Vulkan driver for Intel GPUs
local/vulkan-mesa-layers 1:24.0.7-3
Mesa's Vulkan layers
local/vulkan-radeon 1:24.0.7-3
Open-source Vulkan driver for AMD GPUs
local/vulkan-swrast 1:24.0.7-3
Open-source Vulkan driver for CPUs (Software Rasterizer)
local/vulkan-tools 1.3.269-1 (vulkan-devel)
Vulkan Utilities and Tools
local/xf86-video-amdgpu 23.0.0-2 (xorg-drivers)
X.org amdgpu video driver
local/zdummy-vlkdrv 0.1-1
Dummy package

What happens when you run sudo pacman -R xf86-video-ati ?

error: failed to prepare transaction (could not satisfy dependencies)
:: removing xf86-video-ati breaks dependency ‘xf86-video-ati’ required by garuda-video-linux-config

No, that’s all correct. The wrong module is loaded.
Try to blacklist the radeon module.

Well make a .conf file in /etc/modprobe.ddirectory named radeon.conf and in that conf file, write:
blacklist radeon

And reboot.
See if it makes any difference.

inxi -G
Graphics:
Device-1: AMD Curacao PRO [Radeon R7 370 / R9 270/370 OEM] driver: N/A

My graphics are quite wonky now :q

Well what does inserting this line in the radeon.conf do:

options amdgpu cik_support=1
Try and reboot.

I don’t actually remember exactly what the gpt wanted me to do but i believe it looked liked that line except witin a different config i think
Driver is till n/a

TLDR:

Yes I was wrong make a new .conf file named amdgpu.conf in the /etc/modprobe.d and add in the following lines:

options amdgpu cik_support=1
options amdgpu si_support=1

Make a .conf file named radeon.conf in the same modprobe.d folder , and add: in the following lines

blacklist radeon
options radeon cik_support=0
options radeon si_support=0

Then reboot.

2 Likes

Keep
blacklist radeon
options amdgpu cik_support=1
in the radeon config?

Just remove that amdgpu cik thing.
Keep the blacklist line.

And add the lines mentioned above in your radeon.conf

Still driver n/a

Just to make sure here are my radeon conf:

blacklist radeon
options radeon cik_support=0
options radeon si_support=0

and
amdgpu.conf is
options amdgpu cik_support=1
options amdgpu si_support=1
like you said

amdgpu.conf is name right ? If it is the same name as the driver which is amdgpu then proceed.

I mean yes it’s named amdgpu.conf
and i’ve already rebooted :x
edited my above reply

sudo dracut
libkmod: kmod_config_parse: /etc/modprobe.d/amdgpu.conf line 1: ignoring bad line starting with ‘opt
ions’
libkmod: kmod_config_parse: /etc/modprobe.d/amdgpu.conf line 2: ignoring bad line starting with ‘opt
ions’
libkmod: kmod_config_parse: /etc/modprobe.d/radeon.conf line 2: ignoring bad line starting with ‘opt
ions’
libkmod: kmod_config_parse: /etc/modprobe.d/radeon.conf line 3: ignoring bad line starting with ‘opt
ions’
dracut[I]: Executing: /usr/bin/dracut
dracut[F]: Can’t write to /boot/efi/2645e6fa26db40689e233a11b8d9a16c/6.6.31-1-lts: Directory /boot/e
fi/2645e6fa26db40689e233a11b8d9a16c/6.6.31-1-lts does not exist or is not accessible.

iirc after forcing dracut my system got corrupted last time

apparently the dots are wrong in the option lines the config so they get ignored. i changed them to spaces and dracut has no problems with them anymore.
Rebooted and now inxi says driver:amdgpu :smiley:

And my game works omg

2 Likes

Sorry the .conf did not have to use dots, I made a mistake in reading. I have changed my reply and advise you do the same to all of your replies. So, Issue solved ? If yes then please mark it as solved.

Thank you very much.
I’ve marked the solution and edited the dots out of my one reply not sure if i should edit more.

1 Like

You happy I happy , We All Happy

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.