Meta key not working

Hello!

Back again... Two problems, i think they are related. I believe that the OS isn't detecting my meta key at all.

When I press Meta+Shift+PrintScr it does not give me a rectangular capture dialog, instead captures all of my monitors. I checked the shortcuts and it is set up properly. Also, when I hit Meta, the application launcher does not show up similar to the posts below. I've been working around this with Alt+F1. Other meta functions (the ones I've tested in the spectacle shortcuts) appear to be broken too.


Same/similar problem as these posts, but what worked here did not work for me:

  • Removing Meta mapping from ~/.config/kwinrc -- log out and log back in
  • Uninstalling and reinstalling Spectacle (i did not try this with latte)
  • Reloading a previous backed up latte config (yes, I back them up now! :slight_smile: )
  • Restoring a prior snapshot (EDIT: I was dumb and didn't enable timeline snapshots, this is on now. My latest snapshot was probably a pacman snapshot from AFTER this issue was going on for a while because I ignored it a little while)
System:
Kernel: 5.16.4-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f6cccf9c-8580-435e-8f33-927e3e31bb2d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=2e9cba84-8fd3-4884-995e-6ac1c54716ad loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE v: x.x
serial: <superuser required> UEFI: American Megatrends LLC. v: F34
date: 06/10/2021
CPU:
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3646 high: 4498 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3592 2: 3587
3: 4109 4: 3834 5: 3586 6: 3582 7: 4498 8: 3587 9: 3592 10: 3595 11: 3583
12: 3585 13: 3596 14: 3584 15: 3583 16: 3591 17: 3596 18: 3588 19: 3592
20: 3745 21: 3594 22: 3591 23: 3593 24: 3590 25: 3593 26: 3587 27: 3581
28: 3587 29: 3588 30: 3593 31: 3591 32: 3586 bogomips: 223566
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 510.47.03 alternate: nouveau,nvidia_drm bus-ID: 0a:00.0
chip-ID: 10de:1e84 class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 5119x1440 s-dpi: 107 s-size: 1215x342mm (47.8x13.5")
s-diag: 1262mm (49.7")
Monitor-1: DP-2 res: 2560x1440 dpi: 109 size: 598x336mm (23.5x13.2")
diag: 686mm (27")
Monitor-2: DP-4 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2")
diag: 685mm (27")
OpenGL: renderer: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 510.47.03 direct render: Yes
Audio:
Device-1: YUAN High-Tech Development vendor: Corsair Memory driver: N/A
bus-ID: 06:00.0 chip-ID: 12ab:0380 class-ID: 0480
Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 0a:00.1 chip-ID: 10de:10f8
class-ID: 0403
Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 0c:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-4: Texas Instruments ATH-G1WL type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.1.4:8
chip-ID: 0451:16ba class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
port: f000 bus-ID: 05:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 4.57 TiB used: 496.75 GiB (10.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: A-Data model: SX6000PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9002s85
temp: 36.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T1XHE-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 614600WD temp: 40.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EARX-00ZUDB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 896.73 GiB size: 896.73 GiB (100.00%)
used: 50.43 GiB (5.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 896.73 GiB size: 896.73 GiB (100.00%)
used: 50.43 GiB (5.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 896.73 GiB size: 896.73 GiB (100.00%)
used: 50.43 GiB (5.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 896.73 GiB size: 896.73 GiB (100.00%)
used: 50.43 GiB (5.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.49 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 31.35 GiB used: 768 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 31.0 C mobo: 29.0 C gpu: nvidia temp: 43 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 24%
Info:
Processes: 562 Uptime: 39m wakeups: 0 Memory: 31.35 GiB
used: 4.96 GiB (15.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1915 lib: 526 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-1):
System install date:     2022-01-22
Last full system update: 2022-02-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

What kind of keyboard are you using?

Corsair K70 RGB Rapidfire. It's probably not out of battery. :rofl:

That said, what did help was reinstalling garuda, but reinstalling was also a whole day affair of backing stuff up and restoring. I'd prefer not to do that for a relatively minor issue like this. It's minor, but very annoying.

The time lost to the screenshot issue adds up.

Also, I just saw this:

Corsair Community

Windows key doesn't work (fixed)

I'm writing this to help the next guy. I have the Corsair Gaming K70 RGB Mechanical Gaming Keyboard and one day out of the blue my Windows key stopped working completely (neither the windows key nor windows key combinations like Win-L). I switched to...

i didn't know that's what that switch was (gaming mode switch, disables the windows key), it looks like a shopping bag with a windows logo on it. I always assumed it was a windows store thing.

I toggled it a few times and it did nothing....


Please edit your last post as long as no one has replied to this one. This is not reddit or telegram, thank you :slight_smile:


Sorry, i saw people were typing replies, and i wanted to make sure that the replies made sense in order in case they posted before me. I'll keep that in mind for the future.

2 Likes

That was going to be my suggestion actually! :joy: Oh well...

That is a common feature on gaming keyboards. If you are playing a game in Windows and you accidentally hit the meta key, it will often kick you out of the game to respond to the keypress (to open the start menu).

Edit:

I think it is supposed to be a lock! :laughing:

I ripped the key cap off, it's just a bare switch. I also tried each key combo with the other side's windows key too, so it's not broken.

It'll always be a shopping bag to me. They should stop putting useless features on keyboards that make me go there as a default assumption. xD

1 Like

This is the page from your keyboard's manual talking about the lock key. It is unclear if you would be able to switch between those different profiles without the software (I'm guessing the software is Windows only?). I only mention it because if there is some way to switch profiles from the keyboard the "Disable Windows Key" could have been locked, and then the profile switched to one of those other features.

:man_shrugging:

That a keyboard even needs a manual these days is very :rofl:

I think you're right, this level of configuration sounds like software. There's also a bios switch that affects how it interacts with different motherboards, a compatibility switch according to a youtube video i found.

Also, I pressed the lock a few more times, walked away, came back and tried various things. Turns out that was part of the problem. I feel half dumb, and half validated. The meta key now works with spectacle for the screenshot function. However, latte still does not pop up with the application launcher. I will try adding the line back in ~/.config/kwinrc and edit this post with the results...

EDIT: That was it.

Thank you for educating me! smh keyboard manuals...

It was the "shopping bag" button on my keyboard.

make sure this line is in ~/.config/kwinrc

[ModifierOnlyShortcuts]
Meta=org.kde.lattedock,/Latte,org.kde.LatteDock,activateLauncherMenu

OR -- see the second image in the original post, make sure the checkbox in latte settings is checked reading:

Actions: :ballot_box_with_check: Press ⌘ to activate Application Launcher

:rofl:

You kids and your fancy keyboards! :laughing:

2 Likes

Depends on the keyboard - the lock-out on my K68 is up with the status lights - and to me looks like a lock :grin:

Let me check - do the math - 1954-2022 - nope, definitely not a kid!

1 Like

2022-02-02T20:21:11,970841001-05:00

Now that I look at it, I have to say mine is leaning a little more toward "shopping bag". :joy:

Ahhh! Someone modified the 'icon' it came from - and squared up the top bar. When it has an arch (!) it appears more to be a lock.

You got done in by the 'latest and greatest' syndrome - along with the "it's new - gotta change something" syndrome!

OT a bit - did you know that Windows Store is charging for things like GIMP and LibreOffice? If that takes you there - don't press it! :exploding_head:

That's a disgrace. How is that possible? How are they getting around the licence?

This is rich... no wait, I Am Rich! All you Redmond shadies are just imitating!

Licenses like GPL and MIT allow the software to be sold, or modified and sold commercially.

Is it legal to sell copies of GIMP?

Yes. The terms and conditions for copying, distribution and modification of GIMP are clearly listed in the GNU General Public License. Redistribution for free or for profit is specifically allowed, as long as the license is included and the source code is made available. See also Selling Free Software on the FSF site.

Besides the rights and conditions given by the GPL, it would also be nice (but not required) to mention in any advertising that the product being sold is GIMP (or a bundle including GIMP) or is derived from it.

We're way off topic and should probably close this thread since it has a solution. :sweat_smile:

:joy: Yeah, maybe so!

Before you go, you guys should really consider purchasing this software I've got. It's called "Firefox", trust me you're going to love it.

You have PayPal, right?

1 Like

I wouldn't even feel that aggrieved by the sale of GPL software IF there was any provision for a percentage going to the project itself. There isn't.

OK - far enough OT - even for me!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.