Lutris won't start

Using KDE Dr46onized edition and I can't get lutris to work. At times it just won't load, and when it does it soon crashes.
Tried running lutris through terminal and

lutris
Unable to load locale dir, translations won't work.
Traceback (most recent call last):
File "/usr/bin/lutris", line 54, in
from lutris.gui.application import Application # pylint: disable=no-name-in-module
ModuleNotFoundError: No module named 'lutris'

tried with both lutris and lutris-git

the line 54 of /usr/bin/lutris file is

from lutris.gui.application import Application # pylint: disable=no-name-in-module

Even though this link is quite old, I guess this is (also, like many other things right now :sweat_smile:) caused by the Python 3.9 upgrade. Cant find the module if its looking in the wrong folder :confused:


However shows that its using 3.9 already. Are you on the latest version?

I did update my system today but was stuck with black screen on boot. and used tty to restore timeshift snapshot.

python 3.8.6-1
python-dbus 1.2.16-1
python-distro 1.5.0-1
python-evdev 1.3.0-3
python-gobject 3.38.0-1
python-pillow 8.0.1-3
python-requests 2.25.0-1
python-yaml 5.3.1-4

1 Like

if you have optimus laptop
reinstall optimus-manager-git

sudo pacman -Syu optimus-manager-git
4 Likes

after updating?

Tried doing that and

error: optimus-manager-git: signature from "Pedro Henrique Lara Campos [email protected]"
is invalid
:: File /var/cache/pacman/pkg/optimus-manager-git-1.3.1.r44.ge91fb57-1-any.pkg.tar.zst is co
rrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Try again

It will work

3 Likes

thanks it worked