Loading BIOS (Grub1) endlessly after system update ussing Garuda Assistant

Good evening,

Today i have been updated my system, using Garuda Assistant, after a big update i rebooted my system using terminal, and unusual problem detected me, my laptop endlessly is entering BIOS, (Grub1), any suggestions to resolve this problem?

BTW: i've heard that's problem is massive.

Thank you!

1 Like

Boot from live USB, chroot, update system and reinstall GRUB. Reply back if you get stuck.

2 Likes

Network boot: USB CD, USB FDD, NVMe0, ATA HDD0, USB HDD, PCI LAN, i have no any opportunity to boot with live USB.

After turning on the laptop with live USB inserted, press repeatedly F12 (or whatever is used for your hw) to get to the boot selection which should show the live USB

3 Likes

When you updated your system, did you ignore any update notices? What did they say? This is important info.

5 Likes

i had the same issue with my 2 garuda systems.
my main system wasn't rebooted after the update, my laptop was. i will copy the output of the update i ran on my main console, my laptop's output wasn't saved.

"simply" performing the chroot and reinstalling of grub got both systems booting again

inxi Garuda's PrivateBin

This update shows no mention of grub getting a package update. Do you have any earlier logs?

1 Like

sorry, i do not have any others. only "saved" that one because running the update on my laptop caused it to not boot. i too don't normally save that output.

can you run the following on your PC/laptop please:

sudo /usr/share/libalpm/scripts/garuda-hooks-runner grub-update

and send the output?

2 Likes

╭─[email protected] in ~ via  v8.1.9 took 1s
╰─λ sudo /usr/share/libalpm/scripts/garuda-hooks-runner grub-update
[sudo] password for javabean:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

The GRUB bootloader with the name of Garuda is being updated in 15 seconds!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Press CTRL+C if this is not correct!
If you cancel this, you may have to manually reinstall GRUB to avoid a bootloop.
Installing for x86_64-efi platform.
Installation finished. No error reported.

1 Like

So it would've worked, but for some reason your grub was not updated like it should have been.

4 Likes

interestingly, the system failed to boot properly this morning. last update was the one logged above, i then went through and did the chroot/reinstall grub procedure and got it to boot again where i ran a "garuda-update" again. it rebooted to the "out of memory" grub screen. i hit enter and it went to the black'n'white grub screen i could boot from. unfortunately it seems that this update ran over the "scrollback limit" in konsole so i don't have a full log... gonna have to setup a "wrapper script" to log a call to "garuda-update" so this don't happen again

System updated! 🐧
Update notices:
The GRUB bootloader with the name of Garuda has been updated/reinstalled. If this looks correct, no further action has to be taken.

Seems fine, post output from

pacman -Qi grub

please.

work fine here
pacman -Qi grub
Name                     : grub
Version                  : 2:2.06.r322.gd9b4638c5-1
╭─[email protected] in ~ via  v8.1.9
╰─λ pacman -Qi grub
Name            : grub
Version         : 2:2.06.r322.gd9b4638c5-1
Description     : GNU GRand Unified Bootloader (2)
Architecture    : x86_64
URL             : https://www.gnu.org/software/grub/
Licenses        : GPL3
Groups          : None
Provides        : grub-common  grub-bios  grub-emu  grub-efi-x86_64
Depends On      : sh  xz  gettext  device-mapper
Optional Deps   : freetype2: For grub-mkfont usage [installed]
fuse2: For grub-mount usage [installed]
dosfstools: For grub-mkrescue FAT FS and EFI support [installed]
lzop: For grub-mkrescue LZO support [installed]
efibootmgr: For grub-install EFI support [installed]
libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue [installed]
os-prober: To detect other OSes when generating grub.cfg in BIOS systems [installed]
mtools: For grub-mkrescue FAT FS support [installed]
Required By     : garuda-boot-options  garuda-hooks  grub-btrfs  grub-garuda  grub-theme-garuda-dr460nized
update-grub
Optional For    : None
Conflicts With  : grub-common  grub-bios  grub-emu  grub-efi-x86_64  grub-legacy
Replaces        : grub-common  grub-bios  grub-emu  grub-efi-x86_64
Installed Size  : 33.02 MiB
Packager        : Christian Hesse <[email protected]>
Build Date      : Wed 24 Aug 2022 02:07:30 AM MDT
Install Date    : Fri 26 Aug 2022 02:15:02 PM MDT
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

i also just ran update on my other system, it received its last update on friday as well(around the same time as what was logged above) and everything is booting fine. i didn't need to "fix" grub a second time like i did here. i grabbed the log via piping, if'n you are interested in a more fuller update log.

edit:
i created the following command to start logging my updates. ran from terminal, make sure you create the .update-logs folder before running... further note, run from Konsole i think it uses fish

update &| tee ~/.update-logs/$(date +%Y-%m-%d--%H-%M)-update.txt
4 Likes

I've got the same problem on a lenovo yoga 20c0003smd and a dell optiplex 7010. I've tried booting into Garuda KDE live, used the repair boot software (not working) then chroot grub-config and grub-install (not-working) :frowning: boot loop forever

Did you try the direction in How to chroot Garuda Linux ?

For me the instructions was all i needed, but maybe running a "garuda-update" within that chroot might help. try going back in and grabbing a "garuda-inxi" at least.

p.s. logging the update like i created a command for above might help shed light into why grub keeps breaking even without it being updated

I have the same problem. I tried rebooting from live USB using both Ventoy and Rufus. Rufus method gives me blank screen if I insert the Garuda-booting USB and press BIOS key. Ventoy method gives me ventoy menu that says something like "no ISO map found" (even though I have Garuda .iso file in the USB). And when I don't have USB inserted, and I press BIOS key, then it just takes me to a BIOS menu where "boot order" gives an empty list without any options to choose from.

that is an interesting issue, i use ventoy for my installers and managed to do the chroot/grub-install fix using a ventoy boot thumbdrive. there are a few things that can stop ventoy from working properly, make sure to check their guides for more information. start with their FAQ's at FAQ . Ventoy

I finally managed to enter my computer after trying so many things without success. Here's how I did:

Short answer:

  1. Press and hold F12 on your keyboard as soon as you pressed the power button, to enter the special menu (not quite BIOS, although it resembles BIOS)
  2. The menu asks you which option you want to boot from. Select "garuda". Everything from now on works as if you never had the problem to begin with.

Long answer:

I had my bootloader USB with Garuda inserted into my computer when I started the computer. Instead of pressing the usual F2 key for BIOS, I instead pressed F12 just to see what would happen. Surprisingly, I came to a menu that resembled BIOS but wasn't quite BIOS. It asked me which of the 3 options I should boot on? One is something I don't recognize (probably something from manufacturer or remnants from original OS back when I first bought the computer), one is my USB device, and the third is garuda. And I'm thinking "there you are! I've been searching for you all over the place!" And I select that 3rd option called "garuda" and press ENTER. And then my Garuda OS loads perfectly fine as if I never had the problem to begin with.

EDIT: the above is NOT a permanent solution. It's just a temporary solution that lets me circumvent GRUB and still access my Garuda OS even though the GRUB still isn't working. But hey, I need to start somewhere right?

EDIT2: I have now verified that the USB is redundant and the above method works even without Garuda-booting USB inserted.

I ran this command:

sudo /usr/share/libalpm/scripts/garuda-hooks-runner grub-update

And here's the output I received:

Installing for x86_64-efi platform.
Installation finished. No error reported.


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

The GRUB bootloader with the name of garuda is being updated in 15 seconds!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Press CTRL+C if this is not correct!
If you cancel this, you may have to manually reinstall GRUB to avoid a bootloop.
Installing for x86_64-efi platform.
Installation finished. No error reported.

But still, the GRUB doesn't work