Lenovo Idepad 3 14IIL05 touchpad not working

I am a newcomer to Garuda, and Arch in general. The thing is, when I were in Windows 10, the touchpad would work fine. After switching to Garuda Linux, I found out that the touchpad is not working.

After running


in konsole ...

  Kernel: 5.15.32-1-lts arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=50fd5b08-4d71-4856-ad24-7f956a73a241 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=a1d80f4e-80ba-483d-afb5-ae916a02c4ef loglevel=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81WD v: IdeaPad 3 14IIL05
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 14IIL05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: EMCN14WW date: 05/11/2020
  ID-1: BAT0 charge: 30.2 Wh (97.7%) condition: 30.9/35.0 Wh (88.1%)
    volts: 8.5 min: 7.5 model: SMP L16M2PB2 type: Li-poly serial: <filter>
    status: N/A cycles: 357
  Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xA8
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 3399 high: 3402 min/max: 400/3400 scaling:
    driver: intel_pstate governor: performance cores: 1: 3402 2: 3400 3: 3400
    4: 3396 bogomips: 9523
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G1 vendor: Lenovo driver: i915 v: kernel
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a56
    class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-5:3 chip-ID: 13d3:5a08 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org v: compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 note: <missing: xdpyinfo/xrandr>
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x14d6 built: 2016 res: 1366x768
    dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-lts running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: no
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:4 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.36 TiB used: 19.46 GiB (1.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P5PSSD8
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: P7CR402
    temp: 47.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0E scheme: GPT
  ID-1: / raw-size: 444.44 GiB size: 444.44 GiB (100.00%)
    used: 7.23 GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 444.44 GiB size: 444.44 GiB (100.00%)
    used: 7.23 GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 444.44 GiB size: 444.44 GiB (100.00%)
    used: 7.23 GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 444.44 GiB size: 444.44 GiB (100.00%)
    used: 7.23 GiB (1.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 21.02 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 19.11 GiB used: 5.2 MiB (0.0%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 68.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 201 Uptime: 3h 29m wakeups: 3 Memory: 19.11 GiB
  used: 2.67 GiB (14.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 970 lib: 287 Shell: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.5.6-2):
  System install date:     2022-03-31
  Last full system update: 2022-04-01 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            man-db.timer


So, to explore the issue I plugged in an usb mouse in the freshly installed system.
After some homework I am somewhat convinced that this problem might be happening due to the touchpad drivers(ELAN tech for this lappy, if I'm not wrong).

I did find some similar issues previously asked...


(other distros and variations....)

(^ this one being the same model but from Mint(ubuntu-based)....)

and quite a few more but.....
None of them were exactly what I require maybe. Like, some were same distro but different laptop models and vice versa.
This issue might be of some help for any future users :smiley:


I did not try out any of the fixes on my own. Since, all of them deal with the grub and its file. I have this ominous feeling of messing something up. Finally, I am an absolute tyro regarding the pc drivers.
I will be really grateful, if some clarity is shed on this topic


Hi there, welcome and thanks for the detailed first post.

Just FYI, this means that you have to reboot. But this is not supposed to solve anything, of course :slight_smile:

Please give a look at this suggested BIOS setting (although it's for IdeaPad 5 instead of 3, you never can say...):


So I rebooted the system
Then I did go through the wiki

The touchpad works as expected starting from linux >= 5.8rc3 as long as Load system defaults is disabled in BIOS.

As suggested by this line, I have to disable 'load system defaults' in the bios.
But in the bios there was no option to disable it.
It was just 'load system defaults' Y/N ... sort of .
Which I did "Y" and to no effect on touchpad

Was it set to N? Because No would have made more sense to not load system defaults.
If it was previously already set to Y, you could try N, but if it was N probably that article is too old :frowning:


arch wiki IdeaPad 3 14IIL05 LNVNB161216

Yeah its mint, just try :slight_smile:

Do you change the kernel?
If yes, why? :slight_smile:


So, if you've already tested also with N without success, I see several hits with an internet search like the ones you mentioned.
I don't know... maybe the only one which might slip through is this one:
Specifically post #6, for Ideapad 3 (but they don't say which one...), suggesting to blacklist elants_i2c module
If you want to give it a try, just create e.g. a file /etc/modprobe.d/blacklist.conf and add there
blacklist elants_i2c
and reboot.
Sorry, I don't have enough technical skills to dig deeper...


There is an update.
My touchpad is now working as butter!!!

I just copy pasted the solution in:

but with a few tweaks....
That is

sudo micro /etc/default/grub

instead of installing and using nano
And comment out the line rather than changing it ...
then adding the required line below the comment one....

The journey was really amazing :smile: ......

well, I did not change any kernel prior to applying this fix though....

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.