My lenevo S145 touchpad is not working

Thats not really helpful sadly:

  • Include the output of “inxi -Fxxxza” in your post. This gives the people trying to resolve the issue proper information on the hardware used.
  • Provide the name of the iso (full name!) used to install Garuda on your system
  • If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.
System details
  Kernel: 5.10.15-120-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
  root=UUID=9f72a739-e5b9-4d0b-a28b-9dc98d95670e rw [email protected] 
  i8042.reset quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  resume=UUID=322313da-68d9-423e-960f-41cff7e53c5f loglevel=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM 
  Distro: Garuda Linux 
  Type: Laptop System: LENOVO product: 81W8 v: Lenovo IdeaPad S145-15IIL 
  serial: <filter> Chassis: type: 10 v: Lenovo IdeaPad S145-15IIL 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> UEFI: LENOVO 
  v: DKCN48WW date: 07/22/2020 
  ID-1: BAT0 charge: 22.5 Wh condition: 23.8/35.0 Wh (68%) volts: 8.5/7.6 
  model: LGC L16L2PB3 type: Li-poly serial: <filter> status: Charging cycles: 297 
  Info: Dual Core model: Intel Core i3-1005G1 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A0 
  L2 cache: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 9533 
  Speed: 3400 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3400 2: 3403 
  3: 3400 4: 3400 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Iris Plus Graphics G1 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:8a56 class ID: 0300 
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus ID: 1-5:3 
  chip ID: 5986:1135 class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Smart Sound Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:34c8 
  class ID: 0403 
  Sound Server: ALSA v: k5.10.15-120-tkg-bmq 
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: 3000 
  bus ID: 01:00.0 chip ID: 10ec:c82f class ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus ID: 1-10:4 
  chip ID: 0bda:c02f class ID: e001 serial: <filter> 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 931.51 GiB used: 14.83 GiB (1.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
  serial: <filter> rev: 0E scheme: GPT 
  ID-1: / raw size: 922.42 GiB size: 922.42 GiB (100.00%) used: 14.83 GiB (1.6%) 
  fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) 
  fs: vfat dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw size: 922.42 GiB size: 922.42 GiB (100.00%) 
  used: 14.83 GiB (1.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-4: /var/log raw size: 922.42 GiB size: 922.42 GiB (100.00%) 
  used: 14.83 GiB (1.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-5: /var/tmp raw size: 922.42 GiB size: 922.42 GiB (100.00%) 
  used: 14.83 GiB (1.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 
  ID-2: swap-2 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-3: swap-3 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-4: swap-4 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-5: swap-5 type: zram size: 1.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 220 Uptime: 53m wakeups: 4 Memory: 7.57 GiB used: 3.45 GiB (45.5%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: 
  pacman: 1539 lib: 367 Shell: fish v: 3.1.2 running in: konsole inxi: 3.3.01

Actually, I don't have the exact iso name as I didn't do dual boot. I don't have any files with me and the pendrive I used is writing GARUDA_DR460NIZED_SOARING_ . But I installed it yesterday. So it is I think - [garuda-dr460nized-linux-tkg-bmq-210107.iso]

Output of

1 Like
00:00.0 Host bridge: Intel Corporation Device 8a02 (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Iris Plus Graphics G1 (Ice Lake)
(rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 8a03 (rev 03)
00:14.0 USB controller: Intel Corporation Ice Lake-LP USB 3.1 xHCI Host Controller (r
ev 30)
00:14.2 RAM memory: Intel Corporation Device 34ef (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO I2C Con
troller #0 (rev 30)
00:15.1 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO I2C Con
troller #1 (rev 30)
00:16.0 Communication controller: Intel Corporation Management Engine Interface (rev
00:17.0 SATA controller: Intel Corporation Ice Lake-LP SATA Controller [AHCI mode] (r
ev 30)
00:1d.0 PCI bridge: Intel Corporation Ice Lake-LP PCI Express Root Port #9 (rev 30)
00:1f.0 ISA bridge: Intel Corporation Ice Lake-LP LPC Controller (rev 30)
00:1f.3 Audio device: Intel Corporation Smart Sound Technology Audio Controller (rev
00:1f.4 SMBus: Intel Corporation Ice Lake-LP SMBus Controller (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP SPI Controller (r
ev 30)
01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe W
ireless Network Adapter

This is the output


sudo dmesg | grep -Ei "touch|elan"

No output here. I copied it and pasted it.

xinput --list
1 Like
Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ USB GAMING MOUSE                          id=9    [slave  pointer  (2)]
⎜   ↳ USB GAMING MOUSE  Consumer Control        id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ USB GAMING MOUSE  Keyboard                id=10   [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=12   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ USB GAMING MOUSE  Consumer Control        id=15   [slave  keyboard (3)]

Looks like your touchpad is not detected

Try installing


sudo pacman -S linux-lts linux-lts-headers


sudo pacman -S linux-mainline linux-mainline-headers


Then boot to them from grub advanced option
And check if touchpad is detected


should i use grub advanced option to use the mainline? Or before that?

I installed Linux-lts just now. What should I do next?

And from grub select advanced option then select the lts kernel to boot


I found this related post that seems a potential solution:

It is for Ubuntu, so it will require modifying some aspects.


nothing happened :frowning:

can you convert these three lines please-

sudo apt install make dkms
cd elan_i2c_dkms
sudo dkms install .

i can only guess apt is pacman and install is -S and I don't know others

1 Like

I love you guys!!! Thank you everyone. I was so scared. But atlast the problem got solved. I learnt a lot today. I read many things rather than youtubing. Thank you so much guys for helping me grow. learn as well as fix my own problem mentality giving.

so if anyone other than me faces the same problem-

sudo nano /etc/default/grub

Edit GRUB_CMDLINE_LINUX_DEFAULT= "quiet splash"don't touch others

to GRUB_CMDLINE_LINUX_DEFAULT="quiet i8042.nopnp=1 pci=nocrs"
Now save and exit.

sudo update-grub

The next steps will be to patch the kernel

Now run git clone
After that install make and dkms, so run

sudo pacman -S make dkms

Now run

cd elan_i2c_dkms

After that run

sudo dkms install .

Finally, run



Nice to see a user who has learned to acquire knowledge and knows how to help himself. :slight_smile:
Give 'micro' a try 'instead' nano :wink:


Glad to see that Ubuntu thread got you on the right track. It feels much better when you do the learning yourself rather than waiting for someone to spoon feed you commands. This is what we try to promote with Garuda.

We try to empower new users to rely on themselves more so than others for every little thing. We try to point new users in the right direction and hope they will learn how to resolve things for themselves.

Unfortunately, many new users aren't so appreciative of our methodology. Some take offense at the expectation that users research the Archwiki before asking for help.

I'm glad you understand how much better it is to learn something for yourself. It would be nice if all new users had a similar mentality to yourself.

Congratulations, and welcome to Garuda. :+1:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

My new laptop suffered from the same issue. I tried the DKMS way which worked just alright. But I did not want to patch my kernel for that if there is a better way - adding this in case someone needs it:

  1. Create a /etc/modprobe.d/blacklist.conf
  2. Insert blacklist elan_i2c
  3. Reboot