Laptop with nvidia optimus doesn't boot further than "loading initial ramdisk"

The laptop is after installation and first update Garuda. it's currently loaded using fallback initramfs. On a 500Gb disk, Windows takes up 120 GB, the rest of the space is taken by Garuda. It has an nvidia gtx 1050 ti and integrated intel graphics. Below are the results of some of the commands.

UPD: I tried the GNOME version, it has the same problems. So I'm moving it from KDE to the main theme


inxi -SMGCxxxaz

System:    Kernel: 5.11.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a55f4ac6-88f0-4ae8-869f-69090cd01f30 rw
rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: HP product: HP Pavilion Laptop 15-cs1xxx v: Type1ProductConfigId serial: <filter>
Chassis: type: 10 serial: <filter>
Mobo: HP model: 856A v: 15.32 serial: <filter> UEFI: Insyde v: F.20 date: 08/21/2019
CPU:       Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
model-id: 8E (142) stepping: B (11) microcode: B8 cache: L2: 8 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31999
Speed: 3353 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 3353 2: 3552 3: 3989 4: 3804 5: 4075
6: 3467 7: 3479 8: 4391
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:3ea0 class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Hewlett-Packard driver: nvidia
v: 465.24.02 alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:1c8c class-ID: 0300
Device-3: Lite-On HP Wide Vision FHD Camera type: USB driver: uvcvideo bus-ID: 1-3:3
chip-ID: 04ca:7086 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.0.3 direct render: Yes

mhwd -li

> Installed PCI configs:
NAME               VERSION          FREEDRIVER           TYPE
video-linux            2021.02.19                true            PCI
video-nvidia-prime-render-offload            2021.02.01               false            PCI

Warning: No installed USB configs!

pacman -Qs intel|radeon|amd|nvidia

local/egl-wayland 1.1.6-1
EGLStream-based Wayland external platform
local/gwe 0.15.3-1
A system utility for controlling NVIDIA GPUs
local/intel-compute-runtime 20.48.18558-1
Intel(R) Graphics Compute Runtime for oneAPI Level Zero and OpenCL(TM) Driver
local/intel-gmmlib 21.1.1-1
Intel Graphics Memory Management Library
local/intel-graphics-compiler 1:1.0.5435-1
Intel Graphics Compiler for OpenCL
local/intel-media-driver 21.1.3-1
Intel Media Driver for VAAPI — Broadwell+ iGPUs
local/intel-opencl-clang 11.0.0-2
Wrapper library around clang that can compile OpenCL C kernels to SPIR-V modules
local/intel-ucode 20210216-1
Microcode update files for Intel CPUs
local/ipw2100-fw 1.3-10
Intel Centrino Drivers firmware for IPW2100
local/ipw2200-fw 3.1-8
Firmware for the Intel PRO/Wireless 2200BG
local/lib32-libva-intel-driver 2.4.1-1
VA-API implementation for Intel G45 and HD Graphics family (32-bit)
local/lib32-libvdpau 1.4-1
Nvidia VDPAU library
local/lib32-nvidia-utils 465.24.02-1
NVIDIA drivers utilities (32-bit)
local/lib32-opencl-mesa 21.0.3-1
OpenCL support for AMD/ATI Radeon mesa drivers (32-bit)
local/lib32-opencl-nvidia 465.24.02-1
OpenCL implemention for NVIDIA (32-bit)
local/lib32-vulkan-intel 21.0.3-1
Intel's Vulkan mesa driver (32-bit)
local/lib32-vulkan-radeon 21.0.3-1
Radeon's Vulkan mesa driver (32-bit)
local/libmfx 20.5.1-1
Intel Media SDK dispatcher library
local/libva-intel-driver 2.4.1-1
VA-API implementation for Intel G45 and HD Graphics family
local/libva-utils 2.11.1-1
Intel VA-API Media Applications and Scripts for libva
local/libvdpau 1.4-1
Nvidia VDPAU library
local/libxnvctrl 465.24.02-1
local/mhwd-amdgpu 19.1.0-1
MHWD module-ids for amdgpu
local/mhwd-nvidia 465.24.02-1
mhwd-nvidia pci id
local/mhwd-nvidia-390xx 390.141-1
mhwd-nvidia-390xx PCI ID database
local/neard 0.16-2
Intel's Near Field Communication manager
local/nvidia-dkms 465.24.02-2
NVIDIA drivers - module sources
local/nvidia-prime 1.0-4
NVIDIA Prime Render Offload configuration and utilities
local/nvidia-settings 465.24.02-1
Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 465.24.02-2
NVIDIA drivers utilities
local/opencl-mesa 21.0.3-1
OpenCL support for AMD/ATI Radeon mesa drivers
local/opencl-nvidia 465.24.02-2
OpenCL implemention for NVIDIA
local/vulkan-intel 21.0.3-1
Intel's Vulkan mesa driver
local/vulkan-radeon 21.0.3-1
Radeon's Vulkan mesa driver
local/whois 5.5.9-1
Intelligent WHOIS client
local/xf86-video-amdgpu 19.1.0-2 (xorg-drivers) amdgpu video driver
local/xf86-video-intel 1:2.99.917+916+g31486f40-1 (xorg-drivers) Intel i810/i830/i915/945G/G965+ video drivers
local/xf86-video-nouveau 1.0.17-1 (xorg-drivers)
Open Source 3D acceleration driver for nVidia cards

bash -c 'for Xconf in $(ls /etc/X11/xorg.conf.d/*.conf); do echo -e ==== $Xconf ; cat $Xconf ; done'

==== /etc/X11/xorg.conf.d/00-keyboard.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:alt_shift_toggle"

bash -c 'for Xconf in $(ls /etc/modules-load.d/*.conf); do echo -e ==== $Xconf ; cat $Xconf ; done'

==== /etc/modules-load.d/mhwd-gpu.conf

**bash -c 'for Xconf in $(ls /etc/modprobe.d/*.conf); do echo -e ==== $Xconf ; cat $Xconf ; done'

==== /etc/modprobe.d/mhwd-gpu.conf
options nvidia "NVreg_DynamicPowerManagement=0x02"
==== /etc/modprobe.d/nobeep.conf
# Prevent annoying beep from the pc speaker.
blacklist pcspkr==== /etc/modprobe.d/noime.conf
# Intel VPRO remote access technology driver.
blacklist mei
blacklist mei_me⏎   

journalctl -b -p3 --no-pager --no-hostname

-- Journal begins at Fri 2021-04-23 23:41:58 MSK, ends at Sat 2021-04-24 06:14:44 MSK. --
апр 24 05:56:20 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.IPPF._STA.POS1], AE_NOT_FOUND (20201113/psargs-330)
апр 24 05:56:20 kernel: ACPI Error: Aborting method \_SB.IPPF._STA due to previous error (AE_NOT_FOUND) (20201113/psparse-529)
апр 24 05:56:20 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.IPPF._STA.POS1], AE_NOT_FOUND (20201113/psargs-330)
апр 24 05:56:20 kernel: ACPI Error: Aborting method \_SB.IPPF._STA due to previous error (AE_NOT_FOUND) (20201113/psparse-529)
апр 24 05:56:20 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.IPPF._STA.POS1], AE_NOT_FOUND (20201113/psargs-330)
апр 24 05:56:20 kernel: ACPI Error: Aborting method \_SB.IPPF._STA due to previous error (AE_NOT_FOUND) (20201113/psparse-529)
апр 24 05:56:20 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.IPPF._STA.POS1], AE_NOT_FOUND (20201113/psargs-330)
апр 24 05:56:20 kernel: ACPI Error: Aborting method \_SB.IPPF._STA due to previous error (AE_NOT_FOUND) (20201113/psparse-529)
апр 24 05:56:20 systemd-tmpfiles[415]: Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted
апр 24 05:56:21 kernel:
апр 24 05:56:28 systemd-coredump[2420]: Process 2402 (paleofetch) of user 1000 dumped core.

Stack trace of thread 2402:
#0  0x00007fdd48d1305e __strncpy_avx2 ( + 0x16305e)
#1  0x000056019d8b2537 n/a (paleofetch + 0x3537)
#2  0x000056019d8b119f n/a (paleofetch + 0x219f)
#3  0x00007fdd48bd7b25 __libc_start_main ( + 0x27b25)
#4  0x000056019d8b13ce n/a (paleofetch + 0x23ce)

bash -c 'for Xlog in $(ls /var/log/Xorg.?.log); do echo -e ==== $Xlog ; grep -E "(EE)|(WW)|failed|Time" $Xlog ; done'

==== /var/log/Xorg.0.log
[     5.218] Current Operating System: Linux hp-pavilion 5.11.16-zen1-1-zen #1 ZEN SMP PREEMPT Wed, 21 Apr 2021 17:22:09 +0000 x86_64
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     5.218] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Apr 24 05:56:21 2021
[     5.221] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc".
[     5.221] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[     5.221] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF".
[     5.221] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     5.221] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     5.221] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     5.571] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     5.575] (WW) Warning, couldn't open module nv
[     5.575] (EE) Failed to load module "nv" (module does not exist, 0)
[     5.576] (WW) Warning, couldn't open module fbdev
[     5.576] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.576] (WW) Warning, couldn't open module vesa
[     5.576] (EE) Failed to load module "vesa" (module does not exist, 0)
[     5.577] (WW) Falling back to old probe method for modesetting
[     6.449] (WW) NVIDIA(G0): Unable to get display device for DPI computation.
[     6.454] (II) NVIDIA(G0): ACPI: failed to connect to the ACPI event daemon; the daemon
[     6.478] (II) Initializing extension MIT-SCREEN-SAVER
[   935.476] (EE) event21 - ETPS/2 Elantech Touchpad: kernel bug: Touch jump detected and discarded.

I use optimus and have the same nvidia card as yours. Maybe it is because of the drivers? I use nvidia-all drivers from Tk-Glitch which you can find here: GitHub - Frogging-Family/nvidia-all: Nvidia driver 460 to 396 series AIO installer
I think this is because you don't have a dkms package. My mhwd -li:

NAME               VERSION          FREEDRIVER           TYPE
video-nvidia-dkms            2020.12.19               false            PCI
video-linux            2021.02.19                true            PCI

it didn't help, everything remained the same.

I think it's the bootloader - if I boot linux using efi directly, without the bootloader partition, the error doesn't occur. Did I mark up the boot partition correctly when installing - 300mb, fat32, /boot/efi, one "boot" label?

Please, post:

cat "/proc/cmdline"
grep -i "cmdline" /etc/default/grub
efibootmgr -v
cat "/etc/fstab"

Also I noticed that if replace kernel parametr splash with dis_ucode_ldr, the system will boot, but without the splash screen.

Garuda is installed according to this guide

cat /proc/cmdline

BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e70e0471-a96d-4f7b-8d91-55805210645d rw rootflags=subvol=@ quiet splash rd.udev.lo
g_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3

grep -i cmdline /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3"

efibootmgr -v

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 2001,0004,3004,0003,2002,2004
Boot0001* Fedora        HD(1,GPT,2b348ce4-516a-4abd-8fb4-ff66cd1515b4,0x800,0x96000)/File(\EFI\fedora\shimx64.efi)
Boot0002* USB Hard Drive (UEFI) - General UDisk (General UDisk) PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,MBR,0x20d97ee4,0x800,0x4000000)RC
Boot0003* Windows Boot Manager  HD(4,GPT,6eea16a0-7fef-4e34-b897-1869d786012e,0x3b9af000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...I................
Boot0004* Garuda        HD(4,GPT,6eea16a0-7fef-4e34-b897-1869d786012e,0x3b9af000,0x32000)/File(\EFI\Garuda\grubx64.efi)
Boot2001* EFI USB Device        RC
Boot3004* Internal Hard Disk or Solid State Disk        RC

cat /etc/fstab

UUID=e70e0471-a96d-4f7b-8d91-55805210645d /              btrfs   subvol=/@,defaults,noatime,space_cache,autodefrag,co
mpress=zstd 0 1
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /home          btrfs   subvol=/@home,defaults,noatime,space_cache,autodefra
g,compress=zstd 0 2
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /root          btrfs   subvol=/@root,defaults,noatime,space_cache,autodefra
g,compress=zstd 0 2
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /srv           btrfs   subvol=/@srv,defaults,noatime,space_cache,autodefrag
,compress=zstd 0 2
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /var/cache     btrfs   subvol=/@cache,defaults,noatime,space_cache,autodefr
ag,compress=zstd 0 2
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /var/log       btrfs   subvol=/@log,defaults,noatime,space_cache,autodefrag
,compress=zstd 0 2
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,space_cache,autodefrag
,compress=zstd 0 2
UUID=AA07-7C98                            /boot/efi      vfat    umask=0077 0 2

Your logs say you have booted with splash. How did this happen?

Also there seems no difference between kernel params for main and fallback images. The other known difference is more drivers loaded in fallback.
Have you added any other hardware to your system lately?

Re-create kernel images and try again.

sudo mkinitcpio -P
sudo update-grub

I use the stock system, just reinstalled it today. Splash was there after installation. These commands didn't help

If select "Garuda Linux (on /dev/nvme0n1p1)" (root here) when booting, the system sometimes boots with a splash

Sometimes succeeds, so sometimes the issue is solved. :+1:
Mark the issue solved after a successful boot. :stuck_out_tongue_winking_eye:


I tsted it more carefully - if I turn off the laptop abruptly from the power supply, then the next time I boot up, everything loads along with the splash. If I normally turn off the computer and turn it on, an error occurs

Do you mean crashing the system manually?

Collect errors

journalctl -p3 --no-hostname --no-pager

Also try studying more from journal logs at the time of shutdown and boot, to find what stops booting, or corrupts the system on shutdown.


if I power off the system in GRUB, during boot, when an error is displayed, and when the system is loaded, I can boot. So, after a normal shutdown until I do the above, I can't boot

unsuccessful boots are not displayed in the log. I tried three times - two successful and one not. There are only two in the log

I asked you to check for errors, as if something breaks boot with a normal poweroff, it maybe caught in the shutdown process. Inspect the shutdown processes of existing (logged) boots in journal.

Else it could be a HW/firmware/BIOS issue.

1 Like

Edit your fstab and replace the fsck (last) number to 0 for all btrfs mounted partitions.
Save and reboot normally.

Refs: fstab, fsck.btrfs

1 Like

I changed /etc/fstab, but it didn't help.

UUID=e70e0471-a96d-4f7b-8d91-55805210645d /              btrfs   subvol=/@,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /home          btrfs   subvol=/@home,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /root          btrfs   subvol=/@root,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /srv           btrfs   subvol=/@srv,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /var/cache     btrfs   subvol=/@cache,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /var/log       btrfs   subvol=/@log,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=e70e0471-a96d-4f7b-8d91-55805210645d /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,space_cache,autodefrag,compress=zstd 0 0
UUID=AA07-7C98                            /boot/efi      vfat    umask=0077 0 2

Can you please tell how to check the system status when shutting down. By the way, if I remove splash, everything works. Maybe it gives something

Make sure you have updated your system. SDDM and plymouth were giving problems lately, but they are fixed with new updated packages.


I updated it