Kernel Panic - Not Syncing: Fatal Exception In Interrupt when trying to install/boot from USB?

Image of Error

I will attempt to explain what happened for context. I'm still fairly new to Linux in general so I apologize in advance for stupidity on my part.

System Specs:

  • CPU: Intel i9-9900K
  • Mobo: Z390 Gigabyte Aorus Master (BIOS version F11)
  • RAM: GSkill Trident 32 GB DDR4 (4x8) 3000mhz (XMP Enabled)
  • GPU: EVGA NVIDIA GTX 1080TI FTW3 HYBRID GAMING
  • Storage: Samsung 970 EVO NVME M.2 SSD (2880) 500GB (Intended Destination for Garuda - Clean drive, nothing on it.)

I'm attempting to do a bare metal installation of Garuda KDE Dragonized (Gaming Edition) in dual boot on my main rig that runs Windows 10.

I initially ran the iso from a multi-boot USB flash drive with Ventoy and a few different distros loaded on it with no issues. Garuda booted off the USB, I went through the installation, erased the destination SSD and put Garuda on it. When I got the message that Garuda was done installing, I removed the USB drive and checked the box to restart and waited. The latte dock disappeared, I waited about 30 minutes and the system didn't restart so I powered down the PC with the power button and restarted.

I selected Garuda from the grub menu and booted it up. I put my credentials into the login splash screen and sat waiting for the OS to load (got stuck on the Eagle head logo) it sat there frozen for about 20 minutes so I powered down my PC again, booted into Windows from the bootloader and wiped the SSD in diskpart so I could reinstall since I figured I jumped the gun on disconnecting the USB drive after I got the message that Garuda installed successfully.

I tried install off the USB again and that was the first time I got the error in the picture. It goes through the loading script, gets about halfway and errors out.

Since then, I have tried loading in UEFI and without from the USB, running with the opensource drivers and the Nvidia drivers, I flashed my BIOS on my motherboard from F10 to F11 (the newest version), disabled XMP, reflashed Garuda on a new USB flash drive with Rufus and with Balena Etcher, redownloaded the ISO off the main site and reflashed a different USB flash drive with Rufus and Etcher. Still getting this error. Did I bork my hardware? Not sure what's going on here or what to try next. Any advice would be appreciated.

I really wanted to install Linux on my main computer so I can learn it and I had my heart set on this distro. Thanks for reading.

Search in forum for "Black screen" , please.

Read

please
and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.

and
:slight_smile:

3 Likes

This is likely due to a corrupt image or incomplete download. Verify the checksum and try again. Also make sure you try a different USB flash drive.

3 Likes

Thank you, I went ahead and downloaded the .iso from the source and verified the SHA 256 Checksum. After, I loaded the iso onto another brand new flash drive with Balena Etcher and I'm still running into the same Kernel Panic error. I've spent the last few days googling and checking the wikis for a solution on how to capture the necessary logs. Since the installation is going immediately into a kernel panic from the grub, I haven't been able to find any documentation on how to capture the logs to post here.

Could you try again using Ventoy?

2 Likes

Thunar shows much too early that the copy process is finished.
The safe remove, also in thunar, then takes forever.

Meanwhile, I copy with rsync to the Ventoy USB stick.

2 Likes

Ha, dolphin does this too :smiley:

1 Like

Everyone has their preferences. I use Suse Imagewriter.

1 Like

I prefer nothing, I have to take what works. :wink:

3 Likes

Ad hoc - for this purpose!

The Suse Imagewriter has never failed.

3 Likes

If you haven't got the message most previous posts describe, this is the fault.
Don't remove the USB drive before restart.

Try again until you succeed.:wink:

I just flashed the image with Ventoy onto a new flash drive with nothing else on it and tried to run it. Basically the same thing is happening. It loads the grub menu, I can select to run with Nvidia drivers or opensource drivers. It gets to the part of the initialization for live media, then goes into a kernel panic. Just for my own sanity, I ran a full pass of memtest86+ with no errors too.

Secure and fast boot is off in BIOS?

I've probably tried installing about 30 times now and get a KP every time.

Secure and fast boot is off in the BIOS, I have also disabled the XMP profile for the RAM.

Try this

add this to grub command line

systemd.mask=mhwd-live.service
2 Likes

I added the command to the grub menu like you suggested. Confirmed it does try to bypass the live media setup in the initialization, but goes into a KP after. I also tried disconnecting my Logitech G815 keyboard and only using a non-rgb, e-waste keyboard instead like what was tried in the thread you posted too to see if that made a difference — sadly same deal. I was hopeful for that because that live service / live media module was as far as the installation would go before going into a KP.

It's going to be worth trying some other installer images, e.g. an older Garuda image, the Garuda barebones image, the EndeavourOS image, the basic Arch installer image (maybe even Ubuntu etc.), and see if there is any commonality.

The fact that the error didn't happen to begin with - and then started happening - suggests something else changed, though.

5 Likes

Thank you for the suggestions, I will give that a try.

1 Like

i'm to lazzy to read all the posts
but did you try install it with non-specific driver
it can help to start the system at all and then you can try for your hardware #good_luck@all