Intel Iwlwifi Wifi Issues on a new installation

Hello.
I am using Garuda Linux on another laptop for a while now and just bought this new one, and immediately installed garuda linux with dual boot windows 11.
There have been some stutters but all around its same as last installation, except for the wifi.

Wifi seems to randomly disconnect by itself. (I confirmed that it is not the modem's fault because my old laptop is sitting right beside this one and it is working perfectly.) Also the download speeds in this laptop are not that great. i have run Speed tests on both laptops from same spot but the other one always gets 45 mbps while this one gets 20 mbps. Download speeds are abysmal. They barely went above 200kbps in the last file i downloaded, while the same file from the old laptop gave about 1mbps- 2mbps average.

the only difference i could find between the two laptops regarding the wifi was the modem model, the old laptop has intel AX200 and newer one has Intel AX 201. i think the issue might be solved by reinstalling the driver because the windows 11 gives pretty good speeds from the same spot.

i found my relevant drivers from intel's website https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi/iwlwifi-qu-48.13675109.0.tgz.
i dont know and could not find a way to install the driver in linux.

╭─[email protected] in ~  
╰─λ inxi -Faz  
System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=873c951f-daf4-4fad-aecc-0961323840e3  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Micro-Star product: GF63 Thin 10SC v: REV:1.0 serial: <filter> Chassis:  
type: 10 serial: <filter>  
Mobo: Micro-Star model: MS-16R5 v: REV:1.0 serial: <filter> UEFI: American Megatrends  
v: E16R5IMS.103 date: 05/14/2021  
Battery:   ID-1: BAT1 charge: 28.1 Wh (56.5%) condition: 49.7/51.3 Wh (96.9%) volts: 11.7 min: 11.4  
model: MSI BIF0_9 type: Li-ion serial: N/A status: Unknown  
CPU:       Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake family: 6  
model-id: A5 (165) stepping: 2 microcode: EA cache: L2: 12 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399  
Speed: 4801 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 4801 2: 4801 3: 4800 4: 4801  
5: 4801 6: 4800 7: 4800 8: 4798 9: 4801 10: 4852 11: 4798 12: 4551  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Micro-Star MSI driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Micro-Star MSI driver: nvidia
v: 470.74 alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:1f9d class-ID: 0302
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting
unloaded: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: 5000 bus-ID: 00:14.3
chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI
driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 5 state: up address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 303.64 GiB (26.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3256B-AI1 size: 238.47 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: EDFK0S03 temp: 50.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 0001 scheme: GPT
Partition: ID-1: / raw-size: 100.08 GiB size: 100.08 GiB (100.00%) used: 19.75 GiB (19.7%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%) used: 27.8 MiB (9.4%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 100.08 GiB size: 100.08 GiB (100.00%) used: 19.75 GiB (19.7%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 100.08 GiB size: 100.08 GiB (100.00%) used: 19.75 GiB (19.7%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 100.08 GiB size: 100.08 GiB (100.00%) used: 19.75 GiB (19.7%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.59 GiB used: 815 MiB (10.5%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 405 Uptime: 12h 39m wakeups: 3 Memory: 7.59 GiB used: 6.25 GiB (82.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1542 lib: 486
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

thanks for reading and if you have any suggestions, please do tell.

If it's a brand new laptop you may need to either wait a little bit for Linux to catch up to it (usually only days or a couple weeks), or take a look here:
https://bbs.archlinux.org/viewtopic.php?id=268094

And learn to SEARCH.

Jiminy Crickets--it's friggin disgusting around this joint!

2 Likes

I wonder why the request to include the inxi -Faz included in the topic template is almost always disregarded, especially in cases like this, when it would be foundamental...

2 Likes

My issue is different than the one in the post, my wifi works, his doesnt. mine just doesnt work as good as it does on windows or my older laptop, i did come around this post when i was searching but the problems were different.

i did not think it would be important.(i thought i'll just reinstall my driver), my bad, i'll update it.

1 Like

Thanks for the update.
I wish I could find some useful hint e.g. searching for the laptop model e.g. on the Arch Wiki, but found nothing.
Let's see if someone has good hints before updating the driver.
I'd just suggest you check the Wifi save power option in the Garuda Network Assistant is unflagged...

2 Likes

First of all, disable mac address randomization, if not done already.

Second, try different kernels. Especially Linux-LTS .

3 Likes

I'll try that and see if wifi still misbehaves.

i checked and apparently it was turned on, so i turned it off, hoping that it solves the issue.

If in the older laptop it was off, that might explain a difference...

2 Likes

In addition you should disable IPv6.

You should also test the linux, linux-mainline and linux-next-git kernels.

The driver is included in the kernel and is not something that can be easily changed. What you can do is change the iwlwifi firmware to the git version which will have more recent advancements. Google also releases developmental versions of firmware for Intel wifi hardware for their Android operating system. If you search your Intel model online you may find an updated version for your adapter model's firmware.

There are also many iwlwifi driver options that can be tested to modify and hopefully improve your adapter's performance.

See:

Be sure to read all my posts on this thread:

See this thread:

Also:

As well as:

There is no shortage of information regarding how to modify an Intel wifi adapter's performance on the net. Perhaps you need to improve your search skills.

Perhaps this may help in this regard:

4 Likes

Sure, will do that, although wifi powersave and mac randomization seems to work, just the issue when wifi doesn't connect after sleep persists. for now restarting wifi module from garuda network assistant works.
Thanks for the troubleshooting steps.

2 Likes

For the issue related to connectivity after sleep you could consider this one.
Be careful, it is written for a different card and driver but the concept should remain.

4 Likes

Worked like a charm. Thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.