Intel AX210 - WiFi Not working after installation

No WiFi after installation.
Can anyone help, please?

Network:   Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: 3000 
bus-ID: 04:00.0 chip-ID: 8086:15f3 class-ID: 0200 
IF: enp4s0 state: down mac: <filter> 
Device-2: Intel driver: iwlwifi v: kernel port: 3000 bus-ID: 05:00.0 chip-ID: 8086:2725 
class-ID: 0280 
Device-3: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: 3000 
bus-ID: 07:00.0 chip-ID: 8086:15f3 class-ID: 0200 
IF: enp7s0 state: down mac: <filter> 
Device-4: KYE Systems (Mouse Systems) GF3000F Ethernet Adapter type: USB 
driver: hid-generic,usbhid bus-ID: 1-9.4:5 chip-ID: 0458:6001 class-ID: 0301 
IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A mac: <filter> 

Please always provide those info as text, not images.
Give a look at this guide to do it in a nice way:

But first of all, use inxi -Fxxxza (with capital F) otherwise the network part, which is the most important part here, is not shown :slight_smile:

3 Likes

Try linux-mainline kernel.

5 Likes

Was there wifi during installation?

4 Likes

Also, please do not edit out pertinent information from your inxi -Fxxxza output as this removes much relevant information about your system which helps to resolve wifi issues.

The information such as which desktop, kernel, and mobo bios version you are using is very important in many cases.

We don't even know if you are using Garuda as you have edited this information out. As such I will not assist users who edit outputs as it leaves me to wonder what they are actually hiding, or if they are even a Garuda user.

Please post full outputs if you desire assistance.

Perhaps also you should learn to search for bug reports pertaining to your hardware prior to opening a help request.

There is a current outstanding issue reported with the AX210 adapter on the Arch bug tracker. The bug report contains several known workarounds.

4 Likes

Maybe you could check this workaround?

Anyway, please, read the whole thread and search in general.
This is something I just recalled reading AX210, which was not evident to me at first inxi sight.

If petsam's solution doesn't work you can try to use fallback-initramfs. That worked for me on an older laptop.

2 Likes

There are more than a few workarounds to this, but the actual solution would be to test the new developmental kernels and firmware for a real fix.

2 Likes

No, there was not

OK, so as others have said, if you have a wifi chip that requires the AX210 firmware then you will need to wait for linux-firmware=20210426.fa0efef-1 to reach the stable repos.

Essentially, check back later when support for your hardware has been added.

1 Like

Sorry, I'm newbie to linux. What does it mean " Try linux-mainline kernel."
Could you please tell me what exactly I need to do?

You have newer hardware. Newer hardware has to be added to the kernel and/or firmware. Try again when the newer packages are available (kernel 5.12 and linux firmware as above).

2 Likes

Just to start with a very simple workaround, did you try to remove/rename /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file ?
For sure the fix will be in the kernel or firmware, but this one is easy and quick to try...

1 Like

It means:
Install (using Garuda Settings Manager => Kernels) this kernel and reboot.
At grub menu, select the newly installed kernel in the Advanced options.

1 Like

Thank you!

There is no such option in Settings...

Wow! It worked!
But why??)

1 Like

Please consider that it is only a workaround, found here as part of a previous post that I linked yesterday:
https://bugzilla.kernel.org/show_bug.cgi?id=212371#c13
As stated in that post:

You should know that this file will be recreated with the next linux-firmware package upgrade.
It is possible that an upgrade may fix the issue, or not.
You can temporary disable re-creation of the file with a NoExtract directive in pacman.conf, or better, with a NoUpgrade directive (this will install the file as .pacnew file, so you may test from time to time if the issue is fixed).

3 Likes

Did you push refresh button here?

Thank you very much! I think I haven't noticed it yesterday because I don't understand a single word from here :sweat_smile:

2 Likes