Installation Problem on Dell Inspiron15 7000

Hi All,

I downloaded Garuda KDE both normal Dragonized and the BlackArch versions, but failed to install both of them in my laptop. I have attached screenshot.


Steps Followed:

  1. Download iso using torrent download
  2. Write to USB Flash (32GB) drive using Rufus
  3. Booted through USB mode
  4. Tried both but same results
    i. Select Boot using open source drivers
    ii. Select Boot allowing proprietary drivers (NVIDIA)

Problem:
After booting just few white lines kept flashing on top of the screen leaving rest of the screen black, nothing visible.

System Specs:

  1. Dell Inspiron15 7000
  2. Intel i7-6700HQ 2.60GHz processor
  3. 16GB DDR4 RAM
  4. 500 GB SSD at M.2 slot
  5. 1 TB HDD at SATA slot
  6. NVIDIA GeForce GTX 960M 4 GB Graphics
  7. Intel HD 530 Graphics

My system works without any issues in Windows.

Any help? Thank you in advance

Regards,
Abhishek Mitra

Please no picture from "Black Screen".

Use dd or balena etcher or Ventoy.

Read

please
and post

inxi -Fxxxza

as text!

and
:slight_smile:

1 Like

Ahh, then it is easy to solve your problem :slight_smile:


OT
My car runs well on petrol but fails when I fill up with diesel.

3 Likes

Specifically against the Garuda wiki which states... -

"Dont use Rufus to flash the iso to USB"

2 Likes

Tried with etcher, unfortunately same problem. Tried with Ventoy as well, same problem.

Tried Etecher and Ventoy, same problem.

By saying this "My system works without any issues in Windows." I wanted to mean that I do not have any hardware issues :slight_smile:

Etcher and ventoy did not work either :frowning:

1 Like

Start reading too.
In BIOS remove secure and fastboot. Maybe root user is needed for that.

Hello. Welcome to the community :grin:

Here how I do with when I'm flashing my flash drive to become Live USB to install Garuda.

  1. Download the .iso
  2. Download the sha256.checksum
  3. Make new folder and put it both inside it
  4. Run Balena Etcher to flash my flash drive
  5. Follow the directions from Balena Etcher
  6. After done flashing, I restart my laptop and booting from my Live USB.
  7. Choose the open source/free driver

I hope it help. Good luck :smiley:

Hi,

I tried the exact same steps but it did not solve the problem.

Thanks,
Abhishek

I read as well :slight_smile: but I don't have inxi since I am on windows :slight_smile: Let me know what specific details are you looking for, I will try my best to post them here.

However your suggestion did not work, I checked the BIOS secure and fastboot options are already disabled.

Thanks,
Abhishek

Ok, one suggestion I have, is using RPi-Imager. It has worked for me in the past, when Balena didn't and is available for windows, from

Steps I took

  1. Select Choose OS
  2. Scroll down to Erase wipe your USB drive.
  3. Choose your ISO from Choose OS selecting Use Custom choosing your Garuda ISO and write it - then try installing it.

It is the only thing left for me, but the far better and far more knowledgeable brains here, may have other ideas for you.

Maybe try suse studio image writher.

1 Like

Drag 'n' drop und gut ist.

1 Like

Hi,

I tried this, but it did not solve the problem.

Thanks,
Abhishek

Could you please share some more details?

Have you tried a different USB pendrive? This has resolved some problems encountered by others.

Tied this, but it did not solve the problem

Not yet, but I am able to load Manjaro with the same pen drive without any issues. Does Garuda allow network boot?

I have a Dell Inspiron15 7548. . . I'm going to try and install right now and see if I can recreate the problem.

Dragonized first.

Edit - I don't have nvidia graphics though. Either way, I'll give it a go.

FWIW, I generally use popsicle to flash usb drives. Either way, I'm about to give it a go.

1 Like