I can't edit the grub entry

I can't edit the entries on Garuda boot edit(IDK what's the name)
Is it normal? I've installed by EFI.

The process to change the entries is:

  1. Change the entry, for example. linux-zen for xanmod.
  2. click on save changes.

But when I reboot my PC, I don't see any changes, the grub still join on linux-zen

You change the kernel selection at the grub advanced menu entry during boot up.

Grub has a bug with the btrfs filesystem that will not currently allow changing the default kernel in its config file in /etc/default/grub.


If you'd like to edit the grub, I would suggest reading over this. Make a complete backup because if you're asking these questions, I'm assuming you're new and you will likely ruin something in the process.

Beyond that, as @tbg pointed out, there's also a bug, currently. So, I re-emphasis - backup backup backup.

And learn: GRUB - ArchWiki


I also would like my system to default to boot into linux-lts rather than linux-zen. Given this bug, is the only solution installing a Garuda Linux flavor that ships with a stable kernel?
What happens if I remove the default (zen) kernel?



# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

Thank you @SGS, however I uncommented that line and changed the GRUB_DEFAULT as documented, and yet after manually choosing the lts kernel on a first reboot, and not touching anything on the second, I am still booting into zen.

Is there anything else I should try?

Maybe :man_shrugging:

sudo update-grub

I use only one kernel :wink:

1 Like

Currently to the best of my knowledge the most recent kernel version will be automatically booted by grub with multiple kernels installed. This means the LTS kernel will not be automatically selected by grub at boot. If you wish to automatically boot the LTS kernel then it must be the only kernel installed on the system.

When using btrfs with Grub to the best of my knowledge the only current workaround is to install Garuda with a separate /boot partition (usually formatted as ext2). This will allow grub to work properly with btrfs until grub has been fixed to work properly.


Comment out again and manually set default


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.