Garuda boot options hangs (NOT AFTER GRUB CUSTOMIZER THIS IS A BUG)

If you have a snapshot of before you installed grub-customizer roll back to before you installed it.

Do not perform any more installs or updates until you do this. Otherwise you may lose your opportunity to reverse the changes grub-customizer made as timeshift only store a limited number of snapshots.

4 Likes

Just in case:

1 Like

Ok. I reverted to this morning.
/etc/default/grub looks clean as before my DEFAULT_GRUB="saved" changes

First time using this, how do I restore the snapshot? So i stay here

Is grub-customizer no longer on your system?

2 Likes

Yes it's not there anymore. Also restoring was very intuitive, just licked on the snapshot and clicked restore

Did you restore the snapshot you booted into from within the timeshift GUI afterwards?

I booted it and, reverted to when I just booted this morning. At session start I was prompted to restore, I then deleted the snapshot after the current one and clicked my current snapshot to click restore.

That is good. I was just checking as older versions of Garuda did not ensure the snapshot was restored from within the GUI.

Are you sure the snapshot you are using was created before grub-customizer was installed. Simply uninstalling grub-customizer does not reverse the changes it makes. You must be sure to roll back to a snapshot that was made before grub-customizer was installed.

Y IK ofc, it's the configuration mess that it leave. It was a mistake. I reverted to before I even installed grub customizer

Just wanted to be sure is all. Luckily you dodged a bullet there.

BTRFS to the rescue of my misteps

I tried sudo garuda-boot-options and it didn't work either.

You (grub-customizer) destroyed some files, read the error messages you posted.
So, you have chosen the painful path to learn.
Make yourself knowledgeable before you install and use anything.
The system is corrupt, if you don't have a working snapshot you have to reinstall.
The tool garuda-boot-options, is called boot-option and not grub-customizer-repairer.

Ok. But I reverted, and read the link on the comment I made that says "explanation" Is some bug with BTRFS

It's a grub+btrfs limitation.
Set default boot entry manually.

2 Likes

That was reverted, ty

On a fresh install it still does the same. And for changing the Kernel, since I am switching it, I just uninstalled the one I don't want to use.

ATTENTION:

issuing the command: sudo grub-mkconfig -o /boot/grub/grub.cfg results in the sparse error to appear, don't do it!

Looks like a lot of work here: Would love to know SH, could be easy... :thinking:

/etc/grub.d

There are ways to work around this limitation:

1 Like

Hey. I figure I just uninstall the kernels I won't use so it was a fool's errand for me. Figured before bed LOL, I'm looking at posts about choosing a kernel. I want to do Midi capture with LMMS and who knows if I do with MuseScore too and in my free time I play 3D games. I see there are option and TKG shold be good for gaming and Midi maybe doesn't need anything special but it's important it capture my key strokes the most precisely. XanMod, TKH Zen with Zen 1 optimizations. I have this from install Linux 5.12.5-zen1-1-zen

Back to topic!

This seemed to work though

GRUB_SAVEDEFAULT="true"
GRUB_DEFAULT=saved

And now I think I should go the route: update-grub Any harm on trying that?

UPDATE:

I did and an error appeared: "sparse file not allowed", thi sis becuase of incompatibilities between GRUB and BTRFS so it can't save the last booted entry, maybe because is set in /boot and that's on BTRFS.

I wonder if the installer can simply make a /boot partition and set it boot and esp flag, I think yes it can. That way we avoid any problems.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.