How to solve double windows button of any browser in Dragonized edition?

Any browser in Dragonized edition has double windows applet buttons. one is in top panel and another one is with browser. It's a fresh install. Any help would be appreciated.

my garuda-inxi is as follows:


Kernel: 6.2.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9ad00d39-2040-448a-b08a-92e463e2863d rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=0766bbaf-3607-44d6-b094-9d49cd512873 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Nitro AN515-54 v: V1.33
serial: <superuser required>
Mobo: CFL model: Octavia_CFS v: V1.33 serial: <superuser required>
UEFI: Insyde v: 1.33 date: 11/17/2020
ID-1: BAT1 charge: 40.2 Wh (100.0%) condition: 40.2/57.5 Wh (69.9%)
volts: 16.6 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 2025 high: 2400 min/max: 800/4100 scaling:
driver: intel_pstate governor: powersave cores: 1: 2400 2: 900 3: 2400
4: 2400 5: 900 6: 2400 7: 2400 8: 2400 bogomips: 38400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630]
vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-9.5
process: Intel 14nm built: 2016-20 ports: active: eDP-1 empty: none
bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: Acer Incorporated ALI driver: nouveau v: kernel non-free: 530.xx+
status: current (as of 2023-03) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1f91
class-ID: 0300 temp: 36.0 C
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: iris,nouveau gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x065a built: 2019 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.0.1 renderer: Mesa Intel UHD Graphics 630 (CFL
GT2) direct-render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
API: ALSA v: k6.2.9-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.67 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:5 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Local Storage: total: 1.14 TiB used: 10.72 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: HFM256GDJTNG-8310A size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: 80002C00 temp: 35.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ACM1 scheme: GPT
ID-1: / raw-size: 212.66 GiB size: 212.66 GiB (100.00%)
used: 10.72 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 212.66 GiB size: 212.66 GiB (100.00%)
used: 10.72 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 212.66 GiB size: 212.66 GiB (100.00%)
used: 10.72 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 212.66 GiB size: 212.66 GiB (100.00%)
used: 10.72 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 25.51 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 23.19 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 41.0 C pch: 55.0 C mobo: N/A gpu: nouveau
temp: 36.0 C
Fan Speeds (RPM): N/A
Processes: 286 Uptime: 1m wakeups: 1 Memory: 23.19 GiB used: 3 GiB (12.9%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 Packages: pm: pacman pkgs: 1316 libs: 334
tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-02
Last full system update: 2023-04-02
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:            systemd-vconsole-setup.service

here is the screenshot as new user cannot upload images

Welcome :slight_smile:

Perfect explained, no picture needed.

Maybe this help.

BTW, you did not follow the template, edit your post with the garuda-inxi output as text, please and explain what your previous attempts at a solution were.


Garuda-inxi formatted.
Please give a look how, for the future.
Maybe try this kWin setting in $HOME/.config/kwinrc

1 Like

Already it is in the same state as you explained .

Very intriguing. Which ISO version you used? 230319? 230311? 230305? Other?
After the install from the ISO, did you perform a complete update of the system as per the prompt was asking for on your first reboot/login?

1 Like
  • This is not reproducible with garuda-dr460nized-linux-zen-230305.iso, both before and after a full update of the system.
  • This is also not reproducible with garuda-dr460nized-linux-zen-230319.iso, both before and after a full update of the system.


Also, as you can see, your Firedragon color scheme doesn't match the default Garuda, which means your install is not a "fresh" install.

Which brings the question: What else did you change? And what else did you install during the installation of Garuda (from the prompts of Welcome App or manually from Terminal)?
Maybe something you did impacted the double Window Buttons you are describing.


It is the latest iso which is 19.03.2023. All I did was update via Garuda update after fresh install and reboot. As for firedragon Windows button is concerned, it's windows button is not matched with the the theme in any DE, whether it's kde or GNOME ... I use Firefox which has same theme as of the system.. recently in both isos i have these issues of double windows applet.

Now I'm using Garuda kde lite version which solved the issues of double windows applet because it is vanilla kde with Garuda settings and tweaks.

Something is getting wrong with dragonized version of kde tweaks with the panel which doubles the applet.. interestingly these issues are only in browsers, not in any other window, whether it is konsole or settings app or any other app.. only browsers have double window applets in dragonized edition.. also I saw there is no kwin settings of "hide window buttons " is present. it means all tweaks are made via system settings. These might be conflicting.

here is the screenshot of firefox and firedragon browser with sweet theme enabled. Left one is firefox and the right one is firedragon

Ok I see now, you were using Firefox on your first screenshot, not Firedragon, that explains.

Firedragon is branded for Garuda and since it's part of the theme to hide Window Buttons and only show them when maximized that explains why you don't see window buttons on the top left of a non-maximized Firedragon window:

And Firefox looks like this:

I don't know how you end up with this on Firedragon?

This is not what happens when booting from ISO. :thinking:

1 Like

For Firefox there is a workaround:

  • Starting result:

  • Right-click in the black area and select Customize Toolbar...

  • Tick Title Bar at the very bottom and very left

  • Final result:

Then when you maximize, you only get 1 set of Window Buttons.


Firedragon is branded for Garuda and since it’s part of the theme to hide Window Buttons and only show them when maximized that explains why you don’t see window buttons on the top left of a non-maximized Firedragon window:

Well I really do not know what is really happening here. I am right now using kde lite which solves the issue by default. I use ventoy for all installations. also these double applets are showing after latte dock was replaced by stock panel. I do not have latte dock installed. As I stated this was a fresh install of dragonized edition which comes with stock layout workaround just like latte.

You can see the first screenshot which I posted at the beginning was from dragonized edition which had two windows applet by default in firefox. The second screenshot which I posted afterwards is from kde lite which has only one window applet by default.

The peace-was-never-an-option-goose is not helping but you get the idea

1 Like

I also don't understand what's going on. Still trying to find the code/tweak that removes the Window Buttons by default on Firedragon, that may help figure something out. Maybe it is intermittent.

However there are 2 workarounds at the moment it seems: Titlebar option and KDE Lite.

Yeah, I'm using kde lite right now it works fine except firedragon theming of window applet.

@sanky sorry for the delay, it took some digging.

It turns out there most probably is a bug upstream of Firedragon. The funny part is you are not experiencing the bug, I was! (and some others are too)

For more detailed info, plz have a read here Window Buttons inside TABBAR disappear on launch or don't follow GTK Theme (in Plasma DE) (#106) · Issues · LibreWolf / Browser / Arch · GitLab

This possible bug does not solve your problem per se.
Let’s go back to it:

Strictly focusing on this, I have already responded with a workaround and you also know KDE Lite is free from this issue.
Let me explain a little bit more so you can better decide what to do:

This “issue” you are facing is by design.
What makes the Window Buttons display in a maximized window in Dr460nized is the WindowButtons applet. This applet recognizes a maximized window and automatically displays the buttons in the Top Panel, as if the TITLE BAR was integrated with the Top Panel.
To work at its best, this feature must be used in conjunction with


in order to prevent having double Window Buttons.
If you have a Title Bar on maximized windows, you will have double window buttons.
If you don’t have a Title Bar, only the applet will display the buttons. This is what the above code does.

However, by default Firedragon loads without a Title Bar and uses Firefox’s method of displaying the Window Buttons inside the TAB BAR. The Tab Bar is not recognized by WindowButtons applet so when the window is maximized it displays the buttons as it should and cannot remove them from the Tab Bar. Since there is also a set of buttons inside the Tab Bar, you get double sets.

In your situation, if you want to keep Dr460nized, you would have to simply remove Window Buttons applet and apply


in $HOME/.config/kwinrc

If you do so, you will have a title bar on every app when maximized, but only 1 window button set.
The other workaround is to use the Title Bar feature within Firedragon as explained in previous posts, which moves the window buttons from the Tab Bar to the Title Bar.

Why you don’t have the issue in KDE Lite? It’s not using Window Buttons applet! :smiley:

Hope that helps better understand, this situation turned out to be quite a mouthful but thanks for posting the question, it helped trying to fix something else, even though it doesn’t 100% fix your original issue.


@sanky All you need to do is enable the title bar in the toolbar customization tab. The rest is history!

This actually fixed the problem

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.