How to enable os prober in garuda

how to enable os prober so that garuda boot menu show other os

1 Like

Relevant? :eyes:

6 Likes

definitly, thats got to be one of the most stupid antiupdates i have ever seen. why would they do this

I can smell the next wave of topics here, and relevant banner needed... :slight_smile:

7 Likes

This can be handled using garuda-hooks :blush: (will be added as soon)

As long as Pamac is still working :crazy_face:

6 Likes

Ahah, even proactive!
But I go back to saying that those moments of panic I (obviously as "external" non-mod...) miss from time to time. :blush:

5 Likes

Alright, the hook is added so everyone updating GRUB will get the fix automatically now :smiley:
For the lazy ones who got the update: reinstalling GRUB also does the job (after updating garuda-hooks of course) :wink:

8 Likes

What the hell happened? I have same issue as my Windows partition is gone, it doesn't show up in grub-menu, I trued OS-prober already

It's written in the link
manually configure the os-prober by adding GRUB_DISABLE_OS_PROBER=false to /etc/default/grub
And sudo update-grub of course

3 Likes

Could dev of Garuda encourage any one.:grin:

Searching on both reddit and forum just make getting solution late on my pov.

There are less experts / Devs in reddit

Shows all new and old config files of Pacman , libre.

Now only Rested after waiting till lib got version 13😂 for PacMan.

Os prober , dkm issue on building zen, missing xhci pci ,slow boot
Again manual file configs ah🤐

What does Garuda have to do with reddit?
Someone has used official Garuda graphics to make it look like a support site for Garuda Linux.
That's all.

2 Likes

Its 100% unofficial, I'm just there to keep it sane :yum:

1 Like

Thanks for clarification :v:t4:

This is pretty darn helpful. Most other distros were struggling with manual solutions on similar threads. Good to see that Garuda devs are so proactive.

2 Likes

Ok I am not much knowledgeable about how hooks work. So what is need to be done? Do I need any manual intervention? Or should I update the whole system. I ran -Syu doesn't seem to update the grub. So what should be the procedure now?

And I checked /etc/default/grub
GRUB_DISABLE_OS_PROBER=false <- this is the last line. so should it be true?

If you've already updated the system the fix should be already in.
That parameter was something you could do before the fix was done.
Try
sudo update-grub
And reboot
If for any reason it doesn't work, that parameter should be added as false: disable=false means enable os-prober :wink:

2 Likes

Thank you thank you. This has been bugging me all day. After adding that to the end of grub config file and updating via the official Garuda boot options gui (sudo update-grub also works apparently), everything is now back to harmonious Garuda and Win10 dual-boot computing for me :slight_smile:

1 Like

This fix does not work - i would recomand to test the workarounds before you post them here.

Dude, I was a question not showing the way to fix.
The workaround is (at least what worked mighty fine for me) is that,

  1. You edit /etc/default/grub.
  2. Go to the last line "GRUB_DISABLE_OS_PROBER=false", check if it's false or true.
  3. Make sure it's false.
  4. Then open a terminal, type "sudo update-grub" , and hit enter.

PS. It was stupid of me to post the previous question, as the solution was already there. I somehow skipped it! Oops!

3 Likes