High Boot time & display issue

Slow Boot & Suspect of MisconfigurationšŸ˜…
Soec : Intel Pentium Quad Core 2.7 GHz with 500 HDD ,UEFI (FastBoot-On, Secure Boot-Off)
Having Dual-Boot with Windows 10 & Garuda (Dragonised) .Kept select time for choosing os to 1 sec In GRUB. Black screen with text for 10-15sec .

Loading linux-zen
Booting to Garuda

Then splash screen for 15 sec and then again above black screen for 5 sec and plasma loading screen 10sec . After password entry , widgets loading for 15 sec. Never experienced this much even with windows 10. Switched to linux lts & linux Kernal .Same resultšŸ˜ž . Any tips?

I think the first info to be provided here would be:
systemd-analyze
systemd-analyze blame
And also your specs
inxi -Faz
This part please with ~ 3 times before and after, for better readability

1 Like

This is an example of what I get for me (most likely lower spec than yours):

Ī» systemd-analyze
Startup finished in 4.957s (firmware) + 2.286s (loader) + 3.344s (kernel) + 9.231s (userspace) = 19.819s
graphical.target reached after 9.230s in userspace
Ī» systemd-analyze blame
5.118s systemd-swap.service
4.910s linux-modules-cleanup.service
3.564s ananicy.service
2.442s dev-sda5.device
2.320s NetworkManager.service
2.276s polkit.service
2.228s systemd-logind.service
2.111s lvm2-monitor.service
1.577s [email protected]
1.389s ModemManager.service
1.264s systemd-user-sessions.service
1.122s plymouth-quit-wait.service
1.112s plymouth-quit.service
996ms avahi-daemon.service
793ms systemd-random-seed.service
582ms plymouth-read-write.service
559ms systemd-udev-trigger.service
467ms systemd-journal-flush.service
419ms plymouth-deactivate.service
401ms dev-zram0.swap
370ms upower.service
304ms plymouth-start.service
280ms bluetooth.service
278ms systemd-guest-user.service
266ms systemd-vconsole-setup.service
265ms systemd-modules-load.service
238ms systemd-journald.service
3 Likes

How is your firmware so fast? Mine takes 40-50 sec even with an SSD as root partition.

3 Likes

You will not experience those times with Win10 as Win10 does not shutdown it cheats be going into hibernation by default.
that is part of your start problems with Garuda, windows in its unwise wisdom has locked the drive so Garuda has to do a workaround
So how to fix this Read how to shutdown windows correctly, disable fast boot it does nothing for Linux at all its written for windows solo booting ,
Best solution is remove Windows if not you have to comprise

@ExistingDude mine takes 6.5 secs from grub to working desktop but we do not brag about it on a 8 year old i5 desktop.

6 Likes

HDDs are not as fast as SSDs, to me that doesnt really seem special (about 50 secs in total?) :eyes:
Are you comparing this to Windows boot times?

Thats of course also something to consider.

4 Likes

Probably, overall play in my favour the SSD drive, fast boot disabled in Windows and 8MB of RAM (I don't consider it much but I see even less around). On the firmware, I don't know...

1 Like

@nalisan007 have you disabled Fastboot yet? If not, then please do so.

regards

3 Likes

Sorry everyone for late reply . was upgrading and configuring

Booting Garuda
loading Kernal linux-zen
loading initial ramdisk

inxi -Faz` output :

Output

System:
Kernel: 5.12.10-zen1-1-zen x86_64 bits: 64
compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=96ccd9b5-742f-49b3-938a-315cbcdd6b7f
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 resume=UUID=3b0e0e54-fe69-4891-972e-11ccb81112a2 loglevel=3

Console: tty pts/1
DM: SDDM
Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Portable
System: Dell
product: Inspiron 3551
v: A07
serial: <filter>
Chassis:
type: 8
serial: <filter>

Mobo: Dell
model: 0CMF7W
v: A00
serial: <filter>
UEFI: Dell
v: A07
date: 02/08/2018
Battery:
ID-1: BAT0
charge: 36.4 Wh (95.3%)
condition: 38.2/41.4 Wh (92.2%)
volts: 16.6 min: 14.8
model: PANASONIC DELL 78V9D7C
type: Li-ion
serial: <filter>
status: Discharging

CPU:
Info: Quad Core
model: Intel Pentium N3540
bits: 64
type: MCP
arch: Silvermont
family: 6
model-id: 37 (55)
stepping: 8
microcode: 838
cache:
L1: 224 KiB
L2: 1024 KiB

flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 17333

Speed: 543 MHz
min/max: 500/2666 MHz
base/boost: 2160/2400
volts: 1.2 V
ext-clock: 83 MHz
Core speeds (MHz):
1: 613 2: 639 3: 778 4: 1140
Vulnerabilities:
Type: itlb_multihit status: Not affected Type: l1tf status: Not affected Type: mds mitigation: Clear CPU buffers; SMT disabled Type: meltdown mitigation: PTI Type: spec_store_bypass status: Not affected Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling Type: srbds status: Not affected Type: tsx_async_abort status: Not affected`

Graphics:
Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display vendor:``Dell
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0f31 class-ID: 0300 Device-2: Suyin Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-4:3 chip-ID: 064e:9209 class-ID: 0e02 serial: `

Display: server: X.org 1.20.11
compositor: kwin_x11
driver:
loaded: intel
unloaded: modesetting
alternate: fbdev,vesa
tty: 110x28

Message: Advanced graphics data unavailable in console for root.

Audio:
Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
vendor: Dell
driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:0f04 class-ID: 0403
Sound Server-1: ALSA v: k5.12.10-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.30 running: no

Network:
Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Dell Vostro 3470
driver: ath9k v: kernel port: f000 bus-ID: 03:00.0
chip-ID: 168c:0036 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>

Bluetooth:
Device-1: Qualcomm Atheros
type: USB
driver: btusb v: 0.8 bus-ID: 1-2.1:6
chip ID:0cf3:e005 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: down
bt-service: disabled rfk-block:
hardware: no software: yes
address: see --recommends

Drives:
Local Storage: total: 465.76 GiB used: 22.73 GiB (4.9%)
ID-1: /dev/sda
maj-min: 8:0
vendor: Western Digital
model: WD5000LPVX-75V0TT0
family: Blue Mobile
size: 465.76 GiB
block-size:
physical: 4096 B
logical: 512 B
sata: 3.0
speed: 3.0 Gb/s
rotation: 5400
rpm serial: <filter>
rev: 1A01
temp: 40 C
scheme: GPT
SMART: yes
state: enabled
health:
PASSED on: 248d 19h
cycles: 5210
read: 17.34 TiB written: 9.17 TiB
Old-Age: g-sense error rate: 1122

Partition:
ID-1: /
raw-size: 260.43 GiB size: 260.43 GiB (100.00%) used: 22.73 GiB (8.7%)
fs: btrfs block-size: 4096 B
dev: /dev/sda8 maj-min: 8:8

ID-2: /boot/efi
raw-size: 512 MiB size: 511 MiB (99.80%) used: 588 KiB (0.1%)
fs: vfat block-size: 512 B
dev: /dev/sda6 maj-min: 8:6

ID-3: /home
raw-size: 260.43 GiB size: 260.43 GiB (100.00%) used: 22.73 GiB (8.7%)
fs: btrfs block-size: 4096 B
dev: /dev/sda8 maj-min: 8:8

ID-4: /var/log
raw-size: 260.43 GiB size: 260.43 GiB (100.00%) used: 22.73 GiB (8.7%)
fs: btrfs block-size: 4096 B dev: /dev/sda8 maj-min: 8:8

ID-5: /var/tmp
raw-size: 260.43 GiB size: 260.43 GiB (100.00%) used: 22.73 GiB (8.7%)
fs: btrfs block-size: 4096 B dev: /dev/sda8 maj-min: 8:8

Swap: Kernel:
swappiness: 10 (default 60) cache-pressure: 75 (default 100)

ID-1:
swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7 maj-min: 8:7

ID-2:
swap-2 type: zram size: 952.4 MiB used: 7.3MiB (0.8%) priority: 32767 dev: /dev/zram0

ID-3:
swap-3 type: zram size: 952.4 MiB used: 7.2MiB (0.8%) priority: 32767 dev: /dev/zram1

ID-4:
swap-4 type: zram size: 952.4 MiB used: 7.4MiB (0.8%) priority: 32767 dev: /dev/zram2

ID-5:
swap-5 type: zram size: 952.4 MiB used: 8.4MiB
(0.9%) priority: 32767 dev: /dev/zram3

Sensors:
System Temperatures:
cpu: 60.0 C mobo: 50.0 C
Fan Speeds (RPM): cpu: 3896

Info:
Processes: 201 Uptime: 4m wakeups: 1
Memory: 3.72 GiB used: 1.49 GiB (40.0%)
Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1368 lib: 340 Shell: Bash (su) v: 5.1.8 running-in: tty pts/1 inxi: 3.3.04`

Cant anymore make it appealing above output

systemd-analyze output :

systemd-analyze
Startup finished in 3.500s (firmware) + 17.227s (loader) + 7.426s (kernel) + 58.434s (userspace) = 1min 26.588s
graphical.target reached after 58.431s in userspace

systemd-analyze blame output :

Output

31.815s ldconfig.service

13.809s systemd-swap.service

8.472s ananicy.service

8.294s lvm2-monitor.service

8.114s dev-sda8.device

3.376s polkit.service

2.533s avahi-daemon.service

2.514s NetworkManager.service

2.428s systemd-logind.service

2.418s systemd-remount-fs.service

2.347s systemd-journal-flush.service

967ms systemd-udevd.service

889ms [email protected]\x2duuid-2CDA\x2d3F1E.service

790ms [email protected]

784ms [email protected]

740ms [email protected]

730ms systemd-modules-load.service

728ms [email protected]

682ms udisks2.service

669ms systemd-tmpfiles-setup.service

655ms systemd-sysusers.service

650ms systemd-journal-catalog-update.service

650ms ModemManager.service

618ms systemd-udev-trigger.service

553ms systemd-vconsole-setup.service

539ms colord.service

525ms upower.service

@mandog Before Shutdown i have released chached memory in Windows using rammap tool. Also Stopped all unnecessary task and disable startup task and manually stopped all service except windows. I have Properly ShutDown my Windows 10 (Not Hybrid Shutdown) using Pressing Shift+R and clicking shut down . also did using cmd shutdown -s -f -t 0 .

Repeated the whole above process thrice. Now my Garuda shows 0.9/3.7 GB Ram Used

@c00ter Already Disabled Fast Boot in Windows to avoid cache and hybrid shutdown.t

I have enabled FastBoot in UEFI for faster loading BIOS(POST) . It haven't affected performance as far I know

@dr460nf1r3 At first time period of Windows 10 new installation boot time was 12 s. After many config, reset,reinstall ,Later It gone to 80s. So switched to Garuda. At start it didn't booted slow but now :man_shrugging:t4:

So , it is a mystery for me.

Edit : Have edited post after first reply of me
Edit 2: Included specs

So, I'm not a technical expert but the logic tells me we should focus now on the greatest value.
I don't know exactly what's behind the user space, but I guess it would be more than before useful:

2 Likes

Now we have IMO the main "enemy"

I think this could be easily disabled via

sudo systemctl stop ldconfig.service
sudo systemctl disable ldconfig.service

I saw a post in the arch forum https://bbs.archlinux.org/viewtopic.php?id=248619 saying that:
pacman runs ldconfig after updating anyway, so there should be no need for that service as long as you install software using pacman
If this could be confirmed by a dev, you would be on the safe side.

1 Like

Will try & post u update in short :v:t4:

1 Like

They are two different animals.

I'm getting tired of suggesting solutions to people. I'm outta here.

Maybe outta Garuda.

1 Like

Disabled Fast StartUp in Windows. Cleared Cached Ram. Properly ShutDown(Not Hybrid/ Hibernation) so no cache.

Doesn't Garuda Linux support FastBoot in UEFI BIOS?:thinking:

BIOS FastBoot is not Windows OS specific ryt :roll_eyes:

Linux support Hibernation which is the idea of FastBoot in BIOS ( ending user section but preserving Kernal)

Would be Glad for real solutionšŸ˜Œ

Honestly I think you might improve something but I don't think you could go much further with 4GB of RAM and the HDD.
These I think are the real bottleneck.
This is just my gut feeling though...

1 Like

Sharing your gut feelings too. But till new one , want to optimize as much as I can. Can't abandon it. Thinking of using WINE on Garuda instead of dual boot (feeling as worst choice I madešŸ˜‘)

Fast boot in bios is total windows your motherboard does not support LInux it supports Windows only like most do, your HD only supports Windows. So please do not say it does this in widows it should do that in Linux. Hibernation in linux is not the same its actually better than windows. on my desktop its instant you just have to wait for the monitor. no fast boot enabled or needed. You have stop thinking windows boot times with Garuda HDD 7200 rpm and a i5 on desktop cold boot about 28secs. 5400 rpm 58 secs, SSD 6.5 secs. to stop fast boot on windows 10 you 1st go to power settings and disable hibernation and in bios fast boot this also stops windows locking the drives so you can then read write on ntfs partitions using Linux god you can't even do that with a Mac without 3 party software. The safest way to duel boot is on separate drives i've been doing it for 20odd years with no problems that also applies to duel booting Linux .

4 Likes

Thanks for explanation

Will do it

6 posts were split to a new topic: Long booting time