Hi I was trying to install Garuda on my AMD

I loaded the Garuda installation, it got stuck at the Starting Terminate Plymouth Boot Screen.

I followed the guide by pressing the Ctrl + Alt + F2 to login to the Garuda, and ran the "sudo pacman -Syuu". It downloaded everything, but then after that, I ran the "sudo reflect..." code, it then said "error: no mirror found". And now it's stuck there forever.

Do you have any idea how to fix that?

Sorry I am still a new and noob guy in Linux. Thanks a lot in advance...

What did you write exactly after sudo reflector?
Please find below a couple of suggestions, change country, if used or command.

I got the Garuda installed, but now after resetting the pc, it brought me into the grub, then I chose Garuda, what comes after is a black screen again. Will there be a help on that?
Thanks a lot

I hope this could help


I can't even open the console at all at the grub of choosing Garuda. There were only a few options such as:
UEFI settings (which leads to my Bios)
And uefi settings again at the bottom.

Is there any way I can fix it here?

To get to a console you could press button E at the Garuda grub line and add a 3 (with a space before) at the end of the line starting with linux, then ctrl+x to boot

Sorry again for making it complicated. But it's not working at all. Still it's a black screen. I am sorry again

You could try to chroot from a live USB into your installed system.
There is a tool for that in the USB or you can follow the initial part of this tutorial

How long do you wait before you decide that this black screen is a failure?
Some times it takes more than 30-50 seconds to show the log screen.
Is your PC strong enough for Garuda? How strong?

1 Like

My CPU is AMD Ryzen 7 2700, and my GPU us RX 570 with 16GB of RAM. So I am not too sure.
And I am not too sure if taking more than 5 mins of waiting and still a black screen after the grub is a thing for Garuda?
Do you know how I can fix it?

To start fixing, you either need

(read/search what you can do with this, the forum is filled with such info from others in your place)

replace the word quiet with the number 3. This will send you to console/TTY and you can look into the journal log searching for errors ( -p3 parameter, or others).


I have a terrible feeling this is caused by a regression in kernel 5.13 in the amdgpu driver.

If you can get to a terminal, try installing and using linux-lts. If that works, use that for now.


Can you please help me with it? For now what I can do is I can use the grub repair from the live USB onto the fat32 boot folder of my SSD. What else can I do? I already tried to chroot as well. It seems to not working.

I managed to get into Garuda. Should I just add a Timeshift snapshot. And then restart it again? Or what else should I do so I can save it all there?

The linux-lts kernel can be installed from terminal with
sudo pacman -S linux-lts linux-lts-headers
This should create automatically a snapshot before.
How did you get in, by the way?

1 Like

I followed these codes here:

pacman -Sy
pacman -Sy xf86-video-fbdev
systemctl restart sddm

And then it got me in. Now I am stuck at a place where I can't adjust resolution, and when I restart the machine, it does not boot into the right thing and I have to keep running those commands. Do you have any idea how I can fix that permanently?
Thanks a lot!

Try to use amdgpu.dc=0 as kernel boot parameter

1 Like

Thanks for your help. Now it's stuck at the loading screen right after I input the password. Do you know how I can remove splash from the tty, and then set it to load permanently instead of my using the "systemctl restart sddm" all the time? If you know what I mean. I am sorry again!

Sorry, I don't know this procedure at all.
I can't help much there.
If you need to remove the splash, that's a kernel boot parameter as well, to be removed.
All those kernel parameters can be made persistent from the /etc/default/grub file or, if you are in, from a tool in the Garuda assistant.
Additionally, from the arch wiki for pacman
do not run pacman -Sy package_name instead of pacman -Syu package_name, as this could lead to dependency issues

1 Like

I reinstalled Garuda, it went well. Had the kernel parameters as "nomodeset amdgpu.dc=0" then it got stuck at the "Starting Terminate Plymouth Boot Screen".
I used the console up there to boot into the desktop screen.
Created a Timeshift.
Now what should I do next after creating that Timeshift?
And what should I do to make Garuda load automatically instead of my keeping typing in the code? Cause it seems to be something I really don't wanna do all the time.