Help, I can't boot: "452: out of range pointer"

Hello everyone! So, I got the 452 error after updating my system. Since I can't boot, I got the inxi from my last post here:

inxi
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "pt_BR.UTF-8",
        LC_NAME = "pt_BR.UTF-8",
        LC_MONETARY = "pt_BR.UTF-8",
        LC_PAPER = "pt_BR.UTF-8",
        LC_IDENTIFICATION = "pt_BR.UTF-8",
        LC_TELEPHONE = "pt_BR.UTF-8",
        LC_MEASUREMENT = "pt_BR.UTF-8",
        LC_TIME = "pt_BR.UTF-8",
        LC_NUMERIC = "pt_BR.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.15.67-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=33da784c-6400-4145-99e3-93bc3c7463b2 rw [email protected]
    quiet
    cryptdevice=UUID=5b16040e-5d39-4cd0-80b7-423ffe50eaff:luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
    root=/dev/mapper/luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: LXQt v: 1.1.0 tk: Qt v: 5.15.6 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: INTEL model: HM65DESK serial: <superuser required>
    UEFI: American Megatrends v: 4.6.5 date: 02/23/2019
CPU:
  Info: model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 971 high: 1296 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 937 2: 837 3: 814
    4: 1296 bogomips: 21551
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-08) arch: Maxwell code: GMxxx process: TSMC 28nm built: 2014-19
    pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1381 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1360x768 s-dpi: 90 s-size: 384x300mm (15.12x11.81")
    s-diag: 487mm (19.18")
  Monitor-1: HDMI-0 res: 1360x768 hz: 60 dpi: 49
    size: 708x398mm (27.87x15.67") diag: 812mm (31.98") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
    class-ID: 0403
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403
  Sound Server-1: ALSA v: k5.15.67-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.78 TiB used: 592.46 GiB (20.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 55.9 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter>
    rev: Sb10 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000NM0053
    size: 2.73 TiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: G00A scheme: GPT
Partition:
  ID-1: / raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 164.05 GiB
    (29.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
  ID-2: /boot/efi raw-size: 5.59 GiB size: 5.58 GiB (99.80%) used: 240.8
    MiB (4.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 164.05
    GiB (29.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
  ID-4: /var/log raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 164.05
    GiB (29.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
  ID-5: /var/tmp raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 164.05
    GiB (29.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.79 GiB used: 710.8 MiB (18.3%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A gpu: nvidia temp: 29 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
Info:
  Processes: 238 Uptime: 18m wakeups: 0 Memory: 3.79 GiB used: 1.28 GiB
  (33.8%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: 1803 pm: pacman
  pkgs: 1776 libs: 545 tools: octopi,pamac,paru pm: flatpak pkgs: 27
  Shell: Bash v: 5.1.16 running-in: qterminal inxi: 3.3.21

Alright, so I did a simple garuda update -a as usual, grub updated and then I rebooted.
I could get to grub, but the Garuda entry there couldn't boot up and showed me an error I did not take notes on. I thought "oh well, snapshot it is then" and successfully booted into a snapshot, it prompted me to restore and reboot and so I did.
Except
All entries on Garuda now don't boot, main kernel, second kernel, or snapshots. All give me this same error:

Loading Linux linux-lts ...
452: out of range pointer: 0xcc088520
Aborted. Press any key to continue. _

Ofc small variations on the message, for example for each snapshot I noticed a different pointer, but it always starts with 0xcc, so it's all under the same trouble I guess.

After I press the key I fall back on my secondary system, which is Zorin, no troubles on that part, so at least my pc is usable until Garuda's back. Haven't tried Zorin directly from grub tho.

I found this post on the forum

But seems like the problem there was with timeshift? I'm using snapper, so I don't know if the fix is the same or even the trouble.
Should I give it a try?
Or should I do something else?

But seems like the problem there was with timeshift

That was a separate issue.
I fixed the pointer error by using chroot and following these steps

2 Likes

Maybe?

Summary

seth
Member

Registered: 2012-09-03
Posts: 33,830
[SOLVED] Can't boot (452: out of range pointer: 0x86cb7020) / Kernel & Hardware / Arch Linux Forums

Re: [SOLVED] Can't boot (452: out of range pointer: 0x86cb7020)

This is a filesystem/drive issue.
Could be a too aggressive trimming strategy or issues w/ the filesystem (any btrfs or f2fs over there?) or a power loss during the update.

1 Like

Hmm no power loss, I also didn't do any trim? I only have Garuda as btrfs and I don't really know what f2fs is.

To be exact, I deleted 2 snapshots from january with the BTRFS tool from Garuda, it was before rebooting after updating. Would this be the problem?

I had a similar problem where after updating grub I went back a snapshot and then restoring the snapshot gave me a similar message.
The fix for this is chrooting into your system and reinstalling grub.
Try to follow this tutorial:

3 Likes

Ok, I'm trying to do the chroot thing, but my garuda partition is encrypted and I can't mount it.

I've found this explanation on reddit: https://www.reddit.com/r/archlinux/comments/nv297r/cant_chroot_into_encrypted_partition/

But here are my issues with that solution:

cryptsetup luksOpen /dev/sdb1 GarudaInstalled
Device /dev/sdb1 does not exist or access denied

After that I tried mounting the partition through Thunar and as it did mount properly I thought it would be nice to give a try, mounted or unmounted

sudo mount /dev/sdb1
mount: /dev/sdb1: cant find in /etc/fstab.

sudo mount /dev/mapper/luks-5b17384e-6g96-4fr0-80b7-423ffe50eaff
mount: /dev/mapper/luks-5b17384e-6g96-4fr0-80b7-423ffe50eaff: cant find in /etc/fstab.

Fair enough, that's probably because it was mounted inside the live system so it could not be found. But how come I can't open it with cryptsetup? What should I do?

Update: from Zorin, with udisksctl unlock -b /path/to/disk/partition I was able to unlock the partition, but turns out Zorin doesn't have chroot tools.

I'm gonna find out now if garuda have udisks2 and if that works there as well. Wish me luck.

Update on the matter: I was able open the encryption with gparted, then I successfully chrooted and reinstalled the grub

Thank you all so much for helping me out and maybe sorry because when I panick I get a bit dumb? And I panicked a LOT today xD
Thanks again, wish you all a wonderful end of the week!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.