Help Garuda fails to boot after today's update

System:
Kernel: 6.1.35-x64v1-xanmod1-1-lts arch: x86_64 bits: 64 compiler: gcc
v: 13.1.1 parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod-lts
root=UUID=3f34e6eb-f8f5-4bec-a1c6-3bfe5d27ab86 rw single
rootflags=subvol=@
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Micro-Star product: MS-7C24 v: 1.0
serial:
Mobo: Micro-Star model: Z390M-S01 (MS-7C24) v: 1.0
serial: UEFI: American Megatrends v: 1.60
date: 12/30/2019
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M275/M280
serial: charge: 55% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xF2
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2949 high: 3600 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 1188 2: 3600 3: 3600
4: 873 5: 3600 6: 3600 7: 3600 8: 3112 9: 3600 10: 3600 11: 1622 12: 3600
13: 800 14: 3600 15: 3600 16: 3600 bogomips: 115200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: Gigabyte driver: nvidia
v: 535.54.03 alternate: nvidiafb,nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 10de:2184 class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 157 s-size: 621x341mm (24.45x13.43")
s-diag: 708mm (27.89")
Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 157
size: 621x341mm (24.45x13.43") diag: 708mm (27.89") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX
1660/PCIe/SSE2 direct-render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
API: ALSA v: k6.1.35-x64v1-xanmod1-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 10.99 TiB used: 7.64 TiB (69.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Seagate model: BarraCuda Q5
ZP2000CV30001 size: 1.82 TiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 tech: SSD serial: fw-rev: SU5SH017
temp: 26.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: TeamGroup model: TM8FP4002T
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: fw-rev: VB421D65 temp: 34.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3000DM007-1WY10G
size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5425 serial: fw-rev: 0001 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-00WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial:
fw-rev: 1A01 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD40NMZW-11GX6S1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: fw-rev: 1018 scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 vendor: SanDisk model: USB 3.2Gen1
size: 28.67 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial:
fw-rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 1.86 TiB size: 1.86 TiB (100.00%) used: 1.59 TiB (85.2%)
fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 1.59 TiB (85.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 1.59 TiB (85.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 1.86 TiB size: 1.86 TiB (100.00%)
used: 1.59 TiB (85.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
ID-1: swap-1 type: zram size: 31.28 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 32.0 C pch: 56.0 C mobo: 31.0 C gpu: nvidia
temp: 40 C
Fan Speeds (RPM): fan-1: 414 fan-2: 646 fan-3: 243 fan-4: 0 fan-5: 0
gpu: nvidia fan: 0%
Info:
Processes: 418 Uptime: 1m wakeups: 3 Memory: available: 31.28 GiB
used: 3.96 GiB (12.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 2139 libs: 587 tools: gnome-software,octopi,pamac,paru Shell: Bash
v: 5.1.16 running-in: lxterminal inxi: 3.3.27
Garuda (2.6.16-1):
System install date: 2023-04-29
Last full system update: 2023-06-10
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut nvidia-dkms
Windows dual boot: No/Undetected
Failed units: fancontrol.service

Please help i cannot normally boot my Garuda installation any more after todays update, and restoring a snapshot creates a grub error. The only way i can get into my installation is through recovery mode.

I am assuming that the latest update had a grub update and hence going back a snapshot renders you unable to boot with a message like “452: out of range pointer” or something similar.
The fix for this is chrooting into your system and reinstalling grub.
Try to follow this tutorial:

And then hold off on updating and provide us with the update logs first.

cat /var/log/pacman.log | tb

This will give you a link post it here. Your system looks a pretty recent install so your logs shouldn’t be particularly big to require filtering.

4 Likes

Thanks i did already fix the grub issue, but Garuda wont boot. It hangs at loading ramdisk. i installed another version of Garuda on a free partition and let it update and the same issue occurred.

Here is the link
https://termbin.com/e1ub

i hope this helps.

@Jeshu

I had the same problem booting up this morning. I noticed there was an update to SDDM last night, and this thread: Boot hang after update mentions about hanging at the same point. The suggested solution of removing "splash" from the boot options has resolved it for me. Hopefully, an update to SDDM or Plymouth will come soon to properly resolve this.

3 Likes

i'll try it right away

1 Like

I am guessing that log was too long for termbin to handle :sweat: This only has the update logs from april. Let's try this

grep '2023-06-10' /var/log/pacman.log | tb

Since according to your inxi your last system update was 2023-06-10 I wrote that in grep command if the update date was something else for you please ammend it accordingly in the grep command.

I'm having the same issue. None of the snapshots allow me to boot. I've managed to do it only recovery in mode. Also my systemctl --user is showing that app-autorandr\[email protected] and [email protected] are failed. It seems that second one is BTRFS Assistant Snapper check.

Also, I'm having systemd[4595]: Failed to start Powerdevil. and org_kde_powerdevil[307584]: org.kde.powerdevil: KDE Power Management System init failed! journal errors.

When I make garuda-update everything is normal, but if I restart it won't boot again. Only in recovery mode in one of the kernels.

Last full system update: 2023-06-25 ↻

1 Like

Same issue here. Hangs at Loading initial ramdisk.
One of my pre-update snapshots booted and I am typing this from it.
So now what?

Search for @petsam and chroot in forum search upper right, please.

Please don’t misunderstand, but it has been repeated over and over again so many times in the forum. If you had opened your own thread, you would know that we ask you to start your own search before asking.

4 Likes

Hmm... Since no one here was providing an update log I decided to take matters in my own hand and update my system and see what's happening. Which surprisingly resulted in nothing... The system updates normally and I could reboot my system as always. Which could result in either of the two scenarios:

  1. The package that was causing the issue causing the issue has been fixed upstream, or
  2. I simply don't have the package that's causing this issue installed.

I would request anyone facing this issue to provide us with the update logs when they roll back a snapshot and chroot to fix their grub.

grep '2023-06-25' /var/log/pacman.log | tb

change '2023-06-25' here with whatever date you updated your system on.
Please post this log along with your inxi when you post in this thread. :slightly_smiling_face:

4 Likes

I had the same issue, I’ve just put sddm in my ignorepkg parameter in pacman.conf in the interim till it is resolved. I also had to go back to a snapshot, I realised it was sddm when I noticed all of my peripherals were being accessed by the linux kernel on boot due to the lights flickering.

Honestly a lot of login user applications don’t run well for me due to me using a 5120x1440 resolution on an NVIDIA card. The open-source drivers REALLY DON’T LIKE this resolution. But that is off topic

Hmm... that's strange because as I said above I updated my system today and could access the system normally. The only thing that's different from stock garuda on my system is that I use plymouth instead of plymouth-git. So, I thought that's the issue since that's for whom the splash kernel parameter is for additionally that's the package that's been updated along side sddm recently.

╰─λ pacman -Qi sddm
Name            : sddm
Version         : 0.20.0-1
Description     : QML based X11 and Wayland display manager
Architecture    : x86_64
URL             : https://github.com/sddm/sddm
Licenses        : GPL
Groups          : None
Provides        : display-manager
Depends On      : qt5-declarative  xorg-xauth  xorg-server  ttf-font
Optional Deps   : None
Required By     : sddm-kcm
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 4.51 MiB
Packager        : Antonio Rojas <[email protected]>
Build Date      : Friday 23 June 2023 10:22:10 PM
Install Date    : Sunday 25 June 2023 09:13:06 PM
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Search for what? I came here and found my topic right away.
Help Garuda fails to boot after today’s update

Sorry I'm not a garuda developer. Don't know what @petsam is and how chroot fits in.
So now what? Wait for a fix confirmation?

Here is my grep output from restored snapshot:
https://termbin.com/offy

[:mag:] × inxi
CPU: quad core Intel Core i7-6700K (-MT MCP-) speed/min/max: 3430/800/4200 MHz
Kernel: 6.3.7-zen1-1-zen x86_64 Up: 12m Mem: 4065.6/31973.2 MiB (12.7%)
Storage: 4.58 TiB (6.4% used) Procs: 284 Shell: fish inxi: 3.3.27

From what I understand this is the first big update to SDDM in years and it coincides with KDE6 upstream updates.

Me too.

petsam is a Garuda Linux admin, like me, and wrote the tutorial I pointed out.

chroot makes it possible to update your system and repair your grub.


Again for you.

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:

garuda-inxi

Refusing to post the output of the required “garuda-inxi” on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki’s, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum’s search engine and on the web. For in depth information on how to search for answers to Linux issues effectively, read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.

4 Likes

Thanks! Garuda boots now that i removed the splash from my command line. Right at the beginning of the booting process i see an error line flash past but i can't read it.

About the link i updated yesterday when the trouble occurred, but i tried restoring it with the 2023-06-10 snapshot that is why it might think that was the last one. i give you the 2023-06-25's details
https://termbin.com/34ag

Did you try and remove splash from your command line that fixed it for me.

Boot Garuda through your recovery option (press CTRL D to complete loading)

Run Garuda Welcome and Choose Garuda boot option. (Enter pass word)
The kernel command line has the word 'splash' right at the beginning of the command line, delete only that word, save and reboot, Garuda should boot fine again.

1 Like

FYI: There is a parallel thread here as well (System wont start after update - #8 by Kottonballs) that addresses splash and plymouth.

[2023-06-25T08:18:19+0800] [ALPM] upgraded plymouth-git (22.02.122.r178.ga5eda165-1 → 22.02.122.r180.gb1d5aa9d-1)

Yeah it’s plymouth-git that’s responsible for the errors everyone is facing. Try switching from plymouth-git to plymouth following this.

4 Likes

i tried doing that but it came up with an error saying that mkinitcpio wasn't installed but after i installed that it came up with an error saying mkinitcpio.d has no preset.

i also tried installing plymouth instead of plymouth-git but it made no difference.

no splash for my kernel by the looks of it