Hdd ownwership change

Hi have come across an issue. My 2TB refuses to let me store things on it as it used to.

have tried sudo chown -HR bruce /mnt/wwn-0x50014ee25b773f61-part1, /mnt/wwn-0x50014ee25b773f61-part1 is the mount point.

i get operation not permitted

any suggestions please

P.S this has only happened in the last couple of days

this is my fstab

#/etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
/dev/disk/by-uuid/FCA2-762E /mnt/FCA2-762E auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Bruce\040#3 /mnt/Bruce\040#3 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Please post garuda-inxi for support requests.

Hmm, that does not look right. Please post the outputs of:

lsblk -f
ls /mnt/
1 Like

When posting command line commands, post complete input and output from terminal, because you may have done a typo mistake, so we can check.

What you try to access and chown is not in fstab. Can you give more details on your issue and what exactly you want to achieve and usage?

2 Likes

If you mean the escaped characters, it's probably generated by a program like Gnome Disks, or KDE Partition Manager, to mask the spaces that are not allowed.
Use this to see the resulted line:

printf "LABEL=Bruce\040#3 /mnt/Bruce\040#3"
LABEL=Bruce #3 /mnt/Bruce #3

:wink:

3 Likes
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                    0   100% /var/lib/snapd/snap/gtk-common-themes/1534
loop1
squash 4.0                                                    0   100% /var/lib/snapd/snap/libreoffice/254
loop2
squash 4.0                                                    0   100% /var/lib/snapd/snap/gnome-3-38-2004/106
loop3
squash 4.0                                                    0   100% /var/lib/snapd/snap/snapd/15904
loop4
squash 4.0                                                    0   100% /var/lib/snapd/snap/bare/5
loop5
squash 4.0                                                    0   100% /var/lib/snapd/snap/qt5-core20/10
loop6
squash 4.0                                                    0   100% /var/lib/snapd/snap/core20/1494
loop7
squash 4.0                                                    0   100% /var/lib/snapd/snap/gnome-3-38-2004/99
sda
`-sda1
vfat   FAT32 Bruce #3
79A5-C383                               1.1T    39% /mnt/Bruce #3
sdb
`-sdb1
btrfs              1b6c0a30-a1a9-4674-ab29-9bd72b32b4fd   70.9G    62% /home
/var/cache
/var/log
/root
/var/tmp
/srv
/
sdc
`-sdc1
vfat   FAT32 Bruce #2
FCA2-762E                             462.7G     1% /mnt/FCA2-762E
sr0
zram0
[SWAP]
drwxr-xr-x - root  1 Jan  1970  Bruce #3
drwxr-xr-x - root  1 Jan  1970  FCA2-762E
drwxr-xr-x - root 20 Jun 16:15  wwn-0x50014ee25b773f61-part1

this disk is storage for movies and important docs.

cant save to the drive

@anon49420796
Please read.

1 Like

FAT32 does not support file ownership, that is why you are getting an error when you try to change it.

Based on certain evidence, I am guessing you do not historically mount your drives with the terminal. Since something changed recently as you mentioned, I wonder if you have seen this solution? Hard Drives No Longer Mounting On Startup - #8 by BluishHumility

That person also lost their Automount settings when they took the update to Plasma 5.25 (I'm only guessing on your Plasma version, since no garuda-inxi).

2 Likes

thanks to all. had a major system crash and had to get new computer so this issue is now fixed

Whoa, that was a major crash!
Welcomed one maybe as it fixed the issue. :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.