Hard Drives No Longer Mounting On Startup

I have been using Garuda for a bit more than a month now and have grown quite fond of the OS, though as the title states, my hard drives are, for whatever reason no longer auto-mounting on startup when they were just a few days ago. I can open them in Dolphin and then I can access them just fine. This isn't a super big issue but given that I am somewhat lazy and would prefer to not have to make sure that they get mounted myself, I'd prefer to have this fixed.

I'm new to the forums and am unsure just where exactly to post this, thus far I've tried running sudo mount -a, which doesn't seem to mount them either. According to a friend, my fstab file appears to be fine but I've been using Linux for less than a year, so I'll take his word for it. All the same, any help is much appreciated.


Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9cb34755-a24b-463c-9215-498d1e3ea350 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
Desktop: KDE Plasma v: 5.25.0 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Micro-Star product: MS-7A34 v: 1.0
serial: <superuser required>
Mobo: Micro-Star model: B350 TOMAHAWK (MS-7A34) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.M0
date: 01/23/2019
Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
microcode: 0x8001137
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2929 high: 3216 min/max: 1550/3200 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2820 2: 2871
3: 2722 4: 2839 5: 2762 6: 3054 7: 3164 8: 3065 9: 2840 10: 3216 11: 3082
12: 2721 bogomips: 76791
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Sapphire driver: amdgpu v: kernel arch: RDNA 1
process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,HDMI-A-1 empty: DP-1,DP-3 bus-ID: 1d:00.0
chip-ID: 1002:731f class-ID: 0300
Display: wayland server: X.org v: with: Xwayland v: 22.1.2
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
d-rect: 3840x1080 display-ID: 0
Monitor-1: DP-2 pos: primary,left res: 1920x1080 size: N/A modes: N/A
Monitor-2: HDMI-A-1 pos: right res: 1920x1080 size: N/A modes: N/A
OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 13.0.1 DRM 3.46
v: 4.6 Mesa 22.1.1 direct render: Yes
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 3-2:2 pcie: gen: 4 chip-ID: 1038:12ad speed: 16 GT/s class-ID: 0300
lanes: 16 bus-ID: 1d:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 21:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: SteelSeries ApS Arctis 7 type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 19:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp25s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8812AE 802.11ac PCIe Wireless Network Adapter
vendor: D-Link System driver: rtl8821ae v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 1f:00.0 chip-ID: 10ec:8812
class-ID: 0280
IF: wlp31s0 state: down mac: <filter>
Device-3: D-Link 802.11 n WLAN type: USB driver: rt2800usb bus-ID: 3-4:3
chip-ID: 2001:3c25 class-ID: 0000 serial: <filter>
IF: wlp32s0f3u4 state: down mac: <filter>
Local Storage: total: 5 TiB used: 2.33 TiB (46.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD30EZRZ-00GXCB0 size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: CC38 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A02 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Crucial model: CT1000MX500SSD4
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 023 scheme: GPT
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 542.06 GiB (58.2%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdd1 maj-min: 8:49
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 542.06 GiB (58.2%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 542.06 GiB (58.2%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 542.06 GiB (58.2%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.3 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 56.0 C
mem: 64.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 590
Processes: 359 Uptime: 49m wakeups: 0 Memory: 31.3 GiB
used: 6.25 GiB (20.0%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 2026
lib: 557 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.18
Garuda (2.6.4-1):
System install date:     2022-05-10
Last full system update: 2022-06-20
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Welcome @Quade :slightly_smiling_face:

If you can post the output of lsblk -f and cat /etc/fstab I'm confident we can help you crack the case.

1 Like

Do you mean that before opening your drives, you need to check or do something?
What you say does not make a lot of sense (technically). There is no need to mount a partition at the start of your system, if you can open them in Dolphin without doing something else... :thinking:

1 Like


To give an example, when I launch Steam, it won't display anything that's not on my SSD as installed. When I open Dolphin, they show up as connected but are missing the bar that indicates the storage space and the orange square icon, thus I assume they are not mounted. I have to mount them before I can use them, which Dolphin does just fine for me. Once I've done that and restarted Steam, everything works perfectly fine.

Prior to this, when Steam launched it by default had everything showing as installed and there was no need to do this method to get it to work as desired.

Let me guess: the NTFS drive is the one that is misbehaving. :smirk:


One of them. Anything that isn't my SSD, which has Garuda installed on it has this issue actually.

The fstab entry lists out all devices that should be automatically mounted by your system when you boot. Right now, the SSD with Garuda on it is the only drive on your fstab entry (aside from your EFI partition). There are multiple entries, but that is because each mount point gets an entry and snapshots take a few mount points. If you compare the UUID of the entries in the file you can see they are all the same.

I am guessing that your devices have been getting mounted automatically for you through your KDE settings, since nothing is set up in fstab. Go to Settings -> Removable Storage -> Removable Devices and check what Automount settings are checked; to produce the behavior you are describing, the "On Login" box will have to be checked for the respective devices.


Yeah, none of these were checked. I'm assuming this might be the cause. I'll test and see here.

Yep, exactly it. Thanks for the guidance.

Your multiple installed Linux operating systems situation says you qualify as one of the forum experts on multi-boot problem post scenarios. Now we know who to send 'em to. MUAHAHAHA!
:wink: :smiley:


:rofl: Don't look at all those partitions!! :shushing_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.