Grey menubars corrupted

I figured I'd give Garuda a go, and used an image I downloaded a month or two ago. Finally got the non-free install to work fine, and was happy, but decided to run a pacman update. During the update a heap of "transfer failed, less than 1B/s" errors came up, but the system completed the update and worked ok. However at next power on, the desktop shows the top and bottom 1/3 of the desktop as grey borders with no interaction (and occasionally what looks like mpeg frames of the desktop scattered around it like corrupt desktop snippets). The centre 1/2 still works but you can't interact with what's "behind" the grey bars even though you can move a cursor over it.

Using the snapshot from before the update, it works fine again, but trying to repeat the update process to find anything broken yields nothing but the system being up to date.

Any ideas where to begin?

I would try to boot into console mode to fix your problem (use 4 instead of 3 in Grub entry)

Once you are in the console use reflector to generate a new mirrorlist:

Then attempt to run sudo pacman -Syu again

After updating if there is still problems, you can attempt a complete reinstall of all system packages:

Finally, just to confirm, what version of Garuda Linux are you using? Issues of this sort can sometimes happen with Latte dock on KDE.


I am not native English speaking, so I am not sure if I understand correctly.
You have restored a snapshot and updated packages with no problem.?

Another note about how real facts like system info is preferred from a substantial description. Here we go to another level of arithmetics.
1/3 + 1/3 + 1/2 = 1
:thinking: :grin:


That is very cursed :grin:

1 Like

OK I deserve some of that :joy:
I started off with 1/3rds and then realised it was more like 1/4 + 1/2 + 1/4 but I was too tired to go back.

I booted from an old snapshot, which worked. But as soon as I update again it fails again.
I tried reflector but it tells me it failed to retrieve mirrorstatus data.
I can log in fine via ctl+ alt+F2 etc and this time pacman updates fine but the fault still exists.

Pacman fails on every mirror, because it isn't picking up wifi for some reason. I'll try to sort that.
I'll keep digging.

What Iso did you use

As always.


and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.


After restoring

sudo update-grub

reboot, then update. Now post the inxi ^^


Wait was that kde-multimedia by any chance it is a latte error click on the desktop and type


Then in konsole type

killall latte-dock
1 Like

You have to watch for errors in the update process and correct them.
Find which mirrors are good and use them.

most probably.

1 Like

I'll try to collate some info as requested above. The difficulty is getting the terminal output off the machine, especially when it is buried in 200 lines of output, on a machine which has no active connection and I have no spare machine nearby (hence posting by phone) - I'm not going to write out the CLI output by hand, and I'm not going to report it as a bug until I've proved it wasn't my fault first.

In the mean time I removed latte-dock-git, binned the config files associated and the reinstalled and got half of it back without the error but am now missing the top bar. I may just start from scratch at this point as its not worth the time faffing, I've no vested interest in trying to fight this one through.

Distro looks nice though.

Anyways, latte-dock can be used successfully, if you want. Just create a new layout. You may start latte with default layout and clean cache.

latte-dock --help
1 Like

Sorry new ked-multmedia iso with fixed latte by next week :sweat_smile: