Garuda linux stuck in first boot (loading screen)

Hello.
ı planned to use dual boot (windows 10-garuda linux). I dowloaded garuda-dr460nized-linux-zen-211028 iso and created bootable usb with balenaEtcher.ı have two m2 ssd (nvme2 samsung/ kingston a2000) . One already has windows 10 so ı installed garuda to another ssd (with free driver option) and setup finished succesfuly but when ı restarted the pc garuda is stuckking in loading screen. In some topics ı saw that ' Disable Intel-VMD in the BIOS ' but i am using Asus tuf gaming f15 and my bıos version 306 so ı dont have option for disabling intel-vmd.

-nvidia rtx 3050ti
-intel 11th gen i5

-fast boot disabled
-secure boot disabled

setfont: KDFONTOP: Function not implemented
mount: /new_root: can't find UUID=99f10471-47b0-452d-81c3-7f8104784b81.
You are now being dropped in an emergency shell.
sh: can't access tty; job control turned off

Hi there, welcome!
I think you could try the following procedure:

  • use the USB and from there chroot into your system
  • run sudo micro /etc/mkinitcpio.conf
  • add the module vmd to the MODULES list
  • run sudo mkinitcpio -P to regenerate all initramfs
  • run sudo micro /etc/default/grub
  • add nvme_load=YES to GRUB_CMDLINE_LINUX line
  • run sudo grub-mkconfig -o /boot/grub/grub.cfg to regenerate the GRUB menu
  • reboot

If you don't know how to chroot, there is a tool for that in the live USB or a tutorial in the forum to do it "manually".

8 Likes

sorry , ı am new to linux so this question might be dumb. First ı am going to delete existing garuda and reinstall for this process,right?

No no
Keep what you installed.
This is only to let the kernel "see" your disks.
The USB was seeing them so was able to install.

1 Like

but garuda stays on loading screen and in chroot tutorial it says 'start a terminal '. How will ı start terminal ?

You have to boot from your live USB.
There you'll find a button to chroot (I don't remember by heart where) if you want to avoid the manual procedure.

1 Like

I booted from usb and listed my system partition , there is 4 partition which one is for garuda linux ?nvme0n1p1(fat32) /nvme0n1p2 / nvme0n1p3(ntfs) / nvme0n1p4(ntfs)

What is the output of fdisk -l?

I found :slight_smile:

1 Like

A reminder to help with your awesome helpfulness.
This of course loads immediately on boot completion.

Thanks for screenshot , i clicked to chroot button and this is the output
Is this correct?

grub-probe:error: cannot find a GRUB drive for /dev/sda1. Check your device.map
grub-probe:error: cannot find a GRUB drive for /dev/sda1. Check your device.map
==> Mounting (Garuda_Linux) [/dev/nvme1n1p3]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]
 --> mount: [/mnt/root]
 --> mount: [/mnt/srv]
 --> mount: [/mnt/var/cache]
 --> mount: [/mnt/var/log]
 --> mount: [/mnt/var/tmp]

and also when ı run this command

sudo grub-mkconfig -o /boot/grub/grub.cfg

ı am getting this output

/usr/bin/grub-probe: error: failed to get canonical path of `overlay'.

I don't think the chroot was correct.
Maybe you could try to open a terminal from the live USB and use the tutorial.

i tried to make chroot manually and ı got this output. What should ı do ?

Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.
/usr/bin/grub-probe: error: cannot find a device for / (is /dev mounted?).

When do you get this, when you enter

sudo garuda-chroot /mnt/broken/@

?
That one is the last step to chroot, you don't need to install the bootloader.
After that, you should continue with the bullet points in my first post.

There's a proper fix for this coming in mkinitcpio 31, and that will be included in a future installer image.

Until then, you can use a chroot to edit the necessary files on your installed system:

Please revise the installer to add vmd to modules - #5 by ricklinux - General system - EndeavourOS

5 Likes

yes ı got this error when ran the command you mentioned. ı will pass this step.

It looks like it is getting closer :blush:

Although I see a lot of stuff in there other than the install/block: include vmd module by @nl6720 in #60 that we need here... (I mean, I hope everything will be OK with the new release)

5 Likes

When do you think it will be ready for use? ı can wait them :slight_smile:

Soon™ 

5 Likes