Garuda KDE Ryzen 3500 issues?

Hello -

I have tried to install this distro - this is my first Arch experience. The live USB portion works great and this is how I am using and typing currently. When I install on this new HP Elitebook with Ryzen 3500u and Radeon Vega graphics (it is a 745 G6, 8GB model) it hangs after a successful install.

I have tried a lot of other Debain based distros to no avail as well as Fedora - all hang after install.

Live USB runs and works great - I would like to get it installed and working if at all possible. Could anyone help guide me to get around the hang on boot after install?

Do you dual-boot with windows?
Disable secure and fast boot.

and

:slight_smile:

2 Likes

Thank you for the welcome! No dual boot, secure and fast boot both already disabled.

Hangs right after these two lines -

Loading kernel Linux-tkg-bmq ...
Loading initial Ramdisk ...

1 Like

This phase is really looong. How long have you waited?
Leave it and go for coffee... :man_shrugging:

2 Likes

Really? On an SSD even? Good advice I’ll await it and report back!

This would seem to indicate your laptop model has an issue running Linux in general (not Garuda specifically).

Have you performed extensive online searches relating to your problem?

If these other distros will not install properly either, then I would assume there must be a fair bit of information regarding this issue on the net.

Please post some relevant links that cover your models issues that you think could provide insight to your problems installing Linux.

Please post detailed system specs from the live environment:

inxi -Fxxxza 
1 Like

I just went through this with an HP 745 G6, Ryzen 5, Vega graphics, 256GB SSD. I tried (from memory) Ubuntu 20.10, Ubuntu Cinnamon Remix, Mint Cinnamon, Mint xfce, Sparky, Linux Lite, Zorin Lite, and MX Linux. The farthest I ever got was with vanilla Ubuntu "Groovy Gorilla". It ran until I did the first update/upgrade. After that it wouldn't even boot. There's definitely a graphics issue, as I had to install "testing" video drivers from some PPA I never heard of just to get 1080p support. I asked around in a couple of forums. The advice I got was to wait for Linux to catch up. Annoying, as this will soon be my company-issued laptop at work when we trade in our old HP 640s, and I hate using windows. (I'm the IT inventory guy, so I got to play with the HP 745s before anyone else). One archived forum post said vanilla Debian will run on it. I didn't try it so I don't know if it's true.

1 Like

@fecklesstech did you get a chance to test different kernels such as the linux-mainline.

Yes I have done extensive research on this and you are right that it has issues running linux in general - where Garuda seemed different is that I was able to consistently get it to use the live USB without issues, which is why I then installed it on the SSD directly. That being said I ran across the issue that I mentioned above which is why I then posted - if you are just going to point to search online for my answer why even have a community forum?

I will just move on and await Linux to catch up and or find another distro that will get as far as this one has and as far as install.

Yep - same machine - exact same machine and I did as you did and ran the gambit of distros in attempt to find something that would work. I can tell you that after I was able to get into the Garuda environment and run the update 'sudo pacman -Syu' I can consistently get into the OS each time as long as I choose enter when the splash screen comes up, if I let it timeout and make the choice on it's own it hangs every time no matter how long I wait.

No. I didn't know kernel swapping is even a thing in Ubuntu and I was unaware of mainline until I Googled it a minute ago. I did try Manjaro (I failed to list that one in my earlier post) thinking that a rolling release will have the latest drivers. It didn't work. Oddly enough, many distros will boot from a USB stick on the HP 745 and run in a live environment. They only fail after what seems to be a successful bare metal install. Failure can be eternal boot, or blank display on first reboot after a system update/upgrade.

2 Likes

I was also able to get a few other distros to boot live but not consistently - I updated my BIOS firmware also and that did not help either. I am glad that I am not the only one that is dealing with this - I thought about selling this laptop and getting something else....

I would send you a private message to stay in touch as we travel this path but I am not yet allowed to do that on this forum.

Yes! Ubuntu 20.10 seemed to be working for me. I got the 1080p monitor working normally by changing the drivers to a "testing" PPA (don't have that link handy--sorry). If I remember correctly I even made it through an upgrade cycle. I started installing my favorite packages and informed the only other Linux nerd at work that Ubuntu would run on the G6--then it died. Just wouldn't boot. I had kind of given up until now.

Because we have many users who do not research their issues in the least before opening a help request. Asking them to provide links encourages users to do some research for themselves and teaches them some degree of self sufficiency.

We attempt to help all users here, but we also try to encourage them to learn some problem solving techniques and a degree of self sufficiency.

While we try to be helpful, we expect users to develop there own problem solving methods over time and to not be over reliant on our limited forum support capabilities. Users that simply rely on the forum to answer the most basic of questions without even searching overtaxes the forums support capabilities.

The other problem it creates is that complex issues that actually require support get drowned out by floods of trivialities that could be easily resolved with a minimal online search. So it is in your, and everyone else's interests to keep the forum clear of clutter so that real difficult technical support issues don't get buried by posts on how to change a wallpaper.

Can you understand our thought process on how we need to prioritize our support resources. Sometimes it's necessary to separate the wheat from the chaffe. To this end we've started to simply remove many of the posts that contribute nothing to the distro into back channels out of the main forum.

3 Likes

I am no graphics support expert (far from it), but I do have one suggestion. Perhaps try performing a chroot and install the linux-mainline kernel from the chroot environment.

I will leave it to others with better graphics troubleshooting skills to offer up further/better troubleshooting suggestions.

I can tell you if you like Garuda - so far it’s working for me. I am brand new to Arch as I usually use Debian and fedora so pacman etc is a new way of doing things and thus here I am attempting to learn again.

I’d be interested in your experience with Garuda on the 745 G6 - maybe we will fight this battle together lol.

Or I’ll just simply wait on Parrot to catch up. I tried installing that first as it’s my preferred OS to no avail.

Mint Cinnamon was able to run live and install but then the black screen of nothing showed up. I was able to alt-f2 and nano edit the /etc/default/grub file and add a “nomodeset” and get into the OS consistently each time - but then I couldn’t find a graphics driver to allow useable 1080 screen, I did also try updating kernels which also did not work.

2 Likes

https://wiki.archlinux.org/index.php/Pacman/Rosetta

3 Likes

Please read this stickied post for furtherance to your question:

While I have answered your question, you have ignored my question and not responded to my comments or suggestion. If you read my linked post you will see that this type of behaviour on our forum tends to get your help thread bumped down the priority list of threads to receive assistance.

So, to sum things up. Being critical of a mods requests (or advice), ignoring their questions or suggestions, or providing little feedback to their suggestions is not a good methodology for soliciting assistance from experienced users on our forum. Best to change your tactics if you expect support from Garuda support volunteers.

Good luck resolving your issue.

Thank you, I will give that read.

Maybe give me time to go hunt up all the links that I read prior to trying Garuda and then a bit more time to address the questions you asked after abrasively answering them. I understand you are support volunteers which I value and appreciate, however friendly must be a subjective word. I already read your link to new people prior to posting. And by your statement - you don’t wish to help users you would rather them become self reliant and only ask when this has been exhausted - I can’t meet both of your requirements - which would you like? Go search more and then report back with all my links that go with models if I am unable to find the answer or keeping asking for help?

Currently I am able to get into the OS consistently after being able to do an update.

If you read above - I’m not the only person that has seen this type of issue from Linux and I had high hopes after finding Garuda.

Just as you want “new” members to be polite and use good tactics - those of us asking for help would like the same in return.

This would be much much different if you had a very quick solution to the question that I asked that many people post - as an example -

“Man I am loving arch and this flavor (Garuda) thank you making it, how the heck to I update it?”

And you have to answer - “open a terminal and type “Sudo pacman -Syu”, choose Y when it asked”

This was not the type of question I asked - hanging after install when live worked just fine confused me as I would think it would use the same kernel and driver set when it installs. I also might think that the team would be highly interested in solving this issue that is seen with the newer Ryzen and Radeon mobile.

I understand that my position is not what you are used to receiving when interacting with “new” members, and that my “tactics” will get me ignore by you, but I ask that you reread how you addressed the first time and how you yourself would respond when you have spent a lot of time researching on your own.