Garuda Installation Failed

It's not there in advanced either

Secure boot is disabled btw.

EDIT: I've reached the maximum message limit. Can I contact u some other way? And yeah, I've checked everything. @Stroke_Finger
EDIT2: Pls tell me where
EDIT3: @SGS Thanks for the consideration! I'm still unable to reply as I'm a new user, but no worries.


OK, so here's what I did. I booted into that. Connected to wifi. Location to Kolkata. English (US) keyboard.
For partitions, I selected "Erase disk". Went through summary and hit install.

Install process works fine till the "Configure the hardware" part where it freezes for a 5-10 min at 79% and then shows that error.
EDIT4: Nope. Still not working. It's fine.. Ig we can sort this out tomorrow :wink:

You've gone through each setting and checked them all?

Edit - I found it on an internet search for your laptop! As I said - research!


I changed to TL1, try again :slight_smile:



The boot list on the right-hand side indicates you are booting in UEFI mode.

You should go through the installation one step at a time, noting down your choices at each stage, and then providing details if and when a step fails.


Try log out - log in to forum.


(As sent in DM in reply to OP)

As @jonathon stated in his post, UEFI is selected on your rig, so perhaps there is another problem.

Have you tried a different USB pendrive?

Have you ensured the destination drive is completely wiped?

You mention Rufus and Balena Etcher. Personally, I had better results with Rpi-Imager, you may want to try it yourself. See this thread for more options - Another imager option

At the end of the day, the people here give of our spare time, for no cost. Our families, work, health and jobs, must come first, which limits our time.

You must do your part, by thorough preparation, documenting each stage of your process thus far and at which stage fails/successes occur.

A Garuda distro is downloaded, but the second you install on your rig, it becomes your distro. This means your responsibility - it's completely different to Windows. Many do not expect this, because they did no prior research and 'liked the look of it'.

Garuda is based on Archlinux - a leading-edge distro...Garuda is bleeding-edge, so is not for everyone, by it's very nature.

Only you can assess your own and your rigs capabilities. Think long and hard and go from there.


Is this the last partitioning scheme that you used? Because it doesn't look right.

Assuming you're using UEFI boot, most modern motherboards do, the partitioning should look something like:

Partitioning table GPT
1st partition: 300-500 MB FAT32 with esp and boot flags ( no unallocated space before that )
Then the rest of the partitions for root, home etc and/or other distros.


The first time I installed garuda, I had none of these issues. Garuda came in a single partition in my USB, so I didn't think much of it. Now it splits it into 2 partitions. I realize that yeah, I need to do so much more research on my system, lol. I will try that other imager option too. Thanks!

I think the issue has to be something similar to that. As stated above, usually, there's only one partition in my usb when I flash it, but I got 2 this time.
I installed Linux Mint temporarily for now cause I literally have no OS to boot in rip, and that went well. It has the partitions that you mentioned. I tried resizing the linux mint partition and installing garuda in that, but same issue.
PS: Video of my BIOS

@Stroke_Finger @SGS @jonathon @subluminal
Thank you so so much for your efforts at helping me out! Dumb me thought I could do this in a few hours, not a few days, lol. I'm gonna try some stuff out in my spare time and do some more research before I make things worse. Thanks for giving your time!

EDIT: When I find the solution to this, I shall post here for future noobies like me.


No problem - we've all been in your spot at some time! (I'm still a 'fresher')


@Stroke_Finger @subluminal @SGS @jonathon @petsam @sammiev
I finally did it! Even though it took ages, it paid off!
The solution?
Solution (Sort of)

I tried the command that the author showed in the end.
efivar -l

It showed a bunch of dump files. So, I did what "the.ridikulus.rat" suggested.
rm /sys/firmware/efi/efivars/dump-* as root and rebooted.

After that, wiped the drive and tried installing and it worked!

Edit: Mentioned the commands here for convenience.


Glad you got it!!

Think of all the learning you've done :slightly_smiling_face:

1 Like

Yes. Learned much more than I expected lol. Thanks y'all!

Oh, wow. efivarfs dump files. I see those on my X230 - apparently it's due to bugs in the wifi driver.

Is this also breaking in Windows and preventing people from installing Linux? :thinking:


Is that your Realtek based adapter @jonathon

Are the errors present on the LTS kernel?


It's an oldish Intel one - I haven't found any obvious way to replicate the creation of the dump files. It filled efivarfs a couple of days ago, I cleaned them out, and it hasn't happened again yet.


Very strange, perhaps there was an Intel firmware update that caused issues.

OK, I'm investigating a possibility (with some help from grawity on #archlinux) - pstore.

There's a systemd service that might help clear out pstore dumps from the NVRAM; it's supposedly enabled by default but wasn't on my systems.

I'll see what happens now I've done a systemctl enable systemd-pstore .


A couple of hours of digging later, and FS#70140 : pstore can fill EFI storage, prevent machines from booting, and prevent bootloader installation


I did a clean install, so I don't have Windows now. But now, no more dump files are created. As for the installing Linux, I was still able to install Linux Mint. I still don't understand why though.

This should hopefully be fixed with kernel 5.11.9. Let's see how it goes - with any luck, no more of instances of this class of error!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.